Subject: [AVT] Summary for draft-ietf-avt-uncomp-video-02.txt

From: Ladan Gharai <[email-masked]>
Date: Wed, 12 Mar 2003 21:29:29 -0500

The following is a list of changes made to draft
draft-ietf-avt-uncomp-video-02.txt. 

1. the standard RTP header has been extended to 32bits.
2. 4:2:0 interlaced and progressive  packetization
3. addition of  4:1:1 color coding
4. separate time stamps for interlaced fields (to accommodate 
    reversing 3:2 pulldown) 
5. definition of required and optional SDP parameters
6. text on congestion control in the security considerations.

In addition to the changes, we would appreciate feedback on the
remaining open issues:  
 - should planar video be added to the draft or does it unduly 
   complicate the draft?
 - is the SDP parameter for colorimetry sufficient?
 - should time codes have independent representation? or are the
   RTP timestamps and RTCP SR timestamps sufficient?

thank you,
Ladan

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: [email-masked]
Date: Thu, 13 Mar 2003 11:14:32 +0100

ladan,

> - should planar video be added to the draft or does it unduly

Since I was the original proposer of this I feel it is my duty to kill it:-)

the purpose would have been to optimize the transport in terms of memory management
and data locality when processing the format (at both sender and receiver)
After analysis, this type of optimization is dependent on the application
and probably brings only marginal performance gain.

regards,

Philippe Gentric
Software Architect
Philips MP4Net
[email-masked]
http://www.platform4.philips.com