Subject: [AVT] H.264 payload spec: a question

From: Stephan Wenger <[email-masked]>
Date: Tue, 11 Mar 2003 12:38:43 +0700

Folks,

first of all I need to thank Magnus for his careful review.  Most of his 
points will be part of a -02 submission of the draft.  However, there are a 
few points that need more discussion, and one where I would like to get an 
opinion from the group:

Magnus:
>11. Chapter 6.3 The use of the F bit for aggregated units. Is it really 
>wise to set this bit as bad as soon as any of the NALUs part of the 
>aggregate is bad. This is useless information because you still needs to 
>go into the packet an look at each NALU to determine which is actually 
>useful. A cheap implementation that just throws away NALUs which is 
>damaged can't use this flag anyway. It could be useful it the flag is 
>instead defined as: "The F bit MUST only be set if all NALUs part of the 
>aggregate has their F bit set". That way the cheap implementation can 
>throw the whole packet as soon as it looks at the first bit.

To make it short: how do you set an error bit for an aggregation packet 
based on the error bits of the carried sub-packets.  Two options:

You logically AND the sub-packet error bits: this is what is in the draft
You logically OR the sub-packet error bits: this is what Magnus proposed

It's IMHO a minor issue, there are good arguments for going both ways, and 
I would be fine either way.
Opinions?

Thanks,
Stephan

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: [email-masked]
Date: Tue, 11 Mar 2003 14:52:20 +0100

Hi Magnus, stephan,

I agree this bit is not extremely useful

... and it is a better idea then to set it if all are discardable...

regards,

Philippe Gentric
Software Architect
Philips MP4Net
[email-masked]
http://www.platform4.philips.com

                                                                                                                                              
                                                          To:   [email-masked]                                                                  
                                                          cc:   Stephan Wenger <[email-masked]>                                        
                                                           (bcc: Philippe Gentric/MP4-SUR/CE/PHILIPS)                                         
                                                          Subject:    Re: [AVT] H.264 payload spec: a question                                
               Magnus Westerlund                                                                                                              
               <[email-masked]            Classification:                                                                     
               .se>                                                                                                                           
                                                                                                                                              
               Sent by:                                                                                                                       
               [email-masked]                                                                                                             
                                                                                                                                              
               11/03/2003 14:43                                                                                                               

Hi Phillipe and Stephan,

[email-masked] wrote:

>Magnus,
>
>I see your point but such a rule could make the F bit almost never used
>i.e. if all the packets are corrupted you are in bad trouble to start with (!)
>and otherwise the F bit will "almost always" be zero, No?
>
>
>
Yes, however my point is that this field is useless unless it provides
any advantage over looking at each NALU. The F bit in STAP and MTAPs are
a redundant field. The information is available for in each NALU header.
So with the current definition of the F in STAP, MTAP what advantage
does it give? To my understanding the only knowledge it gives is: At
least one NALU is damaged. However you will still need to look at which
they are. So I don't see any advantage of reading the F bit in the STAP,
MTAP header.

However if you redefine it as I propose it is a little bit less
redundant, now the F bit gives the following information: All NALUs are
damaged, unless I can repair them I can throw away them. This means that
simple implementations (not trying any repair) can throw away the whole
packet with less processing. Of course it is correct that the bit will
be set much less often.

Cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research ERA/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

---

From: Stephan Wenger <[email-masked]>
Date: Wed, 12 Mar 2003 05:46:57 +0700

Folks,

>... and it is a better idea then to set it if all are discardable...

Ok, logical OR.  We'll change it in the next revision of the draft.

Thanks,
Stephan