Subject: RE: [AVT] Updated issues to discuss -- draft-ietf-avt-rtp-h264-01 .txt

From: "Even, Roni" <[email-masked]>
Date: Thu, 13 Mar 2003 13:56:45 +0200

Stephan,
In the RTP world how will parameter sets work when a mixer is involved. It
is the same problem.
Roni

> -----Original Message-----
> From: Stephan Wenger [mailto:[email-masked]]
> Sent: Thursday, March 13, 2003 1:49 PM
> To: Even, Roni
> Cc: 'Stephan Wenger'; [email-masked]
> Subject: RE: [AVT] Updated issues to discuss -- 
> draft-ietf-avt-rtp-h264-01 .txt
> 
> 
> Hi Roni,
> 
> At 12:22 PM 3/13/2003 +0200, Even, Roni wrote:
> >[...]
> >I would like to point out that there are problems with supporting 
> >parameters sets in multipoint video conferencing scenarios.
> >[...]
> 
> First, please let me point out that Roni's multipoint is not 
> the multipoint 
> most of the AVT'ers would think of.  Roni speaks, I believe, 
> primarily 
> about a multipoint scenario where a central Multipoint 
> Control Unit (MCU) 
> is employed.  For those who don't know, an MCU is something 
> similar to, but 
> not quite the same as, an RTP Mixer.  It also allows for 
> stream switching 
> in the same RTP session, in addition to spatial mixing 
> (actually, there are 
> product that do switching only).
> 
> Second, I agree that there are issues with parameter sets in these 
> scenarios, and I know that people in the ITU are working on 
> those.  I am 
> one of them.  If the outcome of the ITU discussions is that 
> they will use 
> in-band parameter sets over IP links, then there is indeed a 
> need to send 
> parameter sets closely aligned to the IDR pictures.  Hence, 
> technically, 
> Roni and me are in a perfect technical agreement.
> 
> However, the question is whether the RTP payload 
> specification is the right 
> place to express the mentioned need.  There are many totally valid 
> examples, where RTP-based video, even when using in-band 
> parameter sets, 
> will NOT require the parameter sets being sent with the IDR 
> picture.  And I 
> think I could also come up with at least one example where it would 
> actually be harmful to do so.
> 
> Also, I haven't seen similar statements in RFC2429, where the analog 
> language would be that you have to send the full picture 
> header with all 
> it's extensions with every I picture (or, at least, after 
> every Full Intra 
> Request or something).
> 
> We may add an informal comment on the close relationship 
> between parameter 
> sets and IDR pictures in H.264, but more seems to be 
> inappropriate.  However, I would be more than happy to learn 
> what draft/RFC 
> would be the right place (in the ITU world, IMHO the right 
> place would be 
> the system overview spec, e.g. H.320 or H.323).
> 
> Regards,
> Stephan
> 
> 
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Even, Roni" <[email-masked]>
Date: Thu, 13 Mar 2003 14:07:33 +0200

Stephan,
I do not see how H.264 work through RTP level mixers and transcoders without
sending the parameter sets in band
Roni

Stephan,