Subject: [AVT] Re: Questions about draft-ietf-avt-rfc2833bis-02 and sub-events

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 18 Jun 2003 15:31:55 -0400

Rhodes, Ann wrote:
> These questions are based on the draft-ietf-avt-rfc2833bis-02
> document, specifically in the area of sub-events for DTMF digits
> lasting longer than 8.192 seconds.
> 
> 1. First, this draft of the specification indicates it "expires" in
> April, 2003. Does that mean that this draft is now the accepted
> standard since the comment period has expired?

I plan to issue a new draft shortly, but have been waylaid with other items.

> 
> 2. Second, it would be helpful to have an example of what durations,
> packet intervals and timestamps look like at the rollover points
> where sub-events are created. For example, suppose the Named Event
> began at timestamp 0, has duration 72,000 (9 seconds), and RFC2833
> packets are sent out at 50msec intervals. Assume that associated
> audio packets are muted during the event. Is this sequence of packets
> correct?

Please see if the new edition will help.

> 
> Relative     Sequence      Time Time (ms)    Number        Stamp
> Duration     Comment 
> ---------------------------------------------------------- 0
> X             0         400        this is the first packet of the
> event 50         X+1           0         800        this is the
> second packet of the event .....
> 8.xxx seconds pass with packets sent 8100         X+162         0
> 65200       last packet before rollover/subevent 8141.875     X+163
> 0        65535       last packet of event with duration FFFF note
> that it comes at non-periodic interval 8150         X+164     65535
> 65       this is the first packet of the subevent 8200         X+165
> 65535          465       now the sequence continues from here... 
> .....
> 
> What if, because of DSP sampling intervals, it is impossible for the
> transmitting gateway to send packet X+163 at the rollover instant?
> What should the transmitting gateway do to minimize jitter perceived
> at the receiving gateway?
> 
> If this example is incorrect, what is the appropriate sequence?
> 
> 
> Regards,
> 
> Ann Rhodes

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Rhodes, Ann" <[email-masked]>
Date: Wed, 18 Jun 2003 13:01:30 -0600

These questions are based on the draft-ietf-avt-rfc2833bis-02 document, specifically in the area of sub-events for DTMF digits lasting longer than 8.192 seconds.

1. First, this draft of the specification indicates it "expires" in April, 2003. Does that mean that this draft is now the accepted standard since the comment period has expired?

2. Second, it would be helpful to have an example of what durations, packet intervals and timestamps look like at the rollover points where sub-events are created. For example, suppose the Named Event began at timestamp 0, has duration 72,000 (9 seconds), and RFC2833 packets are sent out at 50msec intervals. Assume that associated audio packets are muted during the event. Is this sequence of packets correct?

Relative     Sequence      Time     
Time (ms)    Number        Stamp     Duration     Comment
----------------------------------------------------------
     0         X             0         400        this is the first packet of the event
    50         X+1           0         800        this is the second packet of the event
 .....                                            8.xxx seconds pass with packets sent
  8100         X+162         0        65200       last packet before rollover/subevent
  8141.875     X+163         0        65535       last packet of event with duration FFFF
                                                  note that it comes at non-periodic interval
  8150         X+164     65535           65       this is the first packet of the subevent
  8200         X+165     65535          465       now the sequence continues from here...
 .....

What if, because of DSP sampling intervals, it is impossible for the transmitting gateway to send packet X+163 at the rollover instant?  What should the transmitting gateway do to minimize jitter perceived at the receiving gateway?

Regards,

Ann Rhodes