Subject: Re: [AVT] RTP timestamp calculation for MPEG1 Video and Audio ES so that itworks with RTSP client like RealOne/QuickTime

From: "Neo Anderson" <[email-masked]>
Date: Tue, 26 Aug 2003 11:14:13 +0530

Hi,

Since you have mentioned the documents yourself, I think they

provide sufficient information for interop with realone. Check out

rfc3550 too.

We need to provide the timestamp with the proper clock rates

mentioned for the specific media type payload format (rfc2250).

For example, if the clock is 90kHz, practically, multiply the

timestamp in seconds by 90000. This is the RTP  timestamp value to be

transmitted in the packet. Check out the clock rates carefully for

each media type and associated payload format is used.

Take care of putting proper NTP and RTP timestamp correlation while

sending SR packets.

There is also an interoperablity statement for RTP/RTSP in the real

networks site. Sorry, I am not able to cite the exact document at

present. try downloading from their website.

--Neo
Get your own Free E-mail at Witch Wisdom http://www.witchwisdom.com
__________________
http://www.zzn.com

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Deepak Kotian <[email-masked]>
Date: Tue, 26 Aug 2003 20:26:19 +0530

Hi,

>>There is also an interoperablity statement for >>RTP/RTSP in the real 
>>networks site. Sorry, I am not able to cite the >>exact document at 

Just to add.
About this documents, there seems to be no 
document with the RealOne guys for the timestamp calculation,etc. I checked with them at the helix forum.

Thanks and Regards
Deepak

----- Original Message ----- 
  From: Deepak Kotian 
  To: [email-masked] 
  Cc: [email-masked] 
  Sent: Tuesday, August 26, 2003 7:33 PM
  Subject: Re: [AVT] RTP timestamp calculation for MPEG1 Video and Audio ES so that itworks with RTSP client like RealOne/QuickTime

  Hi,

  Thanks for the inputs.
  But, these RFCs do not mention about the PTS or DTS timestamp
  calculation, it seems the RTP timestamp is derived from PTS or DTS
  of headers. Which is usually 33 bits, that too is mystery to me as
  the RTP timestamp is 32 bits. 
  That is what I have heard.

  Is there a very simple implementation where Minimal RTSP server
  is implemented and works with RealOne via RTP for both MPEG1 audio 
  and video Elementary stream.
  The helix source is really very big to understand quickly.
  Some more inputs would be of great help.

  Thanks and Regards
  Deepak

    ----- Original Message ----- 
    From: Neo Anderson 
    To: [email-masked] 
    Cc: [email-masked] 
    Sent: Tuesday, August 26, 2003 11:14 AM
    Subject: Re: [AVT] RTP timestamp calculation for MPEG1 Video and Audio ES so that itworks with RTSP client like RealOne/QuickTime

        Hi,

        --Neo