Subject: RE: [AVT] 3GPP timed text draft: more generic?

From: "Jose Rey" <[email-masked]>
Date: Mon, 11 Aug 2003 10:15:44 +0200

Hi all,

--snip
Colin Perkins wrote:
> A specific payload format for 3GPP timed text might be
> appropriate, but I
> would like to understand the options and alternatives before
> we make that
> choice. Is 3GPP the only body doing timed and/or decorated
> text? If not,
> what are the alternatives, and how do they relate?
>
> --

at the moment there are at least two more standardisation bodies
interested
in timed text: MPEG and W3C.

- MPEG is currently defining their own TT format based on 3GPP TT (see
Committee Draft of ISO/IEC 14496-17 from July'03 Meeting in Trondheim)
by defining the access unit structure, the stream type, the object type
indication and decoder specific info of the timed text samples. The
definition of these items enables the transport over RTP using the
mpeg4simple draft. The work in MPEG is assumed to be finalised around
July 2004.

- W3C is at a very early stage in defining a timed text authoring
format. It
has recently (May'03) published a draft for use cases and requirements
of a
timed text authoring format:
http://www.w3.org/TR/2003/WD-tt-af-1-0-req-20030515/. This draft has a
rather long list of requirements and lists many functionalities. In my
understanding W3C targets to a generic format with rich functionality. I
don't know how quick it may develop (anyone?).

None of these above is an option for us, because 1) the only timed text
format in
3GPP is 3GPP timed text 2) 3GPP has not adopted the mpeg4simple for
transport and 3) for this 3GPP timed text format we need an RTP payload
format within the current 3GPP Release 6 schedule (i.e. March'04).

cheers,

Jose

> -----Original Message-----
> From: Colin Perkins [mailto:[email-masked]]
> Sent: Monday, July 28, 2003 3:18 PM
> To: Jose Rey
> Cc: [email-masked]
> Subject: Re: [AVT] 3GPP timed text draft: more generic?
>
>
> --> "Jose Rey" <[email-masked]> writes:
> >
> > Hi all,
> >
> > during the presentation of the payload format for 3GPP
> timed text some
> > concerns arose on whether this work should be more generic.  On the
> > other hand I also emphasized the fact that there's a
> deadline to meet
> > here for 3GPP Release 6: March '04.
> >
> > It is our opinion that, in this case, a more specific
> payload format for
> > the 3GPP timed text format is the right way to go. Does
> anybody think
> > otherwise? We would like to hear comments/critic on this,
> in order to
> > progress to working group work item.  How could it be made
> more generic?
>

> Colin Perkins
> [email-masked]

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Mon, 11 Aug 2003 11:02:37 +0100

On Monday, Aug 11, 2003, at 09:15 Europe/London, Jose Rey wrote:
> interested in timed text: MPEG and W3C.
>
> format. It has recently (May'03) published a draft for use cases and 
> requirements of a timed text authoring format:

I believe SMPTE may also have timed text work in their Digital Cinema 
group?

> format in 3GPP is 3GPP timed text 2) 3GPP has not adopted the 
> mpeg4simple for

I agree that using the MPEG4-simple format doesn't make sense, and that 
the W3C schedule looks to be too long for 3GPP requirements.

-- 
Colin Perkins
http://csperkins.org/

---

From: "Jose Rey" <[email-masked]>
Date: Wed, 20 Aug 2003 14:34:00 +0200

Hi Colin, all,

> Sent: Monday, August 11, 2003 12:03 PM
> To: Jose Rey
> Cc: [email-masked]
> > understanding W3C targets to a generic format with rich
> functionality.
> > I

Yes, there is a DC28.2W Subtitles and Captions Adhoc Group in SMPTE
dealing with a stream timed text format. I've checked the website and as
far as I understand from the available documents they intend to develop
a media format to stream text encoded as MNG (Multi-image Network
Graphics) images. On April'02 they were still working on a requirements
document for the stream text format but no output has been published
until today, at least publicly.

Question to the group: is anyone aware of the progress of this item?

thanks,

Jose