Subject: [AVT] RE: I-D ACTION:draft-ash-e2e-voip-hdr-comp-rqmts-01.txt

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Tue, 30 Sep 2003 17:11:50 -0500

All,

Please review the updated 01 version of the 'Requirements for VoIP Header Compression over Multiple-Hop Paths' http://www.ietf.org/internet-drafts/draft-ash-e2e-voip-hdr-comp-rqmts-01.txt.  

The update is in response to the AVT proposed charter items, where these milestones have been tentatively added to the charter:

Nov 2003 Initial draft requirements for ECRTP over MPLS; discuss with MPLS WG
Mar 2004 Finish requirements for ECRTP over MPLS; re-charter for subsequent work

These are the main changes/updates from the 00 version:

1. Changed the terminology of 'end-to-end VoIP header compression' to 'VoIP header compression from compressor to decompressor over multiple-hop paths'.  The 'end-to-end' terminology caused some confusion at IETF-57.
2. Expanded the introduction to be more descriptive of the problem and background.
3. Added Section 2 on 'scenarios'.
4. Added 'goals' to Section 3, and made the requirements more specific (e.g., added tentative performance requirements for delay, jitter and packet loss).
5. Put a brief summary of 'proposed solutions' in Appendix A (for convenience of the reader).

Please let us know your comments and suggestions.

Thanks,
Jerry Ash

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, September 30, 2003 3:38 PM
Cc: [email-masked]
Subject: [AVT] I-D ACTION:draft-ash-e2e-voip-hdr-comp-rqmts-01.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: Requirements for VoIP Header Compression over 
                          Multiple-Hop Paths
	Author(s)	: J. Ash et al. 
	Filename	: draft-ash-e2e-voip-hdr-comp-rqmts-01.txt
	Pages		: 0
	Date		: 2003-9-30
	
VoIP typically uses the encapsulation voice/RTP/UDP/IP/.  When MPLS 
labels are added, this becomes voice/RTP/UDP/IP/MPLS-labels.  For an 
MPLS VPN, the packet header is at least 48 bytes, while the voice 
payload is often no more than 30 bytes.  VoIP header compression can 
significantly reduce the VoIP overhead through various compression 
mechanisms.  This is important on access links where bandwidth is 
scarce, and can be important on backbone facilities, especially where 
costs are high (e.g., some global cross-sections).  Providing VoIP 
header compression over multiple hop paths avoids multiple 
compression/decompression cycles at each router, and thereby increases 
the processing scalability of the maximum number of simultaneous VoIP 
flows which use header compression at each router.  This draft gives a 
problem statement, example scenarios, goals, and requirements for VoIP 
header compression from compressor to decompressor over multiple-hop 
paths, possibly over MPLS.  It also discusses work items and issues for 
consideration, and highlights various solution alternatives that have 
been proposed.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ash-e2e-voip-hdr-comp-rqmts-01.txt

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Tue, 7 Oct 2003 21:57:10 +0100

Jerry, all,

On Tuesday, Sep 30, 2003, at 23:11 Europe/London, Ash, Gerald R  
(Jerry), ALABS wrote:
> Please review the updated 01 version of the 'Requirements for VoIP  
> Header Compression over Multiple-Hop Paths'  
> http://www.ietf.org/internet-drafts/draft-ash-e2e-voip-hdr-comp-rqmts- 
> 01.txt.
...
> Please let us know your comments and suggestions.

I think this gives a reasonable overview of the problem space. I'd be  
interested, though, to see more discussion of the limiting factor when  
supporting many hop-by-hop CRTP flows: is the primary bottleneck  
processing power in the router, or the amount of per-flow state that  
has to be maintained? Multi-hop header compression will reduce the  
computation, but it's not clear that it will help with the state  
overhead.

-- 
Colin Perkins
http://csperkins.org/