Subject: [AVT] SRTP session keys generation using AES-CM

From: "Sylvain Latulippe" <[email-masked]>
Date: Thu, 30 Oct 2003 10:51:12 -0500

Hi,

I am confused regarding AES-CM initialization for PRF (IV vs AES-CM input).

According to draft-ietf-avt-srtp-09.txt (B.3 Key Derivation Test Vectors), Cipher key generation uses AES-CM input (x*2^16) which is the same value as IV?

Do I init AES-CM IV and than use the same value for encryption input?

Thanks,

Sylvain Latulippe,
M5T Inc.

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Karl Norrman (KI/EAB)" <[email-masked]>
Date: Fri, 31 Oct 2003 11:36:58 +0100

Hello,

 >-----Original Message-----
 >From: [email-masked] [mailto:[email-masked]]On Behalf 
 >Of Sylvain
 >Latulippe
 >Sent: den 30 oktober 2003 16:51
 >To: [email-masked]
 >Subject: [AVT] SRTP session keys generation using AES-CM
 >
 >
 >
 >Hi,
 >
 >According to draft-ietf-avt-srtp-09.txt (B.3 Key Derivation 
 >Test Vectors), Cipher key generation uses AES-CM input 
 >(x*2^16) which is the same value as IV?
 
Yes, the cipher key is generated by the PRF, which takes x
as input. That PRF input is then used to compute x*2^{16},
which is then used as IV for AES-CM.

Note that the IV is the first block that is encrypted  by AES.
The output of of that encryption is the first block of the output of the PRF.

 >Do I init AES-CM IV and than use the same value for encryption input?

I'm not sure what you mean by "encryption input". The IV is the only input
to AES in the PRF, i.e., the IV is the cleartext input to AES and the encrypted
IV is the first part of the PRF output.

Regards,
Karl