Subject: [AVT] ipv6 multicast problem on Linux kernel 2.4.18-3 while doing a sendto

From: Deepak Kotian <[email-masked]>
Date: Sun, 19 Oct 2003 17:15:48 +0530

Hi,    

We  are currently facing a problem when
we try mutlicast IP FF12::224.5.6.7 on Linux.
The function inet_pton() returns > 0, that means the IP is OK, but
when we do a sendto(), it gives an error, EADDRINVAL.

The kernel used is 2.4.18-3 and ipv6 is enable. 
Can one please let me know, how to make this multicast IPV6
sendto() functionality work properly. 

I think, this is not the right forum, but if some has worked on it,
can one please share his experience on it.
Or does anyone know the right forum for this query.

Thanks and Regards
Deepak

---

From: Deepak Kotian <[email-masked]>
Date: Mon, 20 Oct 2003 21:42:42 +0530

Hi,

Also an additional information.
F001:0:0:0:0:0:0:43 MULTICast address works
fine with sendto, but FF12::224.5.6.7 does not
work.
Also, the errno is 99 , the errno menitioned in the 
earlier mail was not OK.

Any inputs from anyone on this now.

Thanks and Regards
Deepak

  ----- Original Message ----- 
  From: Deepak Kotian 
  To: [email-masked] 
  Sent: Sunday, October 19, 2003 5:15 PM
  Subject: ipv6 multicast problem on Linux kernel 2.4.18-3 while doing a sendto 

  Hi,    

  Thanks and Regards
  Deepak