Subject: [AVT] RE: I-D ACTION:draft-ash-avt-ecrtp-over-mpls-reqs-00.txt

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Wed, 7 Jan 2004 17:16:06 -0600

All,

Please review and comment on the current draft of 'Requirements for ECRTP over MPLS' http://www.ietf.org/internet-drafts/draft-ash-avt-ecrtp-over-mpls-reqs-00.txt.

As agreed at IETF-58 and on the list, the main changes are as follows:

1. focus on requirements for ECRTP over MPLS (defer other requirements until later).
2. eliminate MPLS jargon such as CE, PE, etc., just talk about routers R1, R2, etc.
3. eliminate absolute performance objectives and simply state the requirement to 'minimize delta degradation'.
4. eliminate absolute scalability requirements, and simply state the goal to improve scalability of the number of compressed flows that can be handled.

There was considerable discussion of the previous draft at IETF-58 (see the AVT meeting minutes at http://ietf.org/proceedings/03nov/index.html), but not much discussion on the list.

Let's get the discussion going on the list so we can converge on this draft prior to IETF-59 (week of March 1), and meet the AVT charter item milestone:

Mar 2004 Finish requirements for ECRTP over MPLS; re-charter for subsequent work

Thanks,
Jerry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, January 07, 2004 4:01 PM
Subject: I-D ACTION:draft-ash-avt-ecrtp-over-mpls-reqs-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: Requirements for ECRTP over MPLS
	Author(s)	: J. Ash
	Filename	: draft-ash-avt-ecrtp-over-mpls-reqs-00.txt
	Pages		: 0
	Date		: 2004-1-8
	
VoIP typically uses the encapsulation voice/RTP/UDP/IP.  When MPLS 
labels are added, this becomes voice/RTP/UDP/IP/MPLS-labels.  For an 
MPLS VPN, the packet header is at least 48 bytes, while the voice 
payload is often no more than 30 bytes, for example.  VoIP header 
compression can significantly reduce the VoIP overhead through various 
compression mechanisms, such as enhanced compressed RTP (ECRTP).  This 
is important on access links where bandwidth is scarce, and can be 
important on backbone facilities, especially where costs are high (e.g., 
some global cross-sections).  We consider using MPLS to route ECRTP 
compressed packets over multiple router hops without 
compression/decompression cycles at each router.  Such an ECRTP over 
MPLS capability can increase the bandwidth efficiency as well as 
processing scalability of the maximum number of simultaneous VoIP flows 
which use header compression at each router.  This draft gives a problem 
statement, goals, requirements, and an example scenario for ECRTP over 
MPLS.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ash-avt-ecrtp-over-mpls-reqs-00.txt

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Mon, 12 Jan 2004 00:19:57 +0000

--> "Ash, Gerald R (Jerry), ALABS" <[email-masked]> writes:
> Please review and comment on the current draft of 'Requirements for ECRTP
> over MPLS'
> http://www.ietf.org/internet-drafts/draft-ash-avt-ecrtp-over-mpls-reqs-00.txt.

To me, this is a considerable improvement on the previous version. A few
comments:

In a number of places, the draft describes "using MPLS to route ECRTP
compressed packets over multiple router hops". Does this mean routing
compressed packets over an MPLS LSP? If so, I recommend clarifying the
draft to prevent confusion with multiple IP hops.

I'm not sure discussion of access links is appropriate, since MPLS is
unlikely to be used in this scenario.

In section 3, the requirements list ECRTP without discussion. I think ECRTP
is an appropriate solution, but it would be useful to motivation the choice
by discussing the requirements for the compression. This is particularly
important, since there are alternative algorithms (e.g. ROHC) that may be
considered.

In section 3, the draft nots that protocol extensions may be required for
ECRTP. Are these changes to ECRTP or a mapping of ECRTP onto a new "link"
layer? If the latter, the draft could do with clarification.

The draft should discuss the type of extension needed for RSVP-TE and LDP,
since this will feed into any new work plan.

Security considerations: Are there no issues with DoS attacks on MPLS
routers, due to the increased number of flows? 

Before publication, the draft will need an IANA Consideratations section
(even if it just says "No IANA actions are required") and the IPR boiler-
plate.

-- 
Colin Perkins
http://csperkins.org/