Subject: [AVT] Fwd: I-D ACTION:draft-koren-avt-ecrtp-reorder-00.txt

From: Colin Perkins <[email-masked]>
Date: Wed, 16 Feb 2005 20:59:50 +0000

Begin forwarded message:
> From: [email-masked]
> Date: 16 February 2005 15:14:15 GMT
> To: [email-masked]
> Subject: I-D ACTION:draft-koren-avt-ecrtp-reorder-00.txt
> Reply-To: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts  
> directories.
>
>
> 	Title		: Packet reordering in Extended CRTP (ECRTP)
> 	Author(s)	: T. Koren, P. Ruddy
> 	Filename	: draft-koren-avt-ecrtp-reorder-00.txt
> 	Pages		: 0
> 	Date		: 2005-2-15
> 	
> Extended RTP Header Compression (ECRTP) is tolerant to packet
>    misordering. This document describes how ECRTP validates packets
>    that arrive out of order.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-koren-avt-ecrtp-reorder 
> -00.txt

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Haipeng Jin <[email-masked]>
Date: Thu, 17 Feb 2005 08:24:13 -0800

Hi,

Here are some comments on this ID. It seems that remembering the last RTP 
SN where delta IPID has changed may not be enough.

For example, for a sequence of RTP packet with sequence number from 1 to 
100. Suppose delta IPID changed on packet(1) to 1 and stays the same all 
the time, however, IPID jumped  on packet(50) by 10, on packet(75) by 10, 
as a result, packet(100) has IPID 120 (assume IPID is 1 for packet(1)).

Now let's look at packet 101 ~ 104:
101: IPID = 121, compressed_RTP,
102: IPID = 130, CUDP, IPID = 130
103: IPID = 131, CUDP, IPID = 131
104: IPID = 132, CUDP, IPID = 132

Now if  packet(103) is received before packet(101), the decompressor 
context will have IPID = 131, delta IPID = 1, RTP SN = 103, last RTP SN 
with delta IPID change = 1. When the decompressor receives packet(101),
1) it cannot decompress IPID based on (SN =103, IPID = 131) because IPID 
has jumped and the difference in RTP SN tells nothing.
2) it cannot decompress IPID based on the knowledge that last RTP SN with 
delta IPID change = 1, because there have been multiple IPID jumps between 
packet(1) and packet(100) even though delta IPID doesn't change.
To solve the above problem, the decompressor actually needs to remember the 
last RTP SN where IPID changed irregularly.

Another  example is
101: IPID = 121, CRTP
102: IPID =  131, CUDP, IPID = 131, delta IPID = 10
103: IPID = 141, CUDP, IPID = 141, delta IPID = 10
104: IPID = 151, CUDP, IPID = 151, delta IPID = 10

If packet(103) is received before packet(101), the decompressor context 
will have IPID = 141, delta IPID = 10, RTP SN = 103, last RTP SN with delta 
IPID change = 103. Again, the decompressor will have trouble decoding the 
late packet(101). One way to solve this problem is for the decompressor to 
remember both the last and the  next to last RTP SNs where IPID changed 
irregularly.

To summarize,  the decompressor needs to remember the following info for 
the last and the next to last packets where IPID changed irregularly: RTP 
SN, delta IPID, and IPID.

Regards,
Haipeng

At 12:59 PM 2/16/2005, Colin Perkins wrote:
>>http://www.ietf.org/internet-drafts/draft-koren-avt-ecrtp-reorder -00.txt
>
>