Subject: RE: [AVT] Working Group Last Call: draft-ietf-avt-rtp-vmr-wb-08.txt

From: [email-masked]
Date: Tue, 1 Feb 2005 11:06:16 -0800

Hi Magnus,

Thanks for your comments. I will post revision -09 of the draft by the end of today incorporating all your proposed changes.

> 3. Section 9.1:
> There is a fact that you need to be in octet-align mode when doing 
> interleaving. However the text now has a double guarding of 
> this. From 
> Interleaving def:
>                                            The presence of this
>                       parameter also implies automatically that
>                       octet-aligned operation SHALL be used.
> 
> While earlier in the text there is the following statement:
> 
>     Furthermore, if the interleaving parameter is present, the
>     parameter "octet-align=1" MUST also be present.
> 
> Thus the presences of Octet-aligned is required even if the 
> presence of 
> "interleaving" is explicit indication that octet-align mode shall be 
> used. Are there a reason for requiring the presence of 
> "octet-align" in 
> this case?
> 
> It isn't necessary to change this, however I would like to 
> know if there 
> is a reason or simply ended up this way.

This is what Colin asked me to include (in the August meeting) to avoid any confusion and to ensure that if interleaving is used the user must use the octet-align payload format.

Regards

-Sassan Ahmadi
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 02 Feb 2005 09:37:11 +0100

> This is what Colin asked me to include (in the August meeting) to avoid any confusion and to ensure that if interleaving is used the user must use the octet-align payload format.

Okay, there is no reason to change anything. What is in there clearly 
works and is explicit.

Cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]