Subject: RE: [AVT] Update (-09) of Timed Tex draft (WAS: RE: Comments on draft-ietf-avt-rtp-3gpp-timed-text-08.txt)

From: "Rey Jose" <[email-masked]>
Date: Mon, 7 Feb 2005 19:43:06 +0100

Dave,

> >         TYPE 5 units are exception: TYPE 5 units can be 
> used to convey
> >         sample descriptions that are used by many samples. 
> Accordingly,
> >         their timestamp does not represent the instant when they are
> >         played out, but instead the instant at which they 
> become available
> >         for use. A sample description conveyed in a TYPE 5 
> packet MUST NOT
> >         be referenced by a unit with earlier timestamp.
> 
> I like this, it's much clearer to implement and understand.

This is fine. Easy to change and adapt the text accordingly.
How about the below one, what are your thoughts on that?

> >...
> >>>This would only be simpler if modifier boxes were never sent 
> >>>separately from the text. As it stands, a receiver must 
> support two 
> >>>different ways of getting the modifier. If we remove 
> support for type 
> >>>1 packets, and always send either text or modifiers, then 
> a receiver 
> >>>has only one way of getting the data. That would reduce 
> the amount of 
> >>>code in the receiver.
> >>>
> >>I understand. But, is the additional code such a burden? To outline 
> >>the options once again: 1) currently you directly read out text 
> >>samples from (and store into) the file or decoder and 
> transport them 
> >>on TYPE 1 units as they are.  Most server applications will 
> probably 
> >>have no need to send type 2 units, TYPE 2 is there for 
> completeness. 
> >>2) On the other hand, if you elliminate TYPE 1, you would have to 
> >>fragment & reassemble always. For small units this is overhead.
> >
> >That depends on how you build your system, and how tightly 
> integrated 
> >the 3GPP timed text decoder is with the payload format 
> decoder. I would 
> >argue that it's cleaner from a protocol design viewpoint to 
> have only a 
> >single way of transporting the data, rather than forcing both client 
> >and server to implement two alternatives which do 
> essentially the same 
> >thing. Maybe the benefit from having TYPE 1 units is worthwhile, but 
> >I'm a little concerned that the design is being optimised for one 
> >particular case - streaming from a pre-created timed text 
> file across a 
> >network with known characteristics - at the expense of others.

Cheers,

José

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Dave Singer <[email-masked]>
Date: Mon, 7 Feb 2005 11:35:44 -0800

>  > >network with known characteristics - at the expense of others.

I think by far the most common case is likely to be TYPE1 units, so 
(just like single-NAL packets in the H.264 format could be emulated 
with single-time aggregations with one enclosure) it makes sense to 
keep them.
-- 
David Singer
Apple Computer/QuickTime

---

From: Colin Perkins <[email-masked]>
Date: Mon, 7 Feb 2005 19:49:04 +0000

On 7 Feb 2005, at 19:35, Dave Singer wrote:
...
> with single-time aggregations with one enclosure) it makes sense to 

Okay.

Colin