Subject: [AVT] payloads to file

From: "Ar c'hasour" <[email-masked]>
Date: Thu, 7 Apr 2005 13:55:12 -0700 (PDT)

Hi,

I have 2 beginner's questions:

One can directly record a received G711-PCMU RTP
payload in a ".au" file ; this file is then ready to
be played without more implementation effort (I admit
".au" is not handled by all OS).
- Is there such an easy codec for video? 
- Which type of file can contain both these
"no-effort" audio and video payloads?

Thanks,
P. Kasour

PS: I understand the questions are not 100% in the
scope of the WG. Feel free to redirect me to a more
relevant WG or site.

__________________________________ 
Do you Yahoo!? 
Yahoo! Personals - Better first dates. More second dates. 
http://personals.yahoo.com

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Tue, 12 Apr 2005 19:49:49 +0100

> "no-effort" audio and video payloads?

In general, there's no such thing as a "no-effort" conversion, even in 
cases where the file format is simply a concatenation of frames from 
RTP payloads. A receiver needs to reconstruct the timing of the data 
and handle potential packet loss before it can write the media payload 
into a file, irrespective of how similar to the RTP payload format the 
file format appears. The extra processing to conform to a particular 
file format is not, typically, a significant increase in complexity.

Colin