Subject: RE: [AVT] Update (-09) of Timed Tex draft (WAS: RE: Comments ondraft-ietf-avt-rtp-3gpp-timed-text-08.txt)

From: "Jose Rey" <[email-masked]>
Date: Wed, 13 Apr 2005 14:06:04 +0200

Hi,

> Magnus,
> 
> On 13 Apr 2005, at 12:40, Magnus Westerlund wrote:
> > Colin Perkins wrote:
> >> Packet 0: Type 1: SIDX=1
> >> Packet 1: Type 5: SIDX=2
> >>           Type 1: SIDX=2
> >> Packet 2: Type 1: SIDX=2
> >> Packet 3: Type 5: SIDX=2 (Repetition)
> >>           Type 1: SIDX=2
> >
> >>> With the proposed timestamp model, the timestamp of the 
> TYPE 5 unit 
> >>> in packet 3 should have a TS equal to the TS of packet 1, rather 
> >>> than the TS of packet 3 to indicate that it is useful from the TS 
> >>> time of packet 1.
> >> Why? If you give the type 5 unit sent in packet 3 the timestamp of 
> >> packet 3, then the behaviour is unchanged from the 
> previous, except 
> >> that the timing model is used to decode the data.
> >
> > The reason is that otherwise, you would not care to 
> depacketize packet
> > 3 until after you have tried to consume packet 2 and 
> failing that due 
> > to lack of sample description, and moved on.
> 
> Yes, of course. That's exactly the behaviour that was defined 
> in the earlier versions of the draft, which made the Type 5 
> units available for use as soon as they arrived.
> 

Right now, for TYPE 5 units applies:

           o In general, TYPE 5 units MUST receive their timestamp from 
             the first non-TYPE 5 unit following them in the payload. 
           o However, if:  

   Rey & Matsui                                              [Page 31]
   Internet Draft  Payload Format for 3GPP Timed Text   March 29, 2005 

               o the payload only contains (one or several) TYPE 5 
                  units or, 
               o if one or several TYPE 5 units follow a sample of 
                  unknown duration (see Section 4.1.2, SDUR definition), 
              
             then (all) TYPE 5 units MUST use the RTP timestamp. 

Is this what you refer as too much complexity? 

José

> The changes in the latest versions of the draft add a lot of 
> complexity for very minimal benefit (i.e. they help if you 
> have packet loss in between two repetitions of a type 5 unit 
> and a playout buffer long enough such that the repeated copy 
> of the unit arrives before the data referencing the first has 
> been played out). I just don't think the added complexity is 
> worth it for this use case.
> 
> Colin
> 
> 
> 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Wed, 13 Apr 2005 13:17:48 +0100

> Is this what you refer as too much complexity?

Yes. Why not simply state that TYPE 5 units receive a timestamp 
indicating when they become available for use?

Colin