Subject: RE: [AVT] Update (-09) of Timed Tex draft (WAS: RE: Comments ondraft-ietf-avt-rtp-3gpp-timed-text-08.txt)

From: "Jose Rey" <[email-masked]>
Date: Wed, 13 Apr 2005 13:26:01 +0200

Colin, Magnus,

[snip]
> > Packet 0: Type 1: SIDX=1
> >
> > Packet 1: Type 5: SIDX=2
> >           Type 1: SIDX=2
> >
> > Packet 2: Type 1: SIDX=2
> >
> > Packet 3: Type 5: SIDX=2 (Repetition)
> >           Type 1: SIDX=2
> >
> > IF you in the above case would loose packet 1, you can only utilize 
> > packet 2 if you get packet 3 and its SD.
> 
> This is the behaviour in the -09 draft, yes.
> 
> > With the proposed timestamp model, the timestamp of the 
> TYPE 5 unit in 
> > packet 3 should have a TS equal to the TS of packet 1, 
> rather than the 
> > TS of packet 3 to indicate that it is useful from the TS time of 
> > packet 1.
> 
> Why? If you give the type 5 unit sent in packet 3 the 
> timestamp of packet 3, then the behaviour is unchanged from 
> the previous, except that the timing model is used to decode the data.
> 
This is what -13, section 4.5 says. 

José

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Jose Rey" <[email-masked]>
Date: Wed, 13 Apr 2005 15:30:14 +0200

Colin,

[snip]
> >
> > Right now, for TYPE 5 units applies:
> >
> >            o In general, TYPE 5 units MUST receive their 
> timestamp from
> >              the first non-TYPE 5 unit following them in 
> the payload.
> >            o However, if:
> >
> >
> >    Rey & Matsui                                             
>  [Page 31]
> > >    Internet Draft  Payload Format for 3GPP Timed Text   March 29, 2005
> >
> >                o the payload only contains (one or several) TYPE 5
> >                   units or,
> >                o if one or several TYPE 5 units follow a sample of
> >                   unknown duration (see Section 4.1.2, SDUR 
> > definition),
> >
> >              then (all) TYPE 5 units MUST use the RTP timestamp.
> >
> > Is this what you refer as too much complexity?
> 
> Yes. Why not simply state that TYPE 5 units receive a 
> timestamp indicating when they become available for use?
> 

This last sentence is included.  The other issue is where to place them, i.e., currently they are placed as they are read from file. To simplify one could say that they are all placed (regardless to which unit in the payload they apply) at the beginning of the payload before all other units and receive the RTP TS?   

José