Subject: [AVT] SRTP Key Derivation

From: Fries Steffen <[email-masked]>
Date: Mon, 11 Apr 2005 16:48:56 +0200

Hi Mark,

I've got a short question regarding the key derivation in SRTP. 
The packet index is one item that goes into the derivation function. The
packet index itself is build through the ROC and the RTP sequence number in
the packet. What happens if the first packet gets lost? 
Is there any way of synchronization?

Regards
	Steffen

--------------------------------------------
 Steffen Fries,     Siemens AG, CT IC 3	
 Otto-Hahn-Ring 6,  D-81730 Munich, Germany 
 Phone:  (+49) 89 / 636-53403,    
 Fax  :  (+49) 89 / 636-48000
 email:  [email-masked]
--------------------------------------------

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Mark Baugher <[email-masked]>
Date: Mon, 11 Apr 2005 08:35:23 -0700

hi Steffen
   We have been answering this question for years.  It confuses many.  
All of the state that is needed for key derivation is in the packet.  
In other words, the packet index is not the Nth packet observed but the 
packet that has its extended sequence number modulo N equal to zero.

   If you or anyone need more explanation, I think I can find it and 
post it.  I'm not sure whether a previous discussion is in the AVT 
archives.

Mark