Subject: RE: [AVT] Update (-09) of Timed Tex draft (WAS: RE:Commentsondraft-ietf-avt-rtp-3gpp-timed-text-08.txt)

From: "Jose Rey" <[email-masked]>
Date: Fri, 15 Apr 2005 12:54:17 +0200

Jan,

	Jose, 
	
	> I.e., it cannot be that SDs be just discarded once they are used.
	
	Right, but in my view they are stored in an SIDX buffer until they are invalidated; when that is is not relevant. Or do I miss something ?  
	And where is the SD (not SIDX) buffer? What I want to say is (cf. answer to Dave) that dynamic SDs (and SIDX) are first introduced by this payload format and therefore codecs that use them have to implement the dynamic SIDX wrap-up algo to know how long to buffer SDs (at codec level).  This sounds a bit strange: a payload format setting requirement on a codec and that's why I am a bit doubtful this be OK(?) or am I missing something ??
	 
	Cheers,
	José

	Best regards,
	
	Jan
	
	 [] 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Jan vanderMeer <[email-masked]>
Date: Fri, 15 Apr 2005 15:44:31 +0200

Jose,

Sorry, I meant the SD buffer, not the SDIX buffer.

In my view, an SD is an element of the timed text stream, and the SD 
buffer an internal attribute of the timed text decoder. Within the SD 
buffer, each SD with a dynamic SDIX is stored until it is invalidated. The 
SD buffer is transport independent.

I hope that answers your question.

Best regards,

Jan

"Jose Rey" <[email-masked]>
15-04-2005 12:54
 
        To:     Jan vanderMeer/EHV/IPS/PHILIPS@PHILIPS
"Jose Rey" <[email-masked]>
        cc:     <[email-masked]>
"Colin Perkins" <[email-masked]>
"Magnus Westerlund" <[email-masked]>
"Dave Singer" <[email-masked]>
        Subject:        RE: [AVT] Update (-09) of Timed Tex draft (WAS: 
RE:Commentsondraft-ietf-avt-rtp-3gpp-timed-text-08.txt)
        Classification: 

Jan,

Jose, 

> I.e., it cannot be that SDs be just discarded once they are used.

Right, but in my view they are stored in an SIDX buffer until they are 
invalidated; when that is is not relevant. Or do I miss something ?  
And where is the SD (not SIDX) buffer? What I want to say is (cf. answer 
to Dave) that dynamic SDs (and SIDX) are first introduced by this payload 
format and therefore codecs that use them have to implement the dynamic 
SIDX wrap-up algo to know how long to buffer SDs (at codec level).  This 
sounds a bit strange: a payload format setting requirement on a codec and 
that's why I am a bit doubtful this be OK(?) or am I missing something ??
 
Cheers,
José

Best regards,

Jan

 []

---

From: Dave Singer <[email-masked]>
Date: Fri, 15 Apr 2005 09:26:43 -0700

At 12:54 PM +0200 4/15/05, Jose Rey wrote:
>Right, but in my view they are stored in an SIDX 
>buffer until they are invalidated; when that is 
>is not relevant. Or do I miss something ?  
>And where is the SD (not SIDX) buffer? What I 
>want to say is (cf. answer to Dave) that dynamic 
>SDs (and SIDX) are first introduced by this 
>payload format and therefore codecs that use 
>them have to implement the dynamic SIDX 
>wrap-up algo to know how long to buffer SDs (at 
>codec level).  This sounds a bit strange: a 
>payload format setting requirement on a codec 
>and that's why I am a bit doubtful this be OK(?) 
>or am I missing something ??
>
>Cheers,
>José

it's fine.  packet loss introduces requirements on the codec too.
-- 
David Singer
Apple Computer/QuickTime