Subject: RE: [AVT] Re: Request to review media type in AVT working group lastcall: draft-ietf-avt-rtp-3gpp-timed-text.txt

From: "Jose Rey" <[email-masked]>
Date: Fri, 3 Jun 2005 00:15:03 +0200

Ned,

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Ned Freed
> Sent: Thursday, June 02, 2005 7:50 PM
> To: Magnus Westerlund
> Cc: Ned Freed; IETF AVT WG; Allison Mankin; Bruce Lilly; 
> Colin Perkins; [email-masked]
> Subject: Re: [AVT] Re: Request to review media type in AVT 
> working group lastcall: draft-ietf-avt-rtp-3gpp-timed-text.txt
> 
> > Ned Freed wrote:
> > >
> > > Then why do you need the U bit?
> 
> >  From TS 26.245, section 5.1:
> 
> > Text strings for display and font names are uniformly coded 
> in UTF-8, 
> > or start with a UTF-16 BYTE ORDER MARK (\uFEFF) and by that 
> indicate 
> > that the string which starts with the byte order mark is in UTF-16.
> > Terminals shall recognise the byte-order mark in this byte 
> order; they 
> > are not required to recognise byte-reversed UTF-16, indicated by a 
> > byte-reversed byte-order mark.
> 
> > However this payload format removes the Byte Order Mark and 
> requires a 
> > specific byte order. Thus to be able to provide the same 
> information 
> > that a string is encoded in UTF-8 or UTF-16, it is explicitly 
> > indicated using the U bit.
> 
> Does the U bit appear in the same context as the media type 
> itself or is it part of the payload or some other aspect of 
> the  protocol?

I don't know what exactly is meant by the latter, but the former is not the case.  Besides, apart from complicating session negotiation (O/A, as Magnus mentions) it is really not necessary because both charsets are required by the TT media format.

> It seems appropriate to define a mapping to a 
> parameter if it appears alongside the media type, but not if 
> it doesn't.
[snip]

> I'm not suggesting defining additional parameters. I'm only 
> asking if it makes sense to map and existing session 
> parameter to a media type parameter.
> 

It doesn't make sense, it is not a negotiable thing.

Cheers,

José

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Tom Taylor <[email-masked]>
Date: Fri, 03 Jun 2005 09:12:26 -0400

Simple question: do you expect a given session to consist of just one 
character encoding (UTF-8 or UTF-16) or do you want the possibility for 
it to contain a mixture?  If the encoding is a per-session attribute it 
makes more sense for it to be negotiated out-of-band, as a parameter of 
the MIME type (and hence as an SDP "a=fmtp" parameter).

---

From: Ned Freed <[email-masked]>
Date: Fri, 03 Jun 2005 07:48:49 -0700 (PDT)

> the MIME type (and hence as an SDP "a=fmtp" parameter).

Yes, this is what I was trying to get at when I asked if the bit appears
in the same context as the media type or not.

				Ned

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 03 Jun 2005 17:16:03 +0200

Hi Tom,

> the MIME type (and hence as an SDP "a=fmtp" parameter).

To my understanding a session may contain a mixture of UTF-8 and UTF-16.

Note also, that removing the bit wouldn't result in any byte savings.

So I see it as necessary to have the U bit. Duplicating the information 
is mostly a recipe for confusion when it doesn't agree. Thus, I propose 
to leave it out.

Cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

---

From: Ned Freed <[email-masked]>
Date: Fri, 03 Jun 2005 08:49:10 -0700 (PDT)

> To my understanding a session may contain a mixture of UTF-8 and UTF-16.

That implies that the bit isn't aligned with where media types appear. And that
in turn makes it inappropriate to map to a media type parameter, irrespective
of whether or not it is used for negotiation.

				Ned

---

From: Chris Lilley <[email-masked]>
Date: Sun, 5 Jun 2005 14:37:44 +0200

On Friday, June 3, 2005, 5:16:03 PM, Magnus wrote:

MW> Duplicating the information is mostly a recipe for confusion when it
MW> doesn't agree. Thus, I propose to leave it out.

Wise words in general.

-- 
 Chris Lilley                    mailto:[email-masked]
 Chair, W3C SVG Working Group
 W3C Graphics Activity Lead