Subject: RE: [AVT] I-D ACTION:draft-ietf-avt-rtp-ac3-05.txt

From: "Link, Brian" <[email-masked]>
Date: Mon, 6 Jun 2005 11:35:34 -0700

Hi everyone,

A quick note of explanation about this most recent I-D on the AC-3
payload format (announcement quoted below). This version addresses
comments from Magnus on the reflector and also fixes a few remaining
typos.

Major changes:
-Clarification that frame length can be found within each AC-3 frame.
-Added reference to RFC 3555 and draft-freed-media-type-reg-04 for
format of media type registration and now call it framed and binary
data.
-Removed optional media parameter "BSID" and text describing how to use
it.

Regards,
Brian
---
Brian Link
Dolby Laboratories, 100 Potrero Ave., San Francisco, CA 94103
phone: 415-558-0324  fax: 415-863-1373
email: [email-masked]   alt email: [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Friday, June 03, 2005 12:53 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [AVT] I-D ACTION:draft-ietf-avt-rtp-ac3-05.txt
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> This draft is a work item of the Audio/Video Transport 
> Working Group of the IETF.
> 
> 	Title		: RTP Payload Format for AC-3 Audio
> 	Author(s)	: J. Flaks, et al.
> 	Filename	: draft-ietf-avt-rtp-ac3-05.txt
> 	Pages		: 11
> 	Date		: 2005-6-3
> 	
> This document describes an RTP payload format for 
> transporting AC-3 encoded audio data.  AC-3 is a high 
> quality, multichannel audio coding system used in US HDTV, 
> DVD, cable and satellite television and other media.  The RTP 
> payload format as presented in this document includes support 
> for data fragmentation.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-avt-rtp-ac3-05.txt
> 
> To remove yourself from the I-D Announcement list, send a 
> message to [email-masked] with the word 
> unsubscribe in the body of the message.  
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
> 
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username "anonymous" and a password of your e-mail 
> address. After logging in, type "cd internet-drafts" and then
> 	"get draft-ietf-avt-rtp-ac3-05.txt".
> 
> A list of Internet-Drafts directories can be found in 
> http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-avt-rtp-ac3-05.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 

-----------------------------------------
This message (including any attachments) may contain confidential
information intended for a specific individual and purpose.  If you are
not the intended recipient, delete this message.  If you are not the
intended recipient, disclosing, copying, distributing, or taking any
action based on this message is strictly prohibited.

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 07 Jun 2005 13:31:51 +0200

Hi,

I have reviewed this version and have two comments:

1. First is the reference to Freed's registration template. It will 
block publishing if it is in the normative section. I think it should be 
moved to the informative section. It is borderline case, however I think 
it can be considered informative reference to the procedure used. The 
really important normative references are these referencing actual 
technical solution.

2. The optionality of the "channels" parameter. As all decoder are 
required by the AC-3 standard to handle decoding and down mixing of any 
number of channels that are supported. This is similar to the usage of 
channels in the AMR-WB+ payload format. Which allows a sender to reduce 
its number of channels in cases when the receiver can't play them anyway 
by using the receiver indication. It can also be used by a sender in a 
declarative SDP usage (RTSP, SAP) to declare the maximum number of 
channels that will be used.

To me there is two ways of accomplishing this in a useful manner.
A. Make channels a mandatory parameter that is always included.
B. Include it in all cases when the channels don't match 6, i.e. when 
the number of channels actually are supported or used are reduced to 
this provided lower number.

Comments? Please send them quickly for a fast turn around on this.

Cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]