Subject: RE: [AVT] IESG comments on draft-ietf-avr-rtp-retransmission-11.txt -Issue 1: "acceptable packet loss" / retransmission during congestion

From: "Jose Rey" <[email-masked]>
Date: Mon, 20 Jun 2005 14:59:31 +0200

Hi Jon and Mark, all,

I would like you to consider whether these comments address your concerns so we can finalise with this draft.
I will be away for from Friday on until July 19th, it would be good to clarify this before that.

Thank you

José

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Jose Rey
> Sent: Wednesday, May 25, 2005 12:37 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: [AVT] IESG comments on 
> draft-ietf-avr-rtp-retransmission-11.txt -Issue 1: 
> "acceptable packet loss" / retransmission during congestion
> 
> 
> Jon, Mark,
> 
> I tidied up the previous email a bit.  For each issue, I give 
> you a piece of text that (hopefully) brings you back to the 
> issue (instead of copying all text) and then list text pieces 
> proposed. Used different emails for each issue or unanswered 
> comment, will follow.. 
> 
> Looking forward to your comments!
> 
> José
> 
> ------------
> 
> Issue 1:  "little guidance is given how an implementer migh 
> assert that the packet loss level is acceptable"
> Answer:  IMO, this should not be specified in this document.  
> Acceptable packet loss level is application dependent. 
> Likewise, determining when congestion started and when it 
> ended, or when is still a congestion episode is not in scope. 
>  Therefore, it is proposed to change the text and say that 
> "if congestion is not kept under control, retransmission 
> SHOULD NOT be used".  The SHOULD is justified by examples below. 
> 
> OLD:
>    These congestion control mechanisms should keep the packet loss 
>    rate within acceptable parameters.  Packet loss is considered 
>    acceptable if a TCP flow across the same network path and 
>    experiencing the same network conditions would achieve, on a 
>    reasonable timescale, an average throughput, that is not less than 
>    the one the RTP flow achieves.  If the packet loss rate exceeds an 
>    acceptable level, it SHOULD be concluded that congestion is not 
>    kept under control and retransmission SHOULD NOT then be used.  It 
>    may further be necessary to adapt the transmission rate (or the 
>    number of layers subscribed for a layered multicast session), or 
>    to arrange for the receiver to leave the session.  
> 
> NEW:
> 
>    These congestion control mechanisms should keep the packet loss 
>    rate within acceptable parameters.  In the context of 
> congestion control, packet loss is considered 
>    acceptable if a TCP flow across the same network path and 
>    experiencing the same network conditions would achieve, on a 
>    reasonable timescale, an average throughput, that is not less than 
>    the one the RTP flow achieves.  If congestion is not
>    kept under control, then retransmission SHOULD NOT be used.  
> 
>    Retransmissions MAY still be sent in some cases, e.g., 
>    in wireless links where packet losses are not caused by 
> congestion, or if the 
>    server (or the client that makes the retransmission 
> request) estimates that a particular
>    packet or frame is important to continue play out, or if 
> an RTSP PAUSE has been 
>    issued to allow the buffer to fill up (RTSP PAUSE does not affect
>    the sending of retransmissions.)  
> 
>    Finally, it may further be necessary to adapt the 
> transmission rate (or the 
>    number of layers subscribed for a layered multicast session), or 
>    to arrange for the receiver to leave the session.  
> 
> 
> 
> 
> ---------------------------------------------
> Jose Rey     mailto:[email-masked]
> P R D C G - Panasonic R&D Center Germany GmbH
> Phone/Fax: +49(0)6103766-134/166
> --------------------------------------------- 
> 
> 
> ---------------------------------------------
> Jose Rey     mailto:[email-masked]
> P R D C G - Panasonic R&D Center Germany GmbH
> Phone/Fax: +49(0)6103766-134/166
> --------------------------------------------- 
> 
> 
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/avt
> 
> 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 22 Jun 2005 10:32:32 -0400

I Jose, my aplogies, the [AVT] label had moved your earlier comments into a 
folder that I do not regularly check. I have fixed the rule.

I will answer your emails individually now.

Thanks,

- Mark