Subject: [AVT] Re: avt Digest, Vol 15, Issue 16

From: Girish Chandran <[email-masked]>
Date: Fri, 15 Jul 2005 08:03:56 -0400

Pro-MPEG forum has also done some work on FEC for streamed media.

Girish Chandran

[email-masked] wrote:

>Send avt mailing list submissions to
>	[email-masked]
>
>To subscribe or unsubscribe via the World Wide Web, visit
>	https://www1.ietf.org/mailman/listinfo/avt
>or, via email, send a message with subject or body 'help' to
>	[email-masked]
>
>You can reach the person managing the list at
>	[email-masked]
>
>When replying, please edit your Subject line so it is more specific
>than "Re: Contents of avt digest..."
>
>
>Today's Topics:
>
>   1. Proposed FEC Streaming Framework (Magnus Westerlund)
>
>
>----------------------------------------------------------------------
>
>Message: 1
>Date: Thu, 14 Jul 2005 09:42:27 +0200
>From: Magnus Westerlund <[email-masked]>
>Subject: [AVT] Proposed FEC Streaming Framework
>To: IETF AVT WG <[email-masked]>, [email-masked]
>Cc: [email-masked]
>Message-ID: <[email-masked]>
>Content-Type: text/plain; charset=iso-8859-1; format=flowed
>
>All,
>
>The below messge was sent to TSVWG. If you have comments on this please 
>respond to us author or the TSVWG.
>
>/Magnus Westerlund
>
>-----
>
>A few of us have been working on a framework for FEC protection of
>streaming media, based on some work done recently in 3GPP and making use
>of the FEC Building Block defined by RMT (so that the framework is not
>specific to a particular FEC code).
>
>This proposal is described in
>http://www.ietf.org/internet-drafts/draft-watson-tsvwg-fec-sf-00.txt.
>Although intended primarily for streaming, it is not specific to RTP,
>defining instead an FEC protection layer above UDP, which can protect a
>set of several UDP flows.
>
>Since the proposal is not specific to either multicast or RTP, we are
>bringing it first to TSVWG, rather than RMT or AVT. It will be discussed
>at the Paris meeting, so please put it on your reading list.
>
>The questions for the TSVWG are (at least):
>1) is the objective of extending the RMT FEC Building Block framework to
>streaming a good one ?
>2) is this a good approach to that objective ?
>3) what is the relationship with the ULP work in AVT ?
>4) whether the proposal should best be progressed in AVT (where there is
>streaming expertise), in RMT (where there is FEC expertise) or in TSVWG
>?
>
>Regards,
>
>Mark Watson
>Digital Fountain
>
>
>
>
>
>------------------------------
>
>_______________________________________________
>Audio/Video Transport Working Group
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/avt
>
>
>End of avt Digest, Vol 15, Issue 16
>***********************************
>
>
>  
>

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 15 Jul 2005 14:18:45 +0200

> Pro-MPEG forum has also done some work on FEC for streamed media.

Hi,

Thanks for the notice, could you please provide a more complete 
reference. Preferable an link to the document(s) that specify this 
solution?

I would also like to ask you all kindly that receives the mails per 
digest. When responding, please change the subject to what the relevant 
email you are responding to had.

Thanks

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

---

From: Girish Chandran <[email-masked]>
Date: Fri, 15 Jul 2005 16:19:49 -0400

Hello Magnus,

Here is a reference.

http://www.pro-mpeg.org/publications/pdf/Vid-on-IP-CoP3-r2.pdf

It may also be useful to look at some of the other codes of practice for 
transport of MPEG over IP.

http://www.pro-mpeg.org under the publications tab.

Girish Chandran

Newtec America, Inc.
1055 Washington Blvd.
Stamford, CT 06901
USA
Tel: 203.323.0042
www.newtecamerica.com

Magnus Westerlund wrote:

> digest. When responding, please change the subject to what the 
> relevant email you are responding to had.
>
> Thanks
>
> Magnus Westerlund
>