Subject: [AVT] SRTCP key derivation

From: "Guoqiang Lu" <[email-masked]>
Date: Wed, 20 Jul 2005 12:39:46 -0400

Hi,
In RFC3711, section 4.3.2. SRTCP Key Derivation, it says:

"Replace the SRTP index by the 32-bit quantity: 0 || SRTCP index ..."

My question is that SRTP index is a 48-bit quantity, should the SRTCP 32-bit quantity "0 || SRTCP index" be patched with 16 leading zeros?

Thanks!

Guoqiang Lu
ESN: 39-36277
Phone: (613) 763-6277
[email-masked]
--------------------------
The contents of the this e-mail may be Nortel Confidential! 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Karl Norrman (KI/EAB)" <[email-masked]>
Date: Thu, 21 Jul 2005 11:46:49 +0200

Hello!

The SRTCP index should not be padded with zeros to be 48 bits long.  This means
that, e.g., the labels will not be in the same octet position for SRTP and SRTCP.

Regards,
Karl

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Guoqiang Lu
> Sent: den 20 juli 2005 18:40
> To: [email-masked]
> Cc: [email-masked]; Mats Näslund (KI/EAB)
> Subject: [AVT] SRTCP key derivation
> 
> 
> Hi,
> My question is that SRTP index is a 48-bit quantity, should 
> the SRTCP 32-bit quantity "0 || SRTCP index" be patched with 
> 16 leading zeros?
> 
> Thanks!
> 
> Guoqiang Lu
> ESN: 39-36277
> Phone: (613) 763-6277
> [email-masked]