Subject: RE: Re-send: Simple estimate for Nr. of retransmissions (WAS:RE: [AVT] IESG comments on draft-ietf-avr-rtp-retransmission-11.txt - Issue 4: more parameters needed for RTX?)

From: "Jose Rey" <[email-masked]>
Date: Mon, 22 Aug 2005 14:21:57 +0200

Hi Magnus,

> Jose Rey wrote:
> > 
> > I have reviewed the details again and made the assumptions a bit 
> > clearer.  I still have one question to Magnus: you said the 
> > avg_rtcp_size would be around 125 bytes.  Is this based on your 
> > experience?
> > 
> 
> 125 bytes is a figure I use for correctly formed RTCP with 
> CNAME strings but still almost minimal assuming no extra 
> blocks than NACKs. If one actually uses more information then 
> this figure is of course larger. I think it is a reasonable 
> lower size of the RTCP packet even if smaller is possible.
> 
> Example
> 
>   40 IPv6
>    8 UDP
>   32 Receiver Report with 1 report block
>   29 SDES: CNAME (23 chars CNAME string)

Ok, I didn't know where these extra bytes came from. You put them in the CNAME, fine.

>   16 FB: NACK
> ====
> 125
> 
>  From the above it becomes obvious that shorter packets are 
> definitely smaller, but I don't see that any packet below 100 
> bytes are really useful in the discussed scenario and I think 
> there are a couple of other configurations that also end up 
> in around 125 bytes. For example the streaming case with 
> retransmission with SSRC multiplexing which becomes:
> 
>   20 IPv4
>    8 UDP
>   56 Receiver Report with 2 report block (Primary and RTX SSRC)
>   29 SDES: CNAME (23 chars CNAME string)
>   16 FB: NACK
> ====
> 129
> 
> A Sender packet is only 4 bytes smaller than the above due to 
> the SR + 1 report block.
> 
> Thus I feel it is a reasonable number, but definitely not the 
> only one one can use.

That is enough.  

I would like to know if we can call this finalised and send the text (including the packet counts above)to Mark Townsley for further progress.

Looking forward to your feedback,

José  

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Jose Rey" <[email-masked]>
Date: Thu, 25 Aug 2005 19:51:23 +0200

Magnus, all,

[snip]
>   56 Receiver Report with 2 report block (Primary and RTX SSRC)

This is actually 64 bytes for 2 SRs, but anyway, the idea is clear: one should take something more than 100 bytes to be meaningful for the calculations.

Therefore, it would be:

* avg_rtcp_size for SSRC-multiplexing case is approximated by 120 bytes.  This is a rounded-up average of 2 RTCP from senders, one for each SSRC, containing 40/8/28/32 bytes for IPv6/UDP/SR/SDES with CNAME, thus making 105 bytes each; and a RTCP from receiver with 40/8/64/32 bytes for IPv6/UDP/2*RR/SDES, making 157 bytes, thus (157+105+105)/3=117,3~=120 bytes.  This does not contain any NACKs, that would mean and addition of (12+4*N)/3 bytes.

I send the text proposal to IESG and WG right after this email.

Cheers,

José