Subject: [AVT] Re: Audio/Video and packet loss

From: lazzaro <[email-masked]>
Date: Sat, 22 Apr 2006 09:29:14 -0700

On Apr 22, 2006, at 9:00 AM, [email-masked] wrote:
> In general, which type of media flow (audio or video) is more  
> affected with packet loss in an IP network ???
>
> Is this just dependant on the CODEC algorithm used by the audio or  
> video or maybe there is a media that is more sensitive for any  
> given reason ???

In the limiting case of running a low-latency stream
and hitting a long dropout (many hundreds of
milliseconds), the video artifact (a still image) is
much less objectionable that the audio artifact
(a concealment algorithm hitting its limits of
pleasantness, or a dropout).   So, I'd say audio,
since its the limiting cases that tend to make
customers say "this is junk".

---
John Lazzaro
http://www.cs.berkeley.edu/~lazzaro
lazzaro [at] cs [dot] berkeley [dot] edu
---

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Marshall Eubanks" <[email-masked]>
Date: Mon, 24 Apr 2006 19:22:42 -0400

Here is one thing to amplify what Dave said  :

In many video codecs, some bits count for more than others. For example,
if you loose part of an I frame in a MPEG video encoding, the
entire Group of Pictures, potentially several seconds, may be corrupted.

Worse, the more important frames tend to be bigger, and thus in many cases
will be more likely to be dropped. A I frame may be split into a
number of packets (say, N) right at the MTU size, for example, while P
frames may be smaller than your MTU. If the packet loss is random, the
I frame right away is N times more likely to be lost, while some
networks, faced with congestion, may drop the biggest packets
preferentially.

Note, too, that the first P frame is more important than the last one in a GOP.

In many audio codecs, each packet is more or less equal in importance,
and of more or less equal size.

So, I have had cases where each I frame is 10 MTU sized packets, and
everything else is smaller than an MTU.  Total send rate was about 100
packets per second, the GOP being several seconds, The packet loss
rate might then be below 10^-2 with the audio sounding fine and the
video looking like a mess more or less continually.

Regards
Marshall

---

From: "Thomas Stockhammer" <[email-masked]>
Date: Wed, 26 Apr 2006 00:41:51 +0200

Dear all,

I think it is quite difficult to make a general statement here.

In my opinion a final answer depends on 
- the loss statistic, bursty or statistically independent, 
- the video (en)coding algorithms

Audio can deal quite well with sporadic single losses. In case of bursts,
things get annoying.

For video, a single loss can cause a long perceived burst due to error
propagation. The error burst is in general perceived as more disturbing than
a single loss for audio packets.

However, if error propagation can be avoided by any means, e.g. the use of
M-JPEG, very frequent intra, smart combinations with AVPF, etc., then the
losses are subjectively less annoying even for video. Losses just result in
variable frame rates then. 

In case of a burst error, video usually freezes the last correctly decoded
frame which is not too annoying compared to broken audio.

So in general to answer the question, more information would be necessary on
- the expected loss statistics (bursty, burst sizes, frequency)
- the video (en)coding in use.

Comments are very welcome

Best

Tom

=============================
URL: http://www.nomor.de/
Nomor Research, Germany
=============================

> -----Original Message-----
> From: Marshall Eubanks [mailto:[email-masked]]
> Sent: Tuesday, April 25, 2006 1:23 AM
> To: lazzaro
> Cc: [email-masked]
> Subject: Re: [AVT] Re: Audio/Video and packet loss
>