Subject: [AVT] Re: avt Digest, Vol 24, Issue 18

From: lazzaro <[email-masked]>
Date: Tue, 18 Apr 2006 10:47:09 -0700

On Apr 18, 2006, at 9:00 AM, [email-masked] wrote:

> Another separate channel between endpoints introduces a lot of  
> problems:
> a) Extra channel to prop open with STUN/TURN/etc, or hard-configure  
> into
>    a symmetric NAT.

---
John Lazzaro
http://www.cs.berkeley.edu/~lazzaro
lazzaro [at] cs [dot] berkeley [dot] edu
---

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: lazzaro <[email-masked]>
Date: Tue, 18 Apr 2006 10:58:37 -0700

> a) Extra channel to prop open with STUN/TURN/etc, or hard-configure  

I'd be more sympathetic of an initiative to virtualize ports
in the IETF multimedia stack, than I am of the philosophy
of making all new architectural decisions with an eye to
keeping the number of ports used by the stack fixed.

Port virtualization would be analogous of our history
with header compression.  When it became apparent
that wireless applications needed to be more conservative
of bits than wired Internet applications, we didn't change
the way we designed headers in the base protocols.
Instead, we define header compression schemes to let
those who have severe bandwidth constraints get by.

---
John Lazzaro

---

From: Randell Jesup <[email-masked]>
Date: Tue, 18 Apr 2006 18:04:00 -0400

lazzaro <[email-masked]> writes:

>> Another separate channel between endpoints introduces a lot of  problems:
>> a) Extra channel to prop open with STUN/TURN/etc, or hard-configure  into
>>    a symmetric NAT.
>
>

YES.  The current problems with large numbers of ports (especially with
things like SVC) is a real issue, especially with ICE/TURN.  I made a
proposal here (on 4-apr-2006) for a Very Simple alternate transport type
like:

c=IN IP4/PLEX 23.45.67.89 1234
m=audio 2 RTP/AVP 0
m=video 4 RTP/AVP 99
a=rtpmap:99 H999/90000

Packet data could be something like:
[short plex_port]
[datagram]

If you want to look it up, the message-id is <[email-masked]>

-- 
Randell Jesup, Worldgate (developers of the Ojo videophone), ex-Amiga OS team
[email-masked]

---

From: lazzaro <[email-masked]>
Date: Tue, 18 Apr 2006 15:13:22 -0700

> c=IN IP4/PLEX 23.45.67.89 1234

If we're going to go down this road, I think we
need to at least open up the possibility to virtualize ports
for the entire multimedia stack -- SIP, RTSP, RTP, everything.

If what "the world" wants is a single physical port
to open at firewalls for media, a port virtualization scheme
to makes "the world" happy will need to cover the
entire stack.

So, SDP may not be the thing we want to change --
SDP stays backward compatible, but the ports it
references are virtual ports, and some other part
of the stack makes the virtual-to-physical mapping.

---
John Lazzaro