Subject: [AVT] Question from IANA abut registry for WAV and AVI codecs

From: Cullen Jennings <[email-masked]>
Date: Wed, 10 Oct 2007 11:12:30 -0700

I have tried to reach the authors of these registrations but failed  
to resolve the issue. Does anyone know if we have the wrong values in  
the registry and is so can you please suggest what values should be  
in the registry.

Thanks, Cullen <with my AD hat on>

Begin forwarded message:

>>>
>>>
>>> On Mon Aug 13 18:16:20 2007, [email-masked] wrote:
>>>>> Can you provide the URL for which registry you are referring to?
>>>>
>>>> Sure thing:
>>>>
>>>> http://www.iana.org/assignments/wave-avi-codec-registry
>>>>
>>>> It seems that AC3 and DVM are mixed up. Or at least, I know a  
>>>> Format
>>>>    Tag of 0x2000 means AC3 for sure.
>>>>
>>>> I found this because of an AVI that wouldn't play sound. It's  
>>>> tag was
>>>>    0x2000 and I looked it up in the registry (which identifies  
>>>> it as
>>>>    DVM). I searched for the namespace type (audio/
>>>> vnd.wave;codec=2000)
>>>>    and found this:
>>>>
>>>> http://forum.doom9.org/archive/index.php/t-34712.html
>>>>
>>>> [quote]
>>>> For instance, Tag2000 is AC3, yet in the RFC, AC3 is listed as  
>>>> Tag92.
>>>>    It is the only listing for AC3 in the RFC :
>>>> [snip]
>>>> Furthermore, tag2000 is in the list, but is listed as DVM. What in
>>>> the
>>>>    world is DVM?
>>>> [/quote]
>>>>
>>>> I'd like to provide an automatic codec download service, and I
>>>> planned
>>>>    on using RFC 2361 as a reference. I can easily swap these  
>>>> two, but
>>>>    I'm wondering if there are other entries that need fixing.
>>>> -SHAWN-
>>>>
>>>>
>>>
>>
>

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Even, Roni" <[email-masked]>
Date: Thu, 11 Oct 2007 10:18:46 +0200

Cullen,
Searching I found that DVM is also Dolby AC3, probably different format

FAST Multimedia AG DVM (Dolby AC3)
http://www.codeclibrary.com/details.php?code=0x2000

Roni
> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Wednesday, October 10, 2007 8:13 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Question from IANA abut registry for WAV and AVI codecs
> 
>