Subject: [AVT] ZRTP and cryptographic transforms in SRTP

From: "Erwin Davis" <[email-masked]>
Date: Thu, 29 Nov 2007 18:29:54 -0500

Hello, Alan,Philip

SRTP is open to supports more than one cryptographic transforms. It seems
that ZRTP is used to create a shared key but
doesnot negotiate the common cryptographic transform between two parties. If
it is right, will a separate mechanism be used
to accomplish this? how? Thanks,
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Philip Zimmermann <[email-masked]>
Date: Thu, 29 Nov 2007 18:10:01 -0800

But ZRTP does in fact negotiate what kind of block cipher will be  
used in SRTP.  Is that what you mean?

On Nov 29, 2007, at 3:29 PM, Erwin Davis wrote:

> Hello, Alan,Philip
>
> SRTP is open to supports more than one cryptographic transforms. It  
> seems that ZRTP is used to create a shared key but
> doesnot negotiate the common cryptographic transform between two  
> parties. If it is right, will a separate mechanism be used

----------------------------------------------
Philip R Zimmermann        [email-masked]
http://philzimmermann.com  tel +1 650 322-7223
(spelled with 2 n's)       fax +1 650 322-7877

---

From: "Erwin Davis" <[email-masked]>
Date: Thu, 29 Nov 2007 23:37:39 -0500

Hi, Philip,

thanks, By the way, is any reason ZRTP Cipher Type Block doesnot include
AES-f8 which is defined as optional RFC3711?

Regards,

e