Subject: [AVT] Question regarding sequence numbers in RTP

From: Marian Kechlibar <[email-masked]>
Date: Thu, 22 May 2008 10:47:29 +0200

Dear AVT Team,

I am currently implementing my own version of RTP, and I have met a 
problem with understanding the RFC describing the RTP protocol.
Namely, how are the sequence numbers generated? If one side of the RTP 
communication creates two streams within one session (say, audio
and video), they will two different SSRC IDs (will they? I believe so), 
but what about the sequence numbers? Is a single sequence used for
the two streams, or does every SSRC ID have its own sequence of numbers?

Best regards

Marian Kechlibar
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: Dave Singer <[email-masked]>
Date: Thu, 22 May 2008 18:16:06 -0700

>the two streams, or does every SSRC ID have its own sequence of numbers?

each stream has its own sequence numbers (and their own random 
initial value too)

-- 
David Singer
Apple/QuickTime