Subject: Re: [AVT]ìö‘` : Question regarding sequence numbers in RTP

From: Dave Singer <[email-masked]>
Date: Fri, 23 May 2008 12:50:47 -0700

At 9:28  +0800 23/05/08, Roy wrote:
>Hi Dave, and all,
>
>What about the SSRC in the two streams?
>Given the sources is the identical one, should 
>the SSRCs in the streams be the same one or not?

I needed to check, but I think they can be the 
same or different (I think).  Maybe someone else 
has a definitive answer.

p.s. do you know Yingjia Lin?

>
>Best regards,
>Roy YueÅi¿÷î|ã Åj
>Research & Std Dept. App & Service Product Line
>Huawei Technologies CO., LTD P.R. of China
>Tel:+86 25 84676056
>Fax:+86 25 84676060
>Mobile:+86 138 09030401
>Email:[email-masked]
>
>********************************************************************
>This email and its attachments contain 
>confidential information from HUAWEI, which is 
>intended only for the person or entity whose 
>address is listed above. Any use of the 
>information contained herein in any way 
>(including, but not limited to, total or partial 
>disclosure, reproduction, or dissemination) by 
>persons other than the intended recipient(s) is 
>prohibited. If you receive this e-mail in error, 
>please notify the sender by phone or email 
>immediately and delete it!
>********************************************************************
>
>
>-----" åèå¥åè-----
>…¢åèêl: [email-masked] [mailto:[email-masked]] ë“ï\ Dave Singer
>…¢ëó ±º”: 2008îN5åé23ì™ Roy 9:16
>ùæåèêl: Marian Kechlibar; [email-masked]
>éÂÃ’: Re: [AVT] Question regarding sequence numbers in RTP
>
>At 10:47  +0200 22/05/08, Marian Kechlibar wrote:
>  >Dear AVT Team,
>  > 
>  >I am currently implementing my own version of RTP, and I have met a
>  >problem with understanding the RFC describing the RTP protocol.
>  >Namely, how are the sequence numbers generated? If one side of the RTP
>  >communication creates two streams within one session (say, audio
>  >and video), they will two different SSRC IDs (will they? I believe so),
>  >but what about the sequence numbers? Is a single sequence used for
>  >the two streams, or does every SSRC ID have its own sequence of numbers?
>
>each stream has its own sequence numbers (and their own random
>initial value too)
>
>  > 
>  >Best regards
>  > 
>  >Marian Kechlibar
>  >_______________________________________________
>  >Audio/Video Transport Working Group
>  >[email-masked]
>  >https://www.ietf.org/mailman/listinfo/avt
>
>
>--
>David Singer
>Apple/QuickTime
>_______________________________________________
>Audio/Video Transport Working Group
>[email-masked]
>https://www.ietf.org/mailman/listinfo/avt

-- 
David Singer
Apple/QuickTime

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Fri, 23 May 2008 21:49:01 +0100

On 23 May 2008, at 20:50, Dave Singer wrote:
>> Given the sources is the identical one, should the SSRCs in the  
>> streams be the same one or not?
>
> I needed to check, but I think they can be the same or different (I  
> think).  Maybe someone else has a definitive answer.

The SSRCs should each be randomly chosen, with collision detection  
for other sources in each session. It's extremely unlikely that  
they'll be the same.

The association between two different sources should be done using  
the RTCP CNAME.

-- 
Colin Perkins
http://csperkins.org/