Subject: Re: [AVT] I-DAction:draft-lennox-avt-rtp-layered-encoding-timestamps-00.txt

From: "Allison, Art" <[email-masked]>
Date: Thu, 12 Jun 2008 13:40:50 -0400

Can someone please provide a pointer to the RFC for sending HE-AACv2 over RTP?
Of interest is considering the applicability of this draft to synchronizing that audio codec with SVC coded AVC.

Thanks,
Art
Art Allison

Director Advanced Engineering, Science and Technology
 
National Association of Broadcasters
1771 N Street NW
Washington, DC 20036
Phone  202 429 5418 
Fax  202 775 4981
www.nab.org

Advocacy  Education  Innovation

|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On 
|Behalf Of David R Oran
|Sent: Thursday, June 12, 2008 1:14 PM
|To: Colin Perkins
|Cc: [email-masked]; MARJOU Xavier RD-CORE-LAN; [email-masked]
|Subject: Re: [AVT] 
|I-DAction:draft-lennox-avt-rtp-layered-encoding-timestamps-00.txt
|
|
|On Jun 12, 2008, at 1:08 PM, Colin Perkins wrote:
|
|> Hi,
|>
|> I have no particular objection to this proposal in itself, but I 
|> believe that using the same SSRC across multiple layers is 
|> undesirable, and when different SSRC values are used for each layer, 
|> this proposal offers no benefit.
|>
|> While using the same SSRC for each layer is simpler for some 
|case, it 
|> makes multiplexing several layers onto the same session 
|difficult (the 
|> suggestion below to demultiplex based on the RTP payload 
|type doesn't 
|> work). Since managing multiple UDP ports is difficult, I 
|would expect 
|> that multiplexing several layers onto the same port, with 
|media-aware 
|> RTP translators dropping layers at network boundaries to perform 
|> adaptation, to be a common use case, and not something we should 
|> break.
|>
|I agree with Colin. I wonder if there might be a way to get 
|the desired behavior here by pre-signaling the SSRCs and 
|indicating in the SDP that the set of SSRCs of the layers 
|share a media clock and hence a timestamp domain, so you can 
|synchronize without relying on the more general RTCP mechanisms?
|
|> Colin
|>
|>
|>
|> On 10 Jun 2008, at 09:57, [email-masked] wrote:
|>> Hi,
|>>
|>> I fully agree to the main goal of this draft. Simplicity is a
|>> guarantee of efficiency, notably for IPTV services.  Allowing a
|>> common timestamp resolve the very important problem of latency to
|>> access a video. This proposal is consistent with the SVC streams,
|>> because all the layers and all the sessions  come from a single
|>> source. So it makes sense to have the same SSRC and the same TS for
|>> all the layers, particularly since encoding layers use the same
|>> clock. Maybe it could be accurate to precise this draft does not
|>> apply to encoding schemes from multiple independent sources (I
|>> heard about sensor networks).
|>>
|>> About security considerations, in my understanding multiple keys
|>> may be a benefit because it allows several quality to the user
|>> depending of its account.
|>>
|>> From another point of view, I understand it is always possible to
|>> multiplex some layers in the same RTP session with the same SSCR
|>> and the same TS, by the different dynamic Payload Types of each
|>> layer, as it is mandatory for SVC streams. This draft brings some
|>> consistency to the multiplexing of part of encoding layers in a
|>> same RTP session, that already share the same TS, as described in
|>> draft-ietf-avt-rtp-svc-10.txt, ch 9.3.2
|>>
|>> Regards,
|>>
|>> Gérard BABONNEAU
|>>
|>>
|>>> De : [email-masked] [mailto:i-d-announce-
|>>> [email-masked]] De la part de [email-masked] Envoyé :
|>>> mardi 3 juin 2008 01:00 À : [email-masked] Objet : I-D
|>>> Action:draft-lennox-avt-rtp-layered-encoding-timestamps-00.txt A
|>>> New Internet-Draft is available from the on-line Internet-Drafts
|>>> directories. Title : Real-Time Transport Protocol (RTP) Timestamps
|>>> for Layered Encodings Author(s) : J. Lennox, et al. Filename :
|>>> draft-lennox-avt-rtp-layered-encoding-timestamps-00.txt
|>>> Pages           : 8 Date : 2008-06-02 The Real-Time Transport
|>>> Protocol (RTP) specification defines how layered encodings can be
|>>> sent over a layered transmission system. A source can stripe the
|>>> progressive layers of a hierarchically represented signal across
|>>> multiple RTP sessions, each carried on, for example, its own
|>>> multicast group. These layered encodings are given special
|>>> treatment in RTP, notably in that the same synchronization source
|>>> (SSRC) identifier space is used across the sessions of all layers.
|>>> The RTP protocol specification does not, however, explicitly state
|>>> how RTP timestamps are to be used with layered encodings. This
|>>> document updates the RTP specification to require that RTP
|>>> timestamps for layered encodings be synchronized, i.e. that every
|>>> layer chooses the same random initial value for the timestamp. A
|>>> URL for this Internet-Draft is: http://www.ietf.org/internet-
|>>> drafts/draft-lennox-avt-rtp-layered-encoding-timestamps-00.txt
|>>> Internet-Drafts are also available by anonymous FTP at: ftp://
|>>> ftp.ietf.org/internet-drafts/ Below is the data which will enable
|>>> a MIME compliant mail reader implementation to automatically
|>>> retrieve the ASCII version of the Internet-Draft.
|>>
|>> -- 
|>> 
|>> BABONNEAU Gerard RD-MAPS-REN
|>> REN/MAPS/DPC
|>> Tel : +33 299124008
|>> Email: [email-masked]
|>> R&D Rennes 4, rue du Clos-Courtel - BP 91226 - 35512 Cesson-Sevigne
|>> Cedex - France
|>>
|>>
|>> Mailer ThunderBird sous Mandriva
|>> Installez simplement votre poste de travail Linux avec http://
|>> web2000.rd.francetelecom.fr
|>> 
|>>
|>>
|>> 
|>> _______________________________________________
|>> Audio/Video Transport Working Group
|>> [email-masked]
|>> https://www.ietf.org/mailman/listinfo/avt
|>
|>
|>
|> -- 
|> Colin Perkins
|> http://csperkins.org/
|>
|>
|>
|> _______________________________________________
|> Audio/Video Transport Working Group
|> [email-masked]
|> https://www.ietf.org/mailman/listinfo/avt
|
|_______________________________________________
|Audio/Video Transport Working Group
[email-masked]
|https://www.ietf.org/mailman/listinfo/avt
|
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Thu, 12 Jun 2008 18:49:40 +0100

You synchronise audio and video streams by matching up the RTCP  
CNAMES, and using the information in RTCP SR packets to align the  
timelines.

Colin

On 12 Jun 2008, at 18:40, Allison, Art wrote:
> Of interest is considering the applicability of this draft to  
> synchronizing that audio codec with SVC coded AVC.
>
> Thanks,
> Art
> Art Allison
>

-- 
Colin Perkins
http://csperkins.org/