Subject: Re: [AVT] draft-ietf-avt-rtp-vorbis confusion

From: Luca Barbato <[email-masked]>
Date: Tue, 10 Jun 2008 11:32:27 +0200

Remi Denis-Courmont wrote:
> De:	Luca Barbato <[email-masked]>
> 
>> the Identification and the Setup MUST be
>> packed as they are, while the comment
>> header MAY be replaced with a dummy
>> one.
> 
> Yeah - but what is a "dummy" comment header?
> This is not defined in the I-D nor the Vorbis spec.

The vorbis spec defines the minimal header accepted. A sender could put 
there a string like "Program - Version" or just "".

"an empty one" "a different one" "a smaller one" would sound better?

> And how does this translate into the "number of headers" field,
> that comes at the beginning of the packed configuration packet?
> This does not seem to be specified anywhere.
> Add to that, that the xiph-rtp Vorbis example code does not sout of date,
> recipe for IOP failure.

gstreamer and lscube have fully interoperable independent implementations.

>>> A possibly more serious problem
>>> concerns the 2-bytes length which is
>>> prepended to "packets". The text
>>> seems to imply that, in the case of a
>>> fragmented packet, the field is found
>>> once at the beginning of the first
>>> fragment, and encodes the whole
>>> (defragmented) packet length.
> 
>> Could you point me/us the exact line?
> 
> The first sections imply that each Vorbis packet is prepended with a 2 byte length.
> That would "intuitively" mean that the 2-byte length is part of the fragmented data
> (like the UDP length of a fragmented IPv4 packet).

I spent some time to disambiguate the use of packet/payload and any word 
that may refer to the rtp payload or a group of samples encoded in a 
vorbis frame and the people requesting that were happy in the end.

> You however indicate that EACH fragment contains a length field at its beginning.
> This is consistent with the fragmentation examples, but counter-intuitive and
> contradicts my understanding of the previous sections.

This has been discussed before...

lu

-- 

Luca Barbato
Gentoo Council Member
Gentoo/linux Gentoo/PPC
http://dev.gentoo.org/~lu_zero

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: "Remi Denis-Courmont" <[email-masked]>
Date: Tue, 10 Jun 2008 10:45:13 +0300

> header MAY be replaced with a dummy

Yeah - but what is a "dummy" comment header? This is not defined in the I-D nor the Vorbis spec.

And how does this translate into the "number of headers" field, that comes at the beginning of the packed configuration packet? This does not seem to be specified anywhere. Add to that, that the xiph-rtp Vorbis example code does not sout of date, recipe for IOP failure.

(...)

> Could you point me/us the exact line?

The first sections imply that each Vorbis packet is prepended with a 2 byte length. That would "intuitively" mean that the 2-byte length is part of the fragmented data (like the UDP length of a fragmented IPv4 packet).

You however indicate that EACH fragment contains a length field at its beginning. This is consistent with the fragmentation examples, but counter-intuitive and contradicts my understanding of the previous sections. In practice, both approaches work BUT the document ought to state how this works a LOT more explicitly. It cannot rely on schematics only.

-- 
Rémi Denis-Courmont
VideoLAN/VLC core developper