Subject: [AVT] Fwd: I-D Action:draft-ott-avt-rtcp-guidelines-01.txt

From: Colin Perkins <[email-masked]>
Date: Sun, 15 Jun 2008 12:23:19 +0100

We've just submitted an update to the RTCP guidelines draft. Comments  
are welcome - we'd like this to be considered as a working group draft.

Colin

Begin forwarded message:
> From: [email-masked]
> Date: 15 June 2008 11:15:01 BDT
> To: [email-masked]
> Subject: I-D Action:draft-ott-avt-rtcp-guidelines-01.txt
> Reply-To: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts  
> directories.
>
> 	Title           : Guidelines for Extending the RTP Control  
> Protocol (RTCP)
> 	Author(s)       : J. Ott, C. Perkins
> 	Filename        : draft-ott-avt-rtcp-guidelines-01.txt
> 	Pages           : 17
> 	Date            : 2008-06-15
>
> The RTP Control Protocol (RTCP) is used along with the Real-time
> Transport Protocol (RTP) to provide a control channel between media
> senders and receivers.  This allows constructing a feedback loop to
> enable application adaptivity and monitoring, among other uses.  The
> basic reporting mechanisms offered by RTCP are generic, yet quite
> powerful and suffice to cover a range of uses.  This document
> provides guidelines on extending RTCP if those basic mechanisms prove
> insufficient.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ott-avt-rtcp- 
> guidelines-01.txt

-- 
Colin Perkins
http://csperkins.org/

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: "Ingemar Johansson S" <[email-masked]>
Date: Mon, 16 Jun 2008 11:18:46 +0200

Hi

First of all I support that this becomes a working group draft

A few comments to the draft :

The guidelines section is a tricky area as much use for RTCP is
specified in many different foras. Examples are OMA PoC where RTCP APP
is used. Another use is the speech codec adapation defined in 3GPP
TS26.114 which also use RTCP APP. Besides this there may be more
application specific (or standards-forum) specific exotic use of RTCP
emerging. 
While I am in some sense in favor of such extensions (also found guilty
of helping to introduce one) I understand fully the worries expressed in
the draft that this is a potential problem e.g in terms of
interoperability between systems which may in the end introduce more
complexity in gateways. 
IETF cannot probably prevent this from happening but I believe that the
draft may cause implementors to stop and think a bit more (and wider)
before implementing extensions. 

Multicast is one factor to consider throughout the design but personally
I don't even bother with multicast and I have a feeling that it may be a
feeling shared by others active in other standards fora. Why should we
bother with multicast in the design if we know for sure that this
particular extension is not intended for multicast use?. I am not saying
that we should forget about multicast but I believe that some amount of
relaxation that allows the implementor to "unthink" multicast or huge
groups may be useful (together with a requirement to recognize the
limitation). I believe that many implementors think this way already so
I probably kick in an open door.

Regards
Ingemar

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: den 15 juni 2008 21:00
> To: [email-masked]
> Subject: avt Digest, Vol 50, Issue 12
> 
> Send avt mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it is more 
> specific than "Re: Contents of avt digest..."
> 
> 
> Today's Topics:
> 
>    1. Fwd: I-D Action:draft-ott-avt-rtcp-guidelines-01.txt
>       (Colin Perkins)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Sun, 15 Jun 2008 12:23:19 +0100
> From: Colin Perkins <[email-masked]>
> Subject: [AVT] Fwd: I-D Action:draft-ott-avt-rtcp-guidelines-01.txt
> To: [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=US-ASCII; delsp=yes; format=flowed
> 
> We've just submitted an update to the RTCP guidelines draft. 
> Comments are welcome - we'd like this to be considered as a 
> working group draft.
> 
> Colin
> 
> 
> 
> 
> Begin forwarded message:
> > powerful and suffice to cover a range of uses.  This 
> document provides 
> > guidelines on extending RTCP if those basic mechanisms prove 
> > insufficient.
> >
> ------------------------------
> 
> End of avt Digest, Vol 50, Issue 12
> ***********************************
>