Subject: [AVT] how to identify a RTP session

From: "Rockson Li (zhengyli)" <[email-masked]>
Date: Fri, 28 Nov 2008 11:48:04 +0800

Hi folks,
 
Recently, I am confused on the identity of a RTP session.
 
per RFC3550
 
   RTP session: An association among a set of participants
      communicating with RTP.  ...  A participant distinguishes
      multiple RTP sessions by reception of different sessions using
      <NOTE>different pairs of destination transport addresses,</NOTE>
where a pair
      of transport addresses comprises one network address plus a pair
      of ports for RTP and RTCP. 
 
So I draw the conclusion as follows,
 
a RTP session is identified as a network plus two destination ports(RTP
&& RTCP port).
 
therefore suppose two SIP UAs taking with each other on unicast UDP.
 
UA1
UA2
IP: ip1
IP: ip2
RTP port: port1
RTP port: port2
RTCP port: port1+1                                                  RTCP
port: port2+1

so there will be two destination paris (ip1+ (port1,port1+1)),
(ip2+(port2,port2+1))
so based on definition above, this should be thought as two RTP
sessions, shouldn't it?
 
However, the same section of RFC3550.
 
<snip>
      For example, consider a three-
      party conference implemented using unicast UDP with <NOTE>each
      participant receiving from the other two on separate port
pairs.</NOTE>
      If each participant sends RTCP feedback about data received from
      one other participant only back to that participant, then the
      conference is composed of three separate point-to-point RTP
      sessions. 
</snip>
 
why there're only three RTP sessions, I think it should be six?
since "each participant receiving from the other two on separate port
pairs"
which means each pariticipant should listen on two separate port paris
for incoming RTP packets, 
so there're two RTP sessions for each participant, and should be six for
three participants.
 
Confunsed....
 
any ideas?
 
thanks
 
Regards,
-Rockson
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: Evgeniy Khramtsov <[email-masked]>
Date: Fri, 28 Nov 2008 16:34:01 +0900

>so there're two RTP sessions for each participant, and should be six for
+1. I'm also confused and still can't find the answer.

-- 
Regards,
Evgeniy Khramtsov, ProcessOne.
xmpp:[email-masked].

---

From: Colin Perkins <[email-masked]>
Date: Fri, 28 Nov 2008 20:24:31 +0000

The basic idea is that if the participants share a single SSRC space,  
they form a single RTP session.

Colin

On 28 Nov 2008, at 03:48, Rockson Li (zhengyli) wrote:
>       <NOTE>different pairs of destination transport addresses,</ 
> NOTE> where a pair
> a RTP session is identified as a network plus two destination ports 
> (RTP && RTCP port).
>
> IP:  
> ip1                                                                    
> RTP port:  
> port1                                                        RTP  
> port: port2
> RTCP port: port1+1                                                   
> RTCP port: port2+1
> so there will be two destination paris (ip1+ (port1,port1+1)), (ip2+ 
> (port2,port2+1))
> since "each participant receiving from the other two on separate  
> port pairs"
> which means each pariticipant should listen on two separate port  
> paris for incoming RTP packets,
> so there're two RTP sessions for each participant, and should be  
> six for three participants.
>
> Confunsed....
>
> any ideas?
>
> thanks
>
> Regards,
> -Rockson

-- 
Colin Perkins
http://csperkins.org/

---

From: "Rockson Li (zhengyli)" <[email-masked]>
Date: Sat, 29 Nov 2008 19:33:23 +0800

Colin,
 
What do you mean by SSRC space, can you share me with an example?
 
I think SSRC just identify a stream.
And each RTP session is able to include several streams.
 
thanks
 
Regards,
-Rockson 
________________________________

From: Colin Perkins [mailto:[email-masked]] 
Sent: Saturday, November 29, 2008 4:25 AM
To: Rockson Li (zhengyli)
Cc: [email-masked]; [email-masked]
Subject: Re: [AVT] how to identify a RTP session

Colin

	Hi folks,

	per RFC3550
	 
	   RTP session: An association among a set of participants
	      communicating with RTP.  ...  A participant distinguishes
	      multiple RTP sessions by reception of different sessions
using
	      <NOTE>different pairs of destination transport
addresses,</NOTE> where a pair
	      of transport addresses comprises one network address plus
a pair
	      of ports for RTP and RTCP. 

	a RTP session is identified as a network plus two destination
ports(RTP && RTCP port).
	 
	therefore suppose two SIP UAs taking with each other on unicast
UDP.
	 
	UA1
UA2
	IP: ip1
IP: ip2
	RTP port: port1
RTP port: port2
	RTCP port: port1+1
RTCP port: port2+1

	 
	<snip>
	      For example, consider a three-
	      party conference implemented using unicast UDP with
<NOTE>each
	      participant receiving from the other two on separate port
pairs.</NOTE>
	      If each participant sends RTCP feedback about data
received from
	      one other participant only back to that participant, then
the
	      conference is composed of three separate point-to-point
RTP
	      sessions. 
	</snip>

	Confunsed....
	 
	any ideas?
	 
	thanks
	 
	Regards,
	-Rockson

-- 
Colin Perkins
http://csperkins.org/

---

From: Colin Perkins <[email-masked]>
Date: Sun, 30 Nov 2008 09:33:53 +0000

> And each RTP session is able to include several streams.

Right - and those streams each have their own SSRC, which can be seen  
by the other participants in the RTP session, and for which SSRC  
collisions can potentially occur. That's what I mean by a single SSRC  
space.

If you have a unicast session, with Alice and Bob in a VoIP call,  
that's a single SSRC space. Alice sees Bob's SSRC in his data and  
RTCP packets, and her RTCP SR/RR packets reference his SSRC, and he  
likewise is aware of her SSRC. Their SSRCs will be different, due to  
collision detection, and they have a single namespace for SSRC values.

On the other hand, if Alice and Bob are in a unicast multimedia call,  
their audio and video streams will be sent on different UDP ports,  
and the SSRC values used in the audio RTP session won't visible in  
the video RTP session, and vice versa. Those are two different SSRC  
spaces.

Colin

> The basic idea is that if the participants share a single SSRC  
> space, they form a single RTP session.
>
> Colin
>
>
>
>> RTCP port: port1 
>> +1                                                  RTCP port:  
>> port2+1
>> so there will be two destination paris (ip1+ (port1,port1+1)), (ip2 
>> +(port2,port2+1))

-- 
Colin Perkins
http://csperkins.org/