Subject: [AVT] [Fwd: I-D Action:draft-schierl-avt-rtp-ntp-for-layered-codecs-00.txt]

From: Thomas Schierl <[email-masked]>
Date: Thu, 15 Jan 2009 18:07:08 +0100

Dear all,

Please find attached submission of 
draft-schierl-avt-rtp-ntp-for-layered-codecs-00 proposing a NTP header 
extension carrying the NTP timestamp in a backward-compatible way to be 
used with timestamp-based decoding order recovery in layered codecs.

Thomas

-- 
Thomas Schierl
--------------
Fraunhofer HHI

----
Visit us at

FOE 2009 / Tokyo Big Sight, Japan / 21-23 January 2009 / Hall west, Booth 6-1
http://www.foe.jp/en/

Photonics West / San Jose Convention Center / 24-29 January 2009 / Booth 1801
http://spie.org

Subject: I-D Action:draft-schierl-avt-rtp-ntp-for-layered-codecs-00.txt
From: [email-masked]
To: [email-masked]
Date: Thu, 15 Jan 2009 08:15:03 -0800 (PST)
List-Id: Internet Draft Announcements only <i-d-announce.ietf.org>

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : RTP NTP header extension for decoding order recovery in layered codecs
	Author(s)       : T. Schierl
	Filename        : draft-schierl-avt-rtp-ntp-for-layered-codecs-00.txt
	Pages           : 12
	Date            : 2009-01-15

This memo describes an RTP header extension mechanism to be used 
with timestamp-based decoding order recovery of RTP flows containing 
layered codecs.  The header extension may be most useful in the 
presence of clock skew as well as for early decoding order recovery.  
The RTP header extension is based on [RFC5285] and extends the RTP 
header by the lower 56bit part of the NTP timestamp corresponding to 
the RTP timestamp of the same packet as defined in [RFC3550] for the 
RTCP sender reports.  This memo further gives guidance on how 
decoding order is recovered in RTP flows using the NTP timestamp 
information when parts of a layered, multi-view or multi-
descriptions coding media are transported in different RTP flows.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-schierl-avt-rtp-ntp-for-layered-codecs-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Thu, 15 Jan 2009 18:42:15 +0000

I've also submitted draft-perkins-avt-rapid-rtp-sync-01.txt. This  
describes a similar mechanism to Thomas' draft, and is based on a  
suggestion from Dave Singer that the a similar mechanism previously  
defined by ISMA could be of use for the layered codec synchronisation  
problem.

Colin

On 15 Jan 2009, at 17:07, Thomas Schierl wrote:
> Dear all,
>
> Please find attached submission of draft-schierl-avt-rtp-ntp-for- 
> layered-codecs-00 proposing a NTP header extension carrying the NTP  
> timestamp in a backward-compatible way to be used with timestamp- 
> based decoding order recovery in layered codecs.
>
> Thomas
>
>
> -- 
> Thomas Schierl
> --------------
> Fraunhofer HHI
>
>
>
>
>
> ----
> Visit us at
>
> Date: 15 January 2009 16:15:03 GMT
> Reply-To: [email-masked]
>
>
> Content-Type: text/plain
> Content-ID: <[email-masked]>
>

-- 
Colin Perkins
http://csperkins.org/