Subject: Re: [AVT] RTCP XR MIB implementation

From: sathesh edara <[email-masked]>
Date: Mon, 26 Jan 2009 21:34:45 -0800

>
>  Hi All,
>>    I would like to implement RTCP XR MIB in VOIP device, which  sits
>> between two IP phones..
>> Especially interested in  the  RTCP XR MIB variables in the following RTCP
>> XR MIB tables:
>>
>> RTCP XR MIB Variables:
>> =====================
>> A)rtcpXrCallQualityTable
>> -----------------------
>> 1)rtcpXrCallQualityRCQ
>> 2)rtcpXrCallQualityRLQ
>> 3)rtcpXrCallQualityExternalRCQ
>> 4)rtcpXrCallQualityMOSCQ
>> 5)rtcpXrCallQualityMOSLQ
>> 6)rtcpXrCallQualityRLQestAlgorithm
>> 7)rtcpXrCallQualityRCQestAlgorithm
>> 8)rtcpXrCallQualityMOSLQEstAlgorithm
>> 9)rtcpXrCallQualityMOSCQEstAlgorithm
>>
>> Here is my understanding on how to set/update these MIB variables in the
>> VOIP module:
>>
>> Once i get the  RTCP XR packet from the IP phone to VOIP device, In the
>> VOIP module i extract/parse the 'Voice metric report block'.
>>
>> The Voice metric RTCP XR packet gives the following information and assign
>> the value of MOS-CQ  to rtcpXrCallQualityMOSCQ,and MOS-LQ  to
>> rtcpXrCallQualityMOSLQ.
>>  Is my understanding correct?
>>
>> 1)MOS-LQ
>> 2)MOS-CQ
>> 3)R factor
>> 4)ext. R factor
>>
>> But how to get the other information on rtcpXrCallQualityRCQ
>> ,rtcpXrCallQualityRLQ ,rtcpXrCallQualityExternalRCQ
>> ,rtcpXrCallQualityRLQestAlgorithm,  rtcpXrCallQualityRCQestAlgorithm,
>> rtcpXrCallQualityMOSLQEstAlgorithm and rtcpXrCallQualityMOSCQEstAlgorithm
>> .
>>
>>
>>
>> IS IT POSSIBLE TO CALCULATE THE BELOW VARIABLES VALUES FROM THE ABOVE DATA
>> ???. If so what is the procedure?.
>>
>> 1)rtcpXrCallQualityRCQ
>> 2)rtcpXrCallQualityRLQ
>> 3)rtcpXrCallQualityExternalRCQ
>> 4)rtcpXrCallQualityRLQestAlgorithm
>> 5)rtcpXrCallQualityRCQestAlgorithm
>> 6)rtcpXrCallQualityMOSLQEstAlgorithm
>> 7)rtcpXrCallQualityMOSCQEstAlgorithm
>>
>> The block is encoded as seven 32-bit words:
>>     0                   1                   2                   3
>>     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>>    |     BT=7      |   reserved    |       block length = 8        |
>>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>>    |                        SSRC of source                         |
>>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>>    |   loss rate   | discard rate  | burst density |  gap density  |
>>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>>    |       burst duration          |         gap duration          |
>>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>>    |     round trip delay          |       end system delay        |
>>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>>    | signal level  |  noise level  |     RERL      |     Gmin      |
>>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>>    |   R factor    | ext. R factor |    MOS-LQ     |    MOS-CQ     |
>>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>>    |   RX config   |   reserved    |          JB nominal           |
>>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>>    |          JB maximum           |          JB abs max           |
>>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>>
>>
>> B) rtcpXrHistoryTable
>> =====================
>> 1)rtcpXrHistoryMaxDiscardRate
>> 2)rtcpXrHistoryAvgDiscardRate
>>
>> CAN I USE 'loss rate' and 'discard rate' INFORMATION IN  THE ABOVE VOICE
>> METRIC PKT TO CALCULATE HISTORY MAX AND AVG DISCARD RATE.
>>
>> Please kindly suggest the correct way of updating/setting of the above MIB
>> variable.
>>
>> If this is not the correct mailing list to post questions on RTCP XR MIB,
>> Please suggest me the right mailing list.
>>
>> Thanks & Regards,
>> Sathesh
>>
>
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: sathesh edara <[email-masked]>
Date: Mon, 26 Jan 2009 21:25:08 -0800

Hi All,
   I would like to implement RTCP XR MIB in VOIP device, which  sits between
two IP phones..
Especially interested in  the  RTCP XR MIB variables in the following RTCP
XR MIB tables:

RTCP XR MIB Variables:
=====================
A)rtcpXrCallQualityTable
-----------------------
1)rtcpXrCallQualityRCQ
2)rtcpXrCallQualityRLQ

Once i get the  RTCP XR packet from the IP phone to VOIP device, In the VOIP
module i extract/parse the 'Voice metric report block'.

1)MOS-LQ
2)MOS-CQ
3)R factor
4)ext. R factor

But how to get the other information on rtcpXrCallQualityRCQ
,rtcpXrCallQualityRLQ ,rtcpXrCallQualityExternalRCQ
,rtcpXrCallQualityRLQestAlgorithm,  rtcpXrCallQualityRCQestAlgorithm,
rtcpXrCallQualityMOSLQEstAlgorithm and rtcpXrCallQualityMOSCQEstAlgorithm .

1)rtcpXrCallQualityRCQ
2)rtcpXrCallQualityRLQ

B) rtcpXrHistoryTable
=====================

Thanks & Regards,
Sathesh