Subject: Re: [AVTCORE] Fw: I-D Action: draft-ietf-avtcore-monarch-02.txt

From: Colin Perkins <[email-masked]>
Date: Thu, 9 Jun 2011 14:58:43 +0100

On 27 May 2011, at 03:36, Qin Wu wrote:
> This version addresses the open issues regarding identity information repetition and acknowledge section.
> http://www.ietf.org/internet-drafts/draft-ietf-avtcore-monarch-02.txt
> 
> The diff is:
> http://tools.ietf.org/rfcdiff?url2=draft-ietf-avtcore-monarch-02
> 
> Comments are welcome!

This helps, but to my mind doesn't go far enough. We have the SSRC to identify participants. I don't see much benefit from having a separate identity tag in XR blocks.

-- 
Colin Perkins
http://csperkins.org/

---

From: Qin Wu <[email-masked]>
Date: Fri, 10 Jun 2011 16:59:35 +0800

Hi,
----- Original Message ----- 
From: "Colin Perkins" <[email-masked]>
To: "Qin Wu" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Thursday, June 09, 2011 9:58 PM
Subject: Re: [AVTCORE] Fw: I-D Action: draft-ietf-avtcore-monarch-02.txt

[Qin]:  I think that we are talking about how to define future RTCP XR Block. 
It seems to me the rule we are following  to define the new RTCP XR BLock in the avtcore-monarch is a little different from the rule of we are doing to the existing RTCP XR described in RFC3611.

As for the existing XR Block defined in RFC3611, each of the existing XR Block has allocated  a field for SSRC of source. However such identity information can be 
repeated several times if several metric blocks reporting one stream from one source  is carried in the same RTCP Packet.

In order to reduce overhead to carry duplicated SSRC of source in each metric block,  in the new XR Block, we separate such SSRC of source out from each metric block.

One way is to  allocate identity tag field in each metric block which can be used to tell which metric block report on stream from which source. 

Another way is to follow the existing rules defined in RFC3611.
put back the SSRC of source field into each metric block which also can be used to tell which metric block report on stream from which source. 
However this rule seems to contradict to the rule of reducing identity information repetition discussed in avtcore-monarch.

Which way we should follow?

-- 
Colin Perkins
http://csperkins.org/

---

From: Colin Perkins <[email-masked]>
Date: Tue, 14 Jun 2011 11:27:02 +0100

On 10 Jun 2011, at 09:59, Qin Wu wrote:
> [Qin]:  I think that we are talking about how to define future RTCP XR Block. It seems to me the rule we are following  to define the new RTCP XR BLock in the avtcore-monarch is a little different from the rule of we are doing to the existing RTCP XR described in RFC3611.
> 
> As for the existing XR Block defined in RFC3611, each of the existing XR Block has allocated  a field for SSRC of source. However such identity information can be repeated several times if several metric blocks reporting one stream from one source  is carried in the same RTCP Packet.
> 
> Another way is to follow the existing rules defined in RFC3611. put back the SSRC of source field into each metric block which also can be used to tell which metric block report on stream from which source. 

I think you should follow RFC 3611. 

The savings from using the new identity tag don't seem worth the added complexity.

-- 
Colin Perkins
http://csperkins.org/

---

From: Peter Musgrave <[email-masked]>
Date: Wed, 15 Jun 2011 08:41:22 -0400

I agree with Colin

Peter Musgrave
(as individual)

On Tue, Jun 14, 2011 at 6:27 AM, Colin Perkins <[email-masked]> wrote:

> >> Cc: <[email-masked]>; <[email-masked]>; <[email-masked]
> >
> >> This helps, but to my mind doesn't go far enough. We have the SSRC to
> identify participants. I don't see much benefit from having a separate
> identity tag in XR blocks.
> >>
> > [Qin]:  I think that we are talking about how to define future RTCP XR
> Block. It seems to me the rule we are following  to define the new RTCP XR
> BLock in the avtcore-monarch is a little different from the rule of we are
> doing to the existing RTCP XR described in RFC3611.
> >
> > As for the existing XR Block defined in RFC3611, each of the existing XR
> Block has allocated  a field for SSRC of source. However such identity
> information can be repeated several times if several metric blocks reporting
> one stream from one source  is carried in the same RTCP Packet.
> >
> > In order to reduce overhead to carry duplicated SSRC of source in each
> metric block,  in the new XR Block, we separate such SSRC of source out from
> each metric block.
> >
> > One way is to  allocate identity tag field in each metric block which can
> be used to tell which metric block report on stream from which source.
> >
> > Another way is to follow the existing rules defined in RFC3611. put back
> the SSRC of source field into each metric block which also can be used to
> tell which metric block report on stream from which source.
> > However this rule seems to contradict to the rule of reducing identity
> information repetition discussed in avtcore-monarch.
> >
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
>

---

From: Qin Wu <[email-masked]>
Date: Thu, 16 Jun 2011 17:33:16 +0800

Okay, I will revise the draft based on the rule in RFC3611.
  ----- Original Message ----- 
  From: Peter Musgrave 
  To: Colin Perkins 
  Cc: Qin Wu ; [email-masked] ; [email-masked] 
  Sent: Wednesday, June 15, 2011 8:41 PM
  Subject: Re: [AVTCORE] [xrblock] Fw: I-D Action: draft-ietf-avtcore-monarch-02.txt

  I agree with Colin

  Peter Musgrave
  (as individual)

    --
    Colin Perkins
    http://csperkins.org/

    [email-masked]

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Tue, 28 Jun 2011 14:47:32 +0200

>> This helps, but to my mind doesn't go far enough. We have the SSRC to identify participants. I don't see much benefit from having a separate identity tag in XR blocks.
Question for clarification:
do you question just the tag element of the proposed measurement identity block (draft-ietf-avt-rtcp-xr-meas-identity-02.txt), or do you want to get completely rid of the the measurement identity block as such?

Keeping in mind that the measurement identity block provides much more capabilities when just the SSRC of the measured stream.

Thanks,
Albrecht

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Peter Musgrave
Sent: Mittwoch, 15. Juni 2011 14:41
To: Colin Perkins
Cc: [email-masked]; [email-masked]
Subject: Re: [AVTCORE] [xrblock] Fw: I-D Action: draft-ietf-avtcore-monarch-02.txt

I agree with Colin

Peter Musgrave
(as individual)

On Tue, Jun 14, 2011 at 6:27 AM, Colin Perkins <[email-masked]<mailto:[email-masked]>> wrote:
On 10 Jun 2011, at 09:59, Qin Wu wrote:
>> From: "Colin Perkins" <[email-masked]<mailto:[email-masked]>>
>> To: "Qin Wu" <[email-masked]<mailto:[email-masked]>>
>> Cc: <[email-masked]<mailto:[email-masked]>>; <[email-masked]<mailto:[email-masked]>>; <[email-masked]<mailto:[email-masked]>>

--
Colin Perkins
http://csperkins.org/

_______________________________________________
Audio/Video Transport Core Maintenance
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Tue, 28 Jun 2011 16:53:22 +0100

I was talking about the tag mechanism.

Colin

-- 
Colin Perkins
http://csperkins.org/