Subject: [AVTCORE] I-D Action: draft-ietf-avtcore-srtp-encrypted-header-ext-01.txt

From: [email-masked]
Date: Fri, 28 Oct 2011 16:41:49 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Audio/Video Transport Core Maintenance Working Group of the IETF.

	Title           : Encryption of Header Extensions in the Secure Real-Time Transport Protocol (SRTP)
	Author(s)       : Jonathan Lennox
	Filename        : draft-ietf-avtcore-srtp-encrypted-header-ext-01.txt
	Pages           : 13
	Date            : 2011-10-28

   The Secure Real-Time Transport Protocol (SRTP) provides
   authentication, but not encryption, of the headers of Real-Time
   Transport Protocol (RTP) packets.  However, RTP header extensions may
   carry sensitive information for which participants in multimedia
   sessions want confidentiality.  This document provides a mechanism,
   extending the mechanisms of SRTP, to selectively encrypt RTP header
   extensions in SRTP.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-avtcore-srtp-encrypted-header-ext-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-avtcore-srtp-encrypted-header-ext-01.txt

---

From: Jonathan Lennox <[email-masked]>
Date: Fri, 28 Oct 2011 19:48:37 -0400

I've just posted a new version of the header extension encryption draft.  I believe this version resolves all open issues and comments from the mailing list and from the last IETF, including a resolution of the AEAD issue that David McGrew and I worked out in Montréal.  (For a full list of changes, see the "Changes" appendix in the draft.)

This version adds test vectors for the header extension encryption process; it'd be great if someone could independently double-check these for me.

Other than that, this is, as far as I know, ready for WGLC.  Note also that this is a dependency of the audio-levels drafts in AVTExt.

On Oct 28, 2011, at 7:41 PM, <[email-masked]> wrote:

> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
> 

--
Jonathan Lennox
[email-masked]