Subject: [AVTCORE] RTP Multiplexing Architecture => term "media stream"

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Fri, 6 Jul 2012 11:27:27 +0200

Ref.: http://tools.ietf.org/id/draft-westerlund-avtcore-multiplex-architecture-01.txt

Magnus,

just a short comment with respect to your definition:

Media Stream:  A sequence of RTP packets using a single SSRC that
      together carries part or all of the content of a specific Media
      Type from a specific sender source within a given RTP session.

=> a media stream may carry multiple different media formats of the same type, right?

If yes, then "media type" dependency might be a key characteristic of "media stream".

I'm wondering whether then the term "media stream" could be replaced by e.g. "media type stream" or "media type specific stream" or anything else, due to the fact that the term "media stream" is heavily used, often with slightly different semantics, in other contexts.

The update in your draft might be e.g.:

Media Type Specific Stream (briefly "Media Stream" in this document):  A sequence ...

BTW: the loosely usage of term "media stream" in RFC 3550 gives the impression that the "RFC 3550 media stream" is tight to a single media format in my understanding. Hm?

Any thoughts?
Albrecht

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 6 Jul 2012 13:10:27 +0200

On 2012-07-06 11:27, Schwarz, Albrecht (Albrecht) wrote:
> Ref.:
> http://tools.ietf.org/id/draft-westerlund-avtcore-multiplex-architecture-01.txt
>
>  Magnus,
> 
> together carries part or all of the content of a specific Media Type
> from a specific sender source within a given RTP session.
> 
> 

If you mean that a video source could be encoded using H.264 or MPEG-2
and what is in the media stream may be either of them at any given time.
The answer is yes.

> If yes, then "media type" dependency might be a key characteristic of

To certain degree it is. But there is several other properties that
defines a media stream. I think your proposal will simply be illogical
to people. However, we already have worked on the next version of the
multiplex-architecture document. It will be much clearer on the usage of
media stream thanks to Harald Alvestrand's work.

Cheers

Magnus

> 
> I'm wondering whether then the term "media stream" could be replaced
> by e.g. "media type stream" or "media type specific stream" or
> anything else, due to the fact that the term "media stream" is
> heavily used, often with slightly different semantics, in other
> contexts.
> 
> BTW: the loosely usage of term "media stream" in RFC 3550 gives the
> impression that the "RFC 3550 media stream" is tight to a single
> media format in my understanding. Hm?
> 
> 
> Any thoughts? Albrecht
> 
> 
> 

-- 

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------