Subject: Re: [AVTCORE] [Technical Errata Reported] RFC3711 (3420)

From: Robert Sparks <[email-masked]>
Date: Fri, 22 Mar 2013 10:26:31 -0500

Using the criteria at 
<http://www.ietf.org/iesg/statement/errata-processing.html> I recommend
putting this into Hold For Document Update.

( I could make an argument for Reject, given the text in 3550 is very 
clear, but a working group can make that decision if 3771 is ever revised).

On 11/28/12 9:13 AM, Karl Norrman wrote:
> Hello!
>
> I always considered the padding count to be part of the padding itself and hence it would be included in the encrypted portion.  However, the proposed errata below makes the text more explicit on this point.  So, if it can avoid some interoperability problems I'm all for accepting it.
>
> BR
> Karl
>
>
>> -----Original Message-----
>> From: RFC Errata System [mailto:[email-masked]]
>> Sent: den 28 november 2012 15:32
>> To: [email-masked]; [email-masked];
>> [email-masked]; Mats Näslund; Karl Norrman; Gonzalo
>> Camarillo; [email-masked];
>> [email-masked]; [email-masked]
>> Cc: [email-masked]; [email-masked];
>> [email-masked]
>> Subject: [Technical Errata Reported] RFC3711 (3420)
>>
>>
>> The following errata report has been submitted for RFC3711,
>> "The Secure Real-time Transport Protocol (SRTP)".
>>
>> --------------------------------------
>> You may review the report below and at:
>> http://www.rfc-editor.org/errata_search.php?rfc=3711&eid=3420
>>
>> --------------------------------------
>> Type: Technical
>> Reported by: Matthias Schertler <[email-masked]>
>>
>> Section: 3.1.
>>
>> Original Text
>> -------------
>>     The "Encrypted Portion" of an SRTP packet consists of the
>> encryption    of the RTP payload (including RTP padding when
>> present) of the    equivalent RTP packet.
>>
>> Corrected Text
>> --------------
>>     The "Encrypted Portion" of an SRTP packet consists of the
>> encryption    of the RTP payload (including RTP padding and
>> RTP pad count when present)    of the equivalent RTP packet.
>>
>> Notes
>> -----
>> In Figure 1 "RTP padding" and "RTP pad count" are different
>> things. The text should use the same terminology in order to
>> make clear that the padding count is encrypted.
>>
>> Instructions:
>> -------------
>> This errata is currently posted as "Reported". If necessary,
>> please use "Reply All" to discuss whether it should be
>> verified or rejected. When a decision is reached, the
>> verifying party (IESG) can log in to change the status and
>> edit the report, if necessary.
>>
>> --------------------------------------
>> RFC3711 (draft-ietf-avt-srtp-09)
>> --------------------------------------
>> Title               : The Secure Real-time Transport Protocol (SRTP)
>> Publication Date    : March 2004
>> Author(s)           : M. Baugher, D. McGrew, M. Naslund, E.
>> Carrara, K. Norrman
>> Category            : PROPOSED STANDARD
>> Source              : Audio/Video Transport
>> Area                : Real-time Applications and Infrastructure
>> Stream              : IETF
>> Verifying Party     : IESG

---

From: Karl Norrman <[email-masked]>
Date: Fri, 22 Mar 2013 17:45:22 +0000

Hello!

OK, putting it on hold for document update is fine with me.

BR
Karl

> From: Robert Sparks [mailto:[email-masked]]
> Sent: den 22 mars 2013 16:27
> To: Karl Norrman
> Cc: [email-masked]; [email-masked];
> [email-masked]; Mats Näslund; Gonzalo Camarillo; keith.drage@alcatel-
> lucent.com; [email-masked]; [email-masked];
> [email-masked]; Gonzalo Camarillo; Richard Barnes
> Subject: Re: [Technical Errata Reported] RFC3711 (3420)
> 
> Using the criteria at
> ( I could make an argument for Reject, given the text in 3550 is very clear, but
> a working group can make that decision if 3771 is ever revised).
> 
> > I always considered the padding count to be part of the padding itself and
> hence it would be included in the encrypted portion.  However, the
> proposed errata below makes the text more explicit on this point.  So, if it
> can avoid some interoperability problems I'm all for accepting it.
> >
> > BR
> > Karl
> >
> >
> >> [email-masked]; Mats Näslund; Karl Norrman; Gonzalo Camarillo;
> >> [email-masked]; [email-masked];
> >> [email-masked]
> >> The following errata report has been submitted for RFC3711, "The
> >> Secure Real-time Transport Protocol (SRTP)".
> >>
> >> In Figure 1 "RTP padding" and "RTP pad count" are different things.
> >> The text should use the same terminology in order to make clear that
> >> the padding count is encrypted.
> >>
> >> Instructions:
> >> -------------
> >> This errata is currently posted as "Reported". If necessary, please
> >> use "Reply All" to discuss whether it should be verified or rejected.
> >> When a decision is reached, the verifying party (IESG) can log in to
> >> change the status and edit the report, if necessary.
> >>