Subject: Re: [AVTCORE] I-D Action: draft-ietf-avtcore-avp-codecs-02.txt

From: Kevin Gross <[email-masked]>
Date: Mon, 10 Jun 2013 13:39:41 -0600

I have reviewed this and it looks good to me. I had to do a bit of digging
to even find out what DVI4 was so removing it looks like removing is a good
idea.

Kevin Gross
+1-303-447-0517
Media Network Consultant
AVA Networks - www.AVAnw.com <http://www.avanw.com/>, www.X192.org

On Wed, Apr 10, 2013 at 10:37 AM, Timothy B. Terriberry
<[email-masked]>wrote:

> [email-masked] wrote:
>
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories.
>>
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/**doc/draft-ietf-avtcore-avp-**codecs<https://datatracker.ietf.org/doc/draft-ietf-avtcore-avp-codecs>
>>
>> There's also a htmlized version available at:
>> http://tools.ietf.org/html/**draft-ietf-avtcore-avp-codecs-**02<http://tools.ietf.org/html/draft-ietf-avtcore-avp-codecs-02>
>>
>> A diff from the previous version is available at:
>> http://www.ietf.org/rfcdiff?**url2=draft-ietf-avtcore-avp-**codecs-02<http://www.ietf.org/rfcdiff?url2=draft-ietf-avtcore-avp-codecs-02>
>>
>
> Changelog for this version:
>
> - Updated profile names to include the "RTP/" prefix.
>
> - Expanded the references in the abstract into document titles, and added
> a sentence to the introduce to actually reference the relevant RFCs.
>
> - Used Magnus's proposal for describing the text updates.
>
> - Used Keith's proposed text: "Some environments REQUIRE support for PCMU"
> (without including an "only").
>
>
> I did not change anything with respect to PCMA, as I could detect no clear
> consensus on the topic. We have one person arguing that neither PCMU nor
> PCMA should be SHOULD requirements, but I think that's a big enough change
> that more than one person should advocate for it before we make it
> (especially considering that PCMU was recently made a MUST for WebRTC).
>
> If I missed any other comments, please let me know!
>
> ______________________________**_________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/avt<https://www.ietf.org/mailman/listinfo/avt>
>

---

From: "Somogyi, Gabor (NSN - HU/Budapest)" <[email-masked]>
Date: Tue, 11 Jun 2013 09:27:44 +0000

> We have one person arguing that neither PCMU nor PCMA should
> be SHOULD requirements, but I think that's a big enough change

For 17+ years IETF RFCs (1890, 3551) recommend PCMU and DVI4. If DVI4 faded away, it may make sense to update the RFC. While PCMU may have gained ground outside of its traditional home. It is nice to have a common encoding supported globally.

> especially considering that PCMU was recently made a MUST for WebRTC

While on trunk side ITU-T Q.1912.5<http://www.itu.int/rec/T-REC-Q.1912.5/en> says that either PCMA only or both PCMU and PCMA shall be sent in SDP offer. 3GPP TS 26.103<http://www.3gpp.org/ftp/Specs/html-info/26103.htm> states that supporting both PCMA and PCMU is mandatory for SIP-I CS CN. And NICC ND1701<http://www.niccstandards.org.uk/files/current/ND1701%20v1_5_2.pdf?type=pdf> and ND1704<http://www.niccstandards.org.uk/files/current/ND1704v2_1_1.pdf?type=pdf> state that PCMA shall be supported. Just to name a few standards.

> "Some environments REQUIRE support for PCMU."

That is true. The same applies to PCMA. And AMR/8000 in certain mobile networks. And I may create a system for my dogs where BARK/32000 will be REQUIRED :-) Sorry for the joke, but I wanted to point out that I do not see (personal opinion) the value of the sentence quoted.

BR,
Gabor Somogyi

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Kevin Gross
Sent: Monday, June 10, 2013 9:40 PM
To: Timothy B. Terriberry
Cc: [email-masked]
Subject: Re: [AVTCORE] I-D Action: draft-ietf-avtcore-avp-codecs-02.txt

I have reviewed this and it looks good to me. I had to do a bit of digging to even find out what DVI4 was so removing it looks like removing is a good idea.

Kevin Gross
+1-303-447-0517
Media Network Consultant
AVA Networks - www.AVAnw.com<http://www.avanw.com/>, www.X192.org<http://www.X192.org>

On Wed, Apr 10, 2013 at 10:37 AM, Timothy B. Terriberry <[email-masked]<mailto:[email-masked]>> wrote:
[email-masked]<mailto:[email-masked]> wrote:
A New Internet-Draft is available from the on-line Internet-Drafts directories.
The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-avtcore-avp-codecs

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-avtcore-avp-codecs-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-avtcore-avp-codecs-02

- Expanded the references in the abstract into document titles, and added a sentence to the introduce to actually reference the relevant RFCs.

- Used Keith's proposed text: "Some environments REQUIRE support for PCMU" (without including an "only").

I did not change anything with respect to PCMA, as I could detect no clear consensus on the topic. We have one person arguing that neither PCMU nor PCMA should be SHOULD requirements, but I think that's a big enough change that more than one person should advocate for it before we make it (especially considering that PCMU was recently made a MUST for WebRTC).

_______________________________________________
Audio/Video Transport Core Maintenance
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/avt