Subject: Re: [AVTCORE] WG last call on draft-ietf-avtcore-aria-srtp-04

From: Woo-Hwan Kim <[email-masked]>
Date: Wed, 28 Aug 2013 13:29:57 +0900

I have searched for the acronym RTCP in several RFC documents.
RTCP is an acronym for RTP Control Protocol in RFCs 3550 and 3611, but
it is an acronym for Real-time-Transport Control Protocol in RFCs 3605,
3711, 4585.
I think any expression is admissible since both of them are widely used and
there is no confusion when one or the other is used.
If necessary, I'll correct the draft.

The byte order for the test vector is the network order (called big endian)
which has been adopted by most documents.
I'll add a comment in the next revision.

Thanks for your comments.

Sincerely,
Woo-Hwan Kim

> Date: Mon, 26 Aug 2013 13:30:52 +0100
> From: Colin Perkins <[email-masked]>
> From a quick look, this looks okay to me. Some nits:
>
> The acronym RTCP is expanded incorrectly in the abstract and Introduction
(should be "RTP Control Protocol" to match RFC3550).
>
> Appendix A: what is the byte order for the test vectors? (especially for
fields like the seqnum and SSRC, which are commonly represented by ints in
code)
> Cheers,
> Colin
> --
> Colin Perkins
> http://csperkins.org/

---

From: Colin Perkins <[email-masked]>
Date: Wed, 28 Aug 2013 16:21:33 +0100

On 28 Aug 2013, at 05:29, Woo-Hwan Kim <[email-masked]> wrote:
> it is an acronym for Real-time-Transport Control Protocol in RFCs 3605, 3711, 4585.
> I think any expression is admissible since both of them are widely used and there is no confusion when one or the other is used.

Please correct it. The expansion in RFC 3550 is definitive. We shouldn't perpetuate the mistakes in other RFCs.

> The byte order for the test vector is the network order (called big endian) which has been adopted by most documents. I'll add a comment in the next revision.

Thanks!
Colin