Subject: Re: [AVTCORE] I-D Action: draft-ietf-avtcore-idms-12.txt

From: Magnus Westerlund <[email-masked]>
Date: Thu, 15 Aug 2013 09:35:12 +0200

Hi,

Looking at this latest version I have a comment.

section 14.4 defines the SPST registry.

Why isn't is adding the ETSI defined values from the start. If they are
known and have well known reference I don't see any issues with putting
in the values into the registry at its creation.

Value           Name                         Reference
   -----           ----                         ---------
   1               Synchronization Client       section 7 of [RFCXXXX]
   2               <Appropriate Name>           [TS183063]
   3               <Appropriate Name>           [TS183063]
   4               <Appropriate Name>           [TS183063]

Cheers

Magnus

On 2013-07-29 10:48, Brandenburg, R. (Ray) van wrote:
> Hi,
> 
> This version of the draft includes the final comments received during
> IETF LC and from Martin Thomson as Appsdir reviewer.
> 
> Best regards,
> 
> Ray
> 
> On 29 jul. 2013, at 10:45, "[email-masked]"
> <[email-masked]> wrote:
> 
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories. This draft is a work item of the Audio/Video Transport
>> Core Maintenance Working Group of the IETF.
>> 
>> Title           : Inter-destination Media Synchronization using the
>> RTP Control Protocol (RTCP) Author(s)       : Ray van Brandenburg 
>> Hans Stokking Oskar van Deventer Fernando Boronat Mario Montagud 
>> Kevin Gross Filename        : draft-ietf-avtcore-idms-12.txt Pages
>> : 22 Date            : 2013-07-29
>> 
>> Abstract: This document defines a new RTP Control Protocol (RTCP)
>> Packet Type and an RTCP Extended Report (XR) Block Type to be used
>> for achieving Inter-Destination Media Synchronization (IDMS).  IDMS
>> is the process of synchronizing playout across multiple
>> geographically distributed media receivers.  Using the RTCP XR IDMS
>> Report Block defined in this document, media playout information
>> from participants in a synchronization group can be collected.
>> Based on the collected information, an RTCP IDMS Settings Packet
>> can then be sent to distribute a common target playout point to
>> which all the distributed receivers, sharing a media experience,
>> can synchronize.
>> 
>> Typical use cases in which IDMS is useful are social TV, shared 
>> service control (i.e. applications where two or more
>> geographically separated users are watching a media stream
>> together), distance learning, networked video walls, networked
>> loudspeakers, etc.
>> 
>> 
>> The IETF datatracker status page for this draft is: 
>> https://datatracker.ietf.org/doc/draft-ietf-avtcore-idms
>> 
>> There's also a htmlized version available at: 
>> http://tools.ietf.org/html/draft-ietf-avtcore-idms-12
>> 
>> A diff from the previous version is available at: 
>> http://www.ietf.org/rfcdiff?url2=draft-ietf-avtcore-idms-12
>> 
>> 
>> Please note that it may take a couple of minutes from the time of
>> submission until the htmlized version and diff are available at
>> tools.ietf.org.
>> 
>> Internet-Drafts are also available by anonymous FTP at: 
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> _______________________________________________ Audio/Video
>> Transport Core Maintenance [email-masked] 
>> https://www.ietf.org/mailman/listinfo/avt
> This e-mail and its contents are subject to the DISCLAIMER at
> http://www.tno.nl/emaildisclaimer
> 
> _______________________________________________ Audio/Video Transport
> Core Maintenance [email-masked] 
> https://www.ietf.org/mailman/listinfo/avt
> 

-- 

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Brandenburg, R. (Ray) van" <[email-masked]>
Date: Thu, 15 Aug 2013 09:22:38 +0000

Hi Magnus,

Good point! For some reason, I never really considered that to be an option. I guess you're right and there's no reason not to. 

If I don't see any disagreements from others, I will add it to the next revision. 

Thanks,

Ray

> -----Original Message-----
> From: Magnus Westerlund [mailto:[email-masked]]
> Sent: donderdag 15 augustus 2013 9:35
> To: Brandenburg, R. (Ray) van; [email-masked]
> Cc: [email-masked]
> Subject: Re: [AVTCORE] I-D Action: draft-ietf-avtcore-idms-12.txt
> 
> Hi,
> 
> Why isn't is adding the ETSI defined values from the start. If they are known
> and have well known reference I don't see any issues with putting in the
> values into the registry at its creation.
> 
> Value           Name                         Reference
>    -----           ----                         ---------
> >> Report Block defined in this document, media playout information from
> >> participants in a synchronization group can be collected.
> >> Based on the collected information, an RTCP IDMS Settings Packet can
> >> then be sent to distribute a common target playout point to which all
> >> the distributed receivers, sharing a media experience, can
> >> synchronize.
> >>
> >> service control (i.e. applications where two or more geographically
> >> separated users are watching a media stream together), distance
> >> learning, networked video walls, networked loudspeakers, etc.
> >>
> >>