Subject: [AVTCORE] [Technical Errata Reported] RFC3550 (3914)

From: RFC Errata System <[email-masked]>
Date: Thu, 6 Mar 2014 08:41:58 -0800 (PST)

The following errata report has been submitted for RFC3550,
"RTP: A Transport Protocol for Real-Time Applications".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3550&eid=3914

--------------------------------------
Type: Technical
Reported by: Hani Mustafa <[email-masked]>

Section: A.1

Original Text
-------------
      init_seq(s, seq);
      s->max_seq = seq - 1;
      s->probation = MIN_SEQUENTIAL;

Corrected Text
--------------
      init_seq(s, seq);
      s->max_seq = seq == 0 ? seq : seq - 1;
      s->probation = MIN_SEQUENTIAL;

Notes
-----
If the first RTP packet has a sequence number of 0, the logic will cause cycles to increase by 1, which will affect "expected number of received packets" calculations.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3550 (draft-ietf-avt-rtp-new-12)
--------------------------------------
Title               : RTP: A Transport Protocol for Real-Time Applications
Publication Date    : July 2003
Author(s)           : H. Schulzrinne, S. Casner, R. Frederick, V. Jacobson
Category            : DRAFT STANDARD
Source              : Audio/Video Transport
Area                : Real-time Applications and Infrastructure
Stream              : IETF
Verifying Party     : IESG

---

From: Hani Mustafa <[email-masked]>
Date: Thu, 6 Mar 2014 18:00:35 +0100

Oops... please ignore... I should've had my coffee before pressing submit...

Sorry!

~Hani Mustafa

On Thu, Mar 6, 2014 at 5:41 PM, RFC Errata System <[email-masked]
> wrote:

> If the first RTP packet has a sequence number of 0, the logic will cause
> cycles to increase by 1, which will affect "expected number of received
> packets" calculations.
>
> Instructions:
> -------------

---

From: Richard Barnes <[email-masked]>
Date: Thu, 6 Mar 2014 23:15:24 +0000

I have marked this erratum as "rejected"

On Thu, Mar 6, 2014 at 5:00 PM, Hani Mustafa <[email-masked]> wrote:

> On Thu, Mar 6, 2014 at 5:41 PM, RFC Errata System <
> [email-masked]> wrote:
>

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 10 Mar 2014 17:15:58 +0100

> Oops... please ignore... I should've had my coffee before pressing submit...

I can recommend that if you believe something is an errata on an
AVTCORE/AVT document, then please send an email first to the WG to
confirm that it is a valid Errata. That way we can discuss both the
issue and also input discussed text on what it should be. That way we
avoid cluttering up the Errata system and putting load on the Area
Directors.

Cheers

Magnus Westerlund

> 
> ~Hani Mustafa
> 
> 
> On Thu, Mar 6, 2014 at 5:41 PM, RFC Errata System
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Reported by: Hani Mustafa <[email-masked] <mailto:[email-masked]>>
> 
>     Section: A.1
> 
>     Original Text
>     -------------
>           init_seq(s, seq);
>           s->max_seq = seq - 1;
>     If the first RTP packet has a sequence number of 0, the logic will
>     cause cycles to increase by 1, which will affect "expected number of
>     received packets" calculations.
> 
>     Instructions:
>     -------------
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
> 

-- 

Magnus Westerlund

----------------------------------------------------------------------
Services, Media and Network features, Ericsson Research EAB/TXM
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Färögatan 6                 | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------