Subject: Re: [AVTCORE] [Technical Errata Reported] RFC2435 (4094)

From: Magnus Westerlund <[email-masked]>
Date: Thu, 29 Jan 2015 13:46:20 +0100

WG,

I need your input on this Errata. Should it be held for document update
or Rejected?

The reason I think we can exclude the Verified option is that these
table are verbatim from Annex K.1 of the JPEG specficiation (ISO/IEC
10918-1 : 1993(E)). I would also note the initial text in that annex
preceding the tables:

   Two examples of quantization tables are given in Tables K.1 and K.2.
These are based on psychovisual thresholding and are derived empirically
using luminance and chrominance and 2:1 horizontal subsampling. These
tables are provided as examples only and are not necessarily suitable
for any particular application. These quantization values have been
used with good results on 8-bit per sample luminance and chrominance
images of the format illustrated in Figure 13. Note that these
quantization values are appropriate for the DCT normalization defined in
A.3.3.

If these quantization values are divided by 2, the resulting
reconstructed image is usually nearly indistinguishable from the
source image.

Please provide any input by the 13th of February.

Cheers

Magnus

On 2014-09-04 16:33, RFC Errata System wrote:
> The following errata report has been submitted for RFC2435,
> "RTP Payload Format for JPEG-compressed Video".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=2435&eid=4094
> 
> --------------------------------------
> Type: Technical
> Reported by: Julius Richard Friedman <[email-masked]>
> 
> Section: Appendix A
> 
> Original Text
> -------------
> /*
>  * Table K.1 from JPEG spec.
>  */
> static const int jpeg_luma_quantizer[64] = {
>         16, 11, 10, 16, 24, 40, 51, 61,
>         12, 12, 14, 19, 26, 58, 60, 55,
>         14, 13, 16, 24, 40, 57, 69, 56,
>         14, 17, 22, 29, 51, 87, 80, 62,
>         18, 22, 37, 56, 68, 109, 103, 77,
>         24, 35, 55, 64, 81, 104, 113, 92,
>         49, 64, 78, 87, 103, 121, 120, 101,
>         72, 92, 95, 98, 112, 100, 103, 99
> };
> 
> /*
>  * Table K.2 from JPEG spec.
>  */
> static const int jpeg_chroma_quantizer[64] = {
>         17, 18, 24, 47, 99, 99, 99, 99,
>         18, 21, 26, 66, 99, 99, 99, 99,
>         24, 26, 56, 99, 99, 99, 99, 99,
>         47, 66, 99, 99, 99, 99, 99, 99,
>         99, 99, 99, 99, 99, 99, 99, 99,
>         99, 99, 99, 99, 99, 99, 99, 99,
>         99, 99, 99, 99, 99, 99, 99, 99,
>         99, 99, 99, 99, 99, 99, 99, 99
> };
> 
> Corrected Text
> --------------
> /*
>  * Table K.1 from JPEG spec.
>  */
> static const int jpeg_luma_quantizer[64] = {
>            16, 11, 12, 14, 12, 10, 16, 14,
>            13, 14, 18, 17, 16, 19, 24, 40,
>            26, 24, 22, 22, 24, 49, 35, 37,
>            29, 40, 58, 51, 61, 60, 57, 51,
>            56, 55, 64, 72, 92, 78, 64, 68,
>            87, 69, 55, 56, 80, 109, 81, 87,
>            95, 98, 103, 104, 103, 62, 77, 113,
>            121, 112, 100, 120, 92, 101, 103, 99,
> };
> 
> /*
>  * Table K.2 from JPEG spec.
>  */
> static const int jpeg_chroma_quantizer[64] = {
>            17, 18, 18, 24, 21, 24, 47, 26,
>            26, 47, 99, 66, 56, 66, 99, 99,
>            99, 99, 99, 99, 99, 99, 99, 99,
>            99, 99, 99, 99, 99, 99, 99, 99,
>            99, 99, 99, 99, 99, 99, 99, 99,
>            99, 99, 99, 99, 99, 99, 99, 99,
>            99, 99, 99, 99, 99, 99, 99, 99,
>            99, 99, 99, 99, 99, 99, 99, 99
> };
> 
> Notes
> -----
> Luma and Chroma was not in Zig Zag order and Luma energy has been de-saturated.
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary. 
> 
> --------------------------------------
> RFC2435 (no draft string recorded)
> --------------------------------------
> Title               : RTP Payload Format for JPEG-compressed Video
> Publication Date    : October 1998
> Author(s)           : L. Berc, W. Fenner, R. Frederick, S. McCanne, P. Stewart
> Category            : PROPOSED STANDARD
> Source              : Audio/Video Transport
> Area                : Real-time Applications and Infrastructure
> Stream              : IETF
> Verifying Party     : IESG
> 
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
> 

-- 

Magnus Westerlund

----------------------------------------------------------------------
Services, Media and Network features, Ericsson Research EAB/TXM
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Färögatan 6                 | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: [email-masked] (Dale R. Worley)
Date: Thu, 29 Jan 2015 21:34:09 -0500

> I need your input on this Errata. Should it be held for document update

It's difficult to say because it's not clear (at least to me) what the
erratum is intended to do.  I would need to see a more detailed
explanation of the error the erratum is intended to correct.

Dale