Subject: [AVTCORE] I-D on RTP failover posted in mmusic

From: Martin Taylor <[email-masked]>
Date: Thu, 3 Mar 2016 09:39:43 +0000

I recently posted https://tools.ietf.org/id/draft-taylor-mmusic-rtp-failover-problem-00.txt  This offers a problem statement around RTP failover.  The TL;DR summary:

- VoIP networks typically contain network functions that terminate large numbers of RTP streams, such as session border controllers and conference bridges.

- Service providers typically require that such network functions have no single points of failure that could cause large numbers of media streams to be interrupted for more than a second or two.

- The usual solution for this is to deploy such network functions as an active / standby pair with a service IP address that can be moved between members of the pair, for example with the aid of a gratuitous ARP, in a manner analogous to VRRP.

- This solution suffers from a number of drawbacks including inefficient use of hardware resources and inability to deploy in environments where it is impractical to connect active and standby instances to the same L2 segment.  These drawbacks are causing network operators particular concern in network function virtualization environments.

We were planning to propose a solution to this problem that would likely involve some extensions to SDP to communicate a connection address for an alternative backup media path.

Simon Perreault suggested that the work on Multipath RTP https://tools.ietf.org/html/draft-ietf-avtcore-mprtp-01 could be relevant here.  Section 1.3 on Use Cases in this doc says: "Using multiple concurrent subflows can improve fault tolerance, because traffic can shift between the subflows when path outages occur.  This results in very fast transport-layer handovers that do not require support from signaling."  That's pretty much what we are trying to achieve here.  And the SDP extensions proposed by https://tools.ietf.org/html/draft-singh-mmusic-mprtp-sdp-extension-04 are quite well aligned with what we had in mind.

It occurs to me that perhaps I should have posted this I-D on RTP failover to avtcore rather than mmusic.  Any views from avtcore would be most welcome. 

Martin

---

From: "Ben Campbell" <[email-masked]>
Date: Fri, 04 Mar 2016 15:41:25 -0600

On 3 Mar 2016, at 3:39, Martin Taylor wrote:

> It occurs to me that perhaps I should have posted this I-D on RTP 
> failover to avtcore rather than mmusic.  Any views from avtcore would 
> be most welcome.

You might also consider sending this to dispatch. That's the starting 
point for most new work in the ART area.

Thanks!

Ben.

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Tue, 15 Mar 2016 19:29:41 +0000

agree VRRP is not great for this. Might be worth considering if ICE can already provide this.