Subject: [AVTCORE] [Technical Errata Reported] RFC6184 (4713)

From: RFC Errata System <[email-masked]>
Date: Fri, 17 Jun 2016 03:53:01 -0700 (PDT)

The following errata report has been submitted for RFC6184,
"RTP Payload Format for H.264 Video".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6184&eid=4713

--------------------------------------
Type: Technical
Reported by: Iñaki Baz Castillo <[email-masked]>

Section: 8.1

Original Text
-------------
profile-level-id:
         A base16 [7] (hexadecimal) representation of the following
         three bytes in the sequence parameter

Corrected Text
--------------
profile-level-id:
         A base16 [7] (hexadecimal) representation of the following
         six bytes in the sequence parameter

Notes
-----
profile-level-id is composed of three 2-byte length fields.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6184 (draft-ietf-avt-rtp-rfc3984bis-12)
--------------------------------------
Title               : RTP Payload Format for H.264 Video
Publication Date    : May 2011
Author(s)           : Y.-K. Wang, R. Even, T. Kristensen, R. Jesup
Category            : PROPOSED STANDARD
Source              : Audio/Video Transport
Area                : Real-time Applications and Infrastructure
Stream              : IETF
Verifying Party     : IESG

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Sun, 19 Jun 2016 13:22:18 +0000

The original text is correct; 3 bytes in the binary representation become 6 text characters in base16. Therefore this errata should be rejected. 

Regards,
Mo

On Jun 18, 2016, at 11:33 PM, RFC Errata System <[email-masked]> wrote:

Section: 8.1

Original Text
-------------
profile-level-id:

Corrected Text
--------------
profile-level-id:

Notes
-----

Instructions:
-------------

_______________________________________________
Audio/Video Transport Core Maintenance
[email-masked]
https://www.ietf.org/mailman/listinfo/avt

---

From: Stephan Wenger <[email-masked]>
Date: Sun, 19 Jun 2016 23:10:28 +0000

Hi,

>The original text is correct; 3 bytes in the binary representation become 6 text characters in base16. Therefore this errata should be rejected.

I agree.

Stephan

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 20 Jun 2016 16:05:18 +0200

Hi,

This errata should be handled by the PAYLOAD WG. Please send any 
feedback to them rather than AVTCORE WG.

Cheers

Magnus

Den 2016-06-17 kl. 12:53, skrev RFC Errata System:
> Reported by: IÃ±aki Baz Castillo <[email-masked]>
>
> Section: 8.1
>
> Original Text
> -------------
> profile-level-id:

-- 

Magnus Westerlund

----------------------------------------------------------------------
Services, Media and Network features, Ericsson Research EAB/TXM
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Färögatan 6                 | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------