Subject: [AVTCORE] I-D Action: draft-ietf-avtcore-rtp-circuit-breakers-16.txt

From: [email-masked]
Date: Mon, 13 Jun 2016 13:46:54 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Audio/Video Transport Core Maintenance of the IETF.

        Title           : Multimedia Congestion Control: Circuit Breakers for Unicast RTP Sessions
        Authors         : Colin Perkins
                          Varun Singh
	Filename        : draft-ietf-avtcore-rtp-circuit-breakers-16.txt
	Pages           : 26
	Date            : 2016-06-13

Abstract:
   The Real-time Transport Protocol (RTP) is widely used in telephony,
   video conferencing, and telepresence applications.  Such applications
   are often run on best-effort UDP/IP networks.  If congestion control
   is not implemented in these applications, then network congestion can
   lead to uncontrolled packet loss, and a resulting deterioration of
   the user's multimedia experience.  The congestion control algorithm
   acts as a safety measure, stopping RTP flows from using excessive
   resources, and protecting the network from overload.  At the time of
   this writing, however, while there are several proprietary solutions,
   there is no standard algorithm for congestion control of interactive
   RTP flows.

   This document does not propose a congestion control algorithm.  It
   instead defines a minimal set of RTP circuit breakers: conditions
   under which an RTP sender needs to stop transmitting media data, to
   protect the network from excessive congestion.  It is expected that,
   in the absence of long-lived excessive congestion, RTP applications
   running on best-effort IP networks will be able to operate without
   triggering these circuit breakers.  To avoid triggering the RTP
   circuit breaker, any standards-track congestion control algorithms
   defined for RTP will need to operate within the envelope set by these
   RTP circuit breaker algorithms.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-avtcore-rtp-circuit-breakers/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-avtcore-rtp-circuit-breakers-16

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-avtcore-rtp-circuit-breakers-16

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Colin Perkins <[email-masked]>
Date: Mon, 13 Jun 2016 22:05:43 +0100

This version contains three sets of changes:

- Editorial changes to the Abstract and Introduction, to address Stephen Farrell’s comment by clarifying what it means to “operate within the envelope defined by this memo". 

- Update Section 4.5 (“Ceasing Transmission”) to address Alissa Cooper’s DISCUSS, clarifying that it is the RTP flows sharing a 5-tuple that are stopped when the circuit breaker triggers, rather than the entire call.

- Update Section 7 to address Mirja Mühlewind’s DISCUSS, expanding the discussion of how the RTP circuit breaker should react to ECN-CE marks. This changes “ECN-CE marked packets SHOULD be treated as if they were lost when calculating if the congestion-based RTP circuit breaker” into a more nuanced recommendation, based on likely future evolution of ECN response.

This changes the normative requirements of the specification, so a brief new WG last call is likely needed. 

Cheers,
Colin

> On 13 Jun 2016, at 21:46, [email-masked] wrote:
> 
> 
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

-- 
Colin Perkins
https://csperkins.org/