Subject: [AVTCORE] Confirmation of Consensus: Adoption of Congestion Control Feedback Message

From: Jonathan Lennox <[email-masked]>
Date: Tue, 25 Jul 2017 20:40:17 +0000

Hi, all —

At the AVTCORE meeting in Prague, we had consensus in the room to take on a Congestion Control Feedback Message as an AVTCORE working group item, and adopt draft-dt-rmcat-feedback-message as the basis for the working group document.

If you were not at the meeting (or if you have changed your mind since the meeting) and have opinions on this topic, please let the working group know in the next week (by August 1st).

Thank you!

Jonathan Lennox
AVTCORE co-chair

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 25 Jul 2017 13:50:45 -0700

I believe that the consensus of the meeting was to utilize feedback message
205.  This change would increase efficiency as well as to improve the
chances that the draft will be implemented and deployed.  With those
changes, I support adoption.

I do have some concerns about potential deployment, though. The proposal
was found to be only marginally more efficient than the feedback message
defined in
https://tools.ietf.org/html/draft-holmer-rmcat-transport-wide-cc-extensions
which is available in open source and is in widespread usage.  In one of
his first acts as Apple CEO, Steve Jobs killed a number of projects that
were "different but not better".  This makes me wonder whether the IETF
would not benefit from that level of realism.

On Tue, Jul 25, 2017 at 1:40 PM, Jonathan Lennox <[email-masked]> wrote:

> Hi, all —
>
> At the AVTCORE meeting in Prague, we had consensus in the room to take on
> a Congestion Control Feedback Message as an AVTCORE working group item, and
> adopt draft-dt-rmcat-feedback-message as the basis for the working group
> document.
>
> If you were not at the meeting (or if you have changed your mind since the
> meeting) and have opinions on this topic, please let the working group know
> in the next week (by August 1st).
>
> Thank you!
>
> Jonathan Lennox
> AVTCORE co-chair
>
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
>

---

From: Colin Perkins <[email-masked]>
Date: Tue, 25 Jul 2017 22:43:35 +0100

> On 25 Jul 2017, at 21:50, Bernard Aboba <[email-masked]> wrote:
> 
> I believe that the consensus of the meeting was to utilize feedback message 205.  This change would increase efficiency as well as to improve the chances that the draft will be implemented and deployed.  With those changes, I support adoption.

The plan is that authors will submit a -04 individual draft making that change, and will confirm with the AVTCORE chairs to adopt that version/

> I do have some concerns about potential deployment, though. The proposal was found to be only marginally more efficient than the feedback message defined in https://tools.ietf.org/html/draft-holmer-rmcat-transport-wide-cc-extensions <https://tools.ietf.org/html/draft-holmer-rmcat-transport-wide-cc-extensions> which is available in open source and is in widespread usage.  In one of his first acts as Apple CEO, Steve Jobs killed a number of projects that were "different but not better".  This makes me wonder whether the IETF would not benefit from that level of realism. 

As an individual, I find the approach taken in the transport-wide-cc-extensions a very poor fit with RTP. It also doesn’t convey ECN feedback information, which is needed by several of the candidate congestion control algorithms being proposed in RMCAT. 

Colin

> On Tue, Jul 25, 2017 at 1:40 PM, Jonathan Lennox <[email-masked] <mailto:[email-masked]>> wrote:
> Hi, all —
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/avt <https://www.ietf.org/mailman/listinfo/avt>
> 

-- 
Colin Perkins
https://csperkins.org/