Subject: Re: [AVTCORE] Mirja Kühlewind's No Objection on draft-ietf-avtcore-aria-srtp-10: (with COMMENT)

From: Ben Campbell <[email-masked]>
Date: Tue, 1 Aug 2017 16:59:39 -0500

> On Jul 31, 2017, at 11:30 AM, Mirja Kühlewind <[email-masked]> wrote:
> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> This actually looks more like a document that we would rather typically publish
> by the ISE (as it is describing a method employed by one specific entity only).
> I do not object to it publication as informational and I do understand that
> this mostly due to the registration the in the MIKEY registry, however, i would
> like to note that IESG Approval would have been another option for this
> registration.
> 

I think if this work were started from scratch in its current form, I would agree with you. But the original version of this draft would have required standards-action. That text has been removed, but by that time most of the work had already been done in the working group. Given that this has already completed IETF last call, the least-effort path seems to be to approve it as an informational RFC on the IETF stream.

Thanks!

Ben.

---

From: Roni Even <[email-masked]>
Date: Wed, 2 Aug 2017 05:59:27 +0000

Hi,
I think that this point is a general problem and should be addressed as a review of the registration procedures for Mikey, DTLS and SDES.
The lack of consistency started this whole discussion.

Roni Even

> -----Original Message-----
> From: Ben Campbell [mailto:[email-masked]]
> Sent: יום ד 02 אוגוסט 2017 01:00
> To: Mirja Kühlewind
> Cc: The IESG; [email-masked]; Roni Even; draft-ietf-avtcore-aria-
> [email-masked]; [email-masked]
> Subject: Re: Mirja Kühlewind's No Objection on draft-ietf-avtcore-aria-srtp-
> 10: (with COMMENT)
> 
> 
> > This actually looks more like a document that we would rather
> > typically publish by the ISE (as it is describing a method employed by one
> specific entity only).
> > I do not object to it publication as informational and I do understand
> > that this mostly due to the registration the in the MIKEY registry,
> > however, i would like to note that IESG Approval would have been
> > another option for this registration.
> >
> 
> I think if this work were started from scratch in its current form, I would
> agree with you. But the original version of this draft would have required
> standards-action. That text has been removed, but by that time most of the
> work had already been done in the working group. Given that this has
> already completed IETF last call, the least-effort path seems to be to approve
> it as an informational RFC on the IETF stream.
> 
> Thanks!
> 
> Ben.

---

From: Ben Campbell <[email-masked]>
Date: Wed, 2 Aug 2017 10:37:21 -0500

> On Aug 2, 2017, at 12:59 AM, Roni Even <[email-masked]> wrote:
> 
> Hi,

It is my understanding that the inconsistency is intentional, in that people wanted a higher bar to add new things for SDES because they wanted to discourage the expansion of its use. It’s reasonable to discuss whether that still makes sense. 

But I don’t think we want to block _this_ draft on that discussion—that’s the reason we removed the SDES registration from it in the first place.