Subject: [AVTCORE] I-D Action: draft-ietf-avtcore-cc-feedback-message-04.txt

From: [email-masked]
Date: Mon, 08 Jul 2019 16:11:21 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Audio/Video Transport Core Maintenance WG of the IETF.

        Title           : RTP Control Protocol (RTCP) Feedback for Congestion Control
        Authors         : Zaheduzzaman Sarker
                          Colin Perkins
                          Varun Singh
                          Michael A. Ramalho
	Filename        : draft-ietf-avtcore-cc-feedback-message-04.txt
	Pages           : 15
	Date            : 2019-07-08

Abstract:
   This document describes an RTCP feedback message intended to enable
   congestion control for interactive real-time traffic using RTP.  The
   feedback message is designed for use with a sender-based congestion
   control algorithm, in which the receiver of an RTP flow sends RTCP
   feedback packets to the sender containing the information the sender
   needs to perform congestion control.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-avtcore-cc-feedback-message/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-avtcore-cc-feedback-message-04
https://datatracker.ietf.org/doc/html/draft-ietf-avtcore-cc-feedback-message-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-avtcore-cc-feedback-message-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Colin Perkins <[email-masked]>
Date: Sun, 14 Jul 2019 17:39:27 +0100

> On 9 Jul 2019, at 00:11, [email-masked] wrote:
> 
> https://datatracker.ietf.org/doc/draft-ietf-avtcore-cc-feedback-message/ <https://datatracker.ietf.org/doc/draft-ietf-avtcore-cc-feedback-message/>

This version addresses feedback received during IETF-104. It does not change the packet format or signalling, but rather makes a number of clarifications:
add an example of use of the "a=rtcp-fb:" attribute;
clarify that congestion control feedback is sent for FEC and retransmission packets, if used;
clarify that congestion control feedback signalling is IDENTICAL-PER-PT when used with the SDP BUNDLE;
clarify that if an SDP offer indicates support for several different ways of providing congestion control feedback, the receiver SHOULD pick its preferred mechanism use use it consistently;
clarify that feedback reports indicating that packets were lost are not explicit requests for retransmission;
clarify that large feedback packets might need to be split across multiple RTCP packets if the RTCP bandwidth fraction is misconfigured; and
add a section on the desired congestion response in cases where congestion control feedback packets are lost.
The only remaining open issue is to add some discussion of how this solution compares to the Holmer draft, in particular to discuss the trade-offs around a single sequence number space vs the per-flow sequence numbers used in this draft.

-- 
Colin Perkins
https://csperkins.org/