Subject: Re: [babel] Call for WG adoption of draft-ovsienko-babel-rfc7298bis (2018-03-25 to 2018-04-08)

From: Denis Ovsienko <[email-masked]>
Date: Wed, 02 May 2018 13:07:10 +0100

---- On Mon, 26 Mar 2018 19:17:06 +0100 Donald Eastlake  wrote ---- 
>Hi,
>
>This message announces a two week adoption call for draft-ovsienko-babel-rfc7298bis-00.txt running for two week starting from the posting of https://www.ietf.org/mail-archive/web/babel/current/msg01079.html
>
>
>Please comment as to whether or not you think this draft is good basis for further work by the BABEL WG.

Hello all.

It has been more than a month since the call so I suggest to go ahead with the adoption as intended. I would like to be able to plan this work.

-- 

    Denis Ovsienko

---

From: Denis Ovsienko <[email-masked]>
Date: Tue, 15 May 2018 10:56:44 +0100

---- On Wed, 02 May 2018 13:07:10 +0100 Denis Ovsienko  wrote ---- 
>It has been more than a month since the call so I suggest to go ahead with the adoption as intended. I would like to be able to plan this work. 

It has been seven weeks since the call. I would like to understand its current status now.

-- 

    Denis Ovsienko

---

From: Juliusz Chroboczek <[email-masked]>
Date: Tue, 15 May 2018 15:49:37 +0200

> It has been seven weeks since the call. I would like to understand its

I was under the impression that we're discussing a vulnerability in your
protocol.  It would be good if we could convince ourselves that the
vulnerability is fixable before we adopt.

I don't think there's any urgency with adopting; I'd much rather we worked
on fixing the protocol and getting it implemented before.  On my side, two
interns are starting next week.  (Yes, I do have a plan for fixing the
vulnerability, although I've yet to convince myself it's correct and not
overly complex.)

-- Juliusz

---

From: Denis Ovsienko <[email-masked]>
Date: Wed, 16 May 2018 13:07:43 +0100

---- On Tue, 15 May 2018 14:49:37 +0100 Juliusz Chroboczek <[email-masked]> wrote ---- 
 > vulnerability, although I've yet to convince myself it's correct and not 

Juliusz, let me assure you that I have started this round of this work because I see ways to get it done in the first place, and I am taking the quality of my contributions at least as seriously as you have taken the quality of yours.

It is correct that we (you and I, two working group members) eventually started to review a solution to the problem, which was initially stated shortly after the WG formation, I really appreciate the recent _constructive_ part of your participation and I am ready to continue until completion. Although a bit overdue, this is a normal way of things. On this note, if you want to fix outstanding issues in 6126-bis, just let me know when you are ready to discuss.

At the WG formation in 2016 you did not suggest to delay the adoption of your own pre-WG work, though you wanted a hold-off on 7298-bis to provide the WG with more choices on security mechanisms. After roughly 2 years and not enough progress in this regard this handicap is over.

It is correct that I have openly requested the adoption of my I-D to continue this work within the working group, consequently I am demanding the working group chairs to state their decision and act it. This is a normal and upfront agreed upon way of things again.

As to "vulnerability in your protocol", let me remind that this was a joint design flaw, with reasoning duly explained on the list. So please mind the wording and try to put the blame where it belongs, not where you would prefer it to be. This is very important for producing the right solution.

Your interns are welcome to work on an implementation, as discussed before. And you, like anybody else, are welcome to oppose or support me in the security mechanism work (after my last message the ball is on your side, I believe). But you would have to convince me what is right, rather than tell me what to do.

-- 
    Denis Ovsienko

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 17 May 2018 23:37:52 -0400

Hi,

> It has been seven weeks since the call. I would like to understand its current status now.

My apologies for being slow to respond. I was on vacation in
California recently and am catching up.

While there is no specific rule (except in Working Groups that have
adopted a rule), typically I would look for at least five non-author
supporting posts to adopt a draft. So far I believe there have been
three. Note that the adoption of the draft just means that its the
starting point for the WG version. I'll post a specific reminder and
extend the Last Call for ~10 days.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]