Subject: [babel] Consensus Determined for Babel Charter Update (2018-06-17 to 2018-06-25)

From: Donald Eastlake <[email-masked]>
Date: Tue, 26 Jun 2018 12:39:40 -0400

Hi,

Based on the responses that have been received and on the prior discussion
on the mailing list, the Babel Charter Update below is determined to have
WG consensus.

Thanks,
Donald and Russ

---------- Forwarded message ----------
From: Donald Eastlake <[email-masked]>
Date: Sun, Jun 17, 2018 at 10:56 AM
Subject: Consensus Call for Babel Charter Update (2018-06-17 to 2018-06-25)
To: Babel at IETF <[email-masked]>
Cc: [email-masked]

Hi,

Based on the recent discussion on the mailing list, we are asking for
comments in favor or opposed to the following change in the Babel WG
Charter to remove the specification of a YANG model as a gating factor
in moving the Babel protocol to standards track. You can also suggest
further changes but to maximize the chances of getting a change
approved it might be best to minimize the changes.

OLD:
- Address manageability of Babel by producing a Babel informational
model to help provide guidance and derive the data models. To be
consistent with the ongoing effort to use YANG data modules in the
Routing Area, a Babel YANG data model to support management of home
gateway routers is required as part of moving Babel to Proposed
Standard. This information model is useful as a common source of
information for the case where the Customer-Premise Equipment (CPE) is
managed by the Service Provider (SP) with the Broadband Forum TR-069
protocol and its associated data model.

NEW:
- Address manageability of Babel by producing a Babel informational
model to help provide guidance and derive the data models. This
information model is useful as a common source of information for the
case where the Customer-Premise Equipment (CPE) is managed by the
Service Provider (SP) with the Broadband Forum TR-069 protocol and its
associated data model. To be consistent with the ongoing effort to use
YANG data modules in the Routing Area, a Babel YANG data model should
be specified to support management of Babel routers.

The full current Babel WG Charter is at
https://datatracker.ietf.org/doc/charter-ietf-babel/

Thanks,
Donald and Russ

---

From: Denis Ovsienko <[email-masked]>
Date: Tue, 26 Jun 2018 22:34:18 +0100

---- On Tue, 26 Jun 2018 17:39:40 +0100 Donald Eastlake <[email-masked]> wrote ---- 
 > Hi,
 > Based on the responses that have been received and on the prior discussion on the mailing list, the Babel Charter Update below is determined to have WG consensus.

Hello.

Thank you for making this update. For the avoidance of doubt, which specific consensus are the chairs declaring: the consensus to leave the charter intact or the consensus to request the proposed change?

-- 
    Denis Ovsienko

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 26 Jun 2018 20:07:15 -0400

The consensus of the WG is to Update the Charter as indicated.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Tue, Jun 26, 2018 at 5:34 PM, Denis Ovsienko <[email-masked]> wrote:

>  > Based on the responses that have been received and on the prior
> discussion on the mailing list, the Babel Charter Update below is
> determined to have WG consensus.
>
> Hello.
>
> Thank you for making this update. For the avoidance of doubt, which
> specific consensus are the chairs declaring: the consensus to leave the
> charter intact or the consensus to request the proposed change?
>
> --
>     Denis Ovsienko
>
>
>

---

From: Denis Ovsienko <[email-masked]>
Date: Wed, 27 Jun 2018 13:02:50 +0100

---- On Wed, 27 Jun 2018 01:07:15 +0100 Donald Eastlake <[email-masked]> wrote ---- 
 > The consensus of the WG is to Update the Charter as indicated.

Thank you for the clarification Donald.

I believe it is right to leave a record on the Babel WG mailing list with the summary of this consensus call, as far as it looked from my point of view:

* I had provided an objection to the suggested change and explained the grounds for my position.
* Other working group members had voted in support of the suggested change, none bothered to explain their grounds, even when explicitly prompted.
* I had explained that there was no consensus, that voting is not the IETF way of reaching rough consensus, and provided supporting reference to RFC 7282.
* The chairs left the objection unaddressed and had declared the situation a consensus.

Cheers.

-- 
    Denis Ovsienko

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 27 Jun 2018 09:12:01 -0400

Hi Denis,

> * Other working group members had voted in support of the suggested change, none bothered to explain their grounds, even when explicitly prompted.

I believe there has been ample discussion of the need for the change
on the WG mailing list, frequently by the same persons who indicated
they supported the change.

In determining WG consensus, the chairs are entitled to take into
account such discussions. In fact, the IETF rules do not require a
consensus call (or WG Last Call for a draft) to determine consensus.
If the chair(s) of a WG are convinced there is consensus for some
draft or position based on the WG discussions, they are entitled to
declare consensus without a last call or consensus call.

> * I had explained that there was no consensus, that voting is not the IETF way of reaching rough consensus, and provided supporting reference to RFC 7282.

I note that in your point further above, you say "voted". Perhaps it
would be better to say "indicated support" or the like. Also, in an
earlier message, you stated that you were a "member" of the Babel WG.
IETF WGs do not have members or a defined membership. The term usually
used is "participant".

> * The chairs left the objection unaddressed and had declared the situation a consensus.

I responded to your earlier objection message and will respond to your
more recent objection message later today.

Thanks,
Donald

---

From: Juliusz Chroboczek <[email-masked]>
Date: Wed, 27 Jun 2018 23:16:38 +0200

> I believe it is right to leave a record on the Babel WG mailing list
> with the summary of this consensus call, as far as it looked from my
> point of view:

These are personal opinions presented as facts.

I don't think it is entirely honest to present personal opinions as if
they were facts.

-- Juliusz

---

From: Denis Ovsienko <[email-masked]>
Date: Fri, 29 Jun 2018 09:50:20 +0100

Thank you for your response Donald, my comments are below.

 ---- On Wed, 27 Jun 2018 14:12:01 +0100 Donald Eastlake <[email-masked]> wrote ---- 
 > they supported the change. 

The whole point I tried to make in this discussion was I believe this was not the case. Thank you for explaining your point of view anyway.

 > declare consensus without a last call or consensus call. 

I accept the above and would only like to add that with great power comes great responsibility.

 > IETF WGs do not have members or a defined membership. The term usually 

Excuse me, indeed I had used a wrong term. I belong to a few non-IETF interest groups, where "member" is the traditional term, which I had automatically copied here. Of course I meant "participant".

That said, I had intentionally used the term "voting" in this thread to make my point as clear as possible in the sense of RFC 7282. I thought it was easy to see from my comments.

-- 
    Denis Ovsienko