Subject: [babel] Consensus Call for Babel Charter Update (2018-06-17 to 2018-06-25)

From: Donald Eastlake <[email-masked]>
Date: Sun, 17 Jun 2018 10:56:39 -0400

Hi,

Based on the recent discussion on the mailing list, we are asking for
comments in favor or opposed to the following change in the Babel WG
Charter to remove the specification of a YANG model as a gating factor
in moving the Babel protocol to standards track. You can also suggest
further changes but to maximize the chances of getting a change
approved it might be best to minimize the changes.

OLD:
- Address manageability of Babel by producing a Babel informational
model to help provide guidance and derive the data models. To be
consistent with the ongoing effort to use YANG data modules in the
Routing Area, a Babel YANG data model to support management of home
gateway routers is required as part of moving Babel to Proposed
Standard. This information model is useful as a common source of
information for the case where the Customer-Premise Equipment (CPE) is
managed by the Service Provider (SP) with the Broadband Forum TR-069
protocol and its associated data model.

NEW:
- Address manageability of Babel by producing a Babel informational
model to help provide guidance and derive the data models. This
information model is useful as a common source of information for the
case where the Customer-Premise Equipment (CPE) is managed by the
Service Provider (SP) with the Broadband Forum TR-069 protocol and its
associated data model. To be consistent with the ongoing effort to use
YANG data modules in the Routing Area, a Babel YANG data model should
be specified to support management of Babel routers.

The full current Babel WG Charter is at
https://datatracker.ietf.org/doc/charter-ietf-babel/

Thanks,
Donald and Russ

---

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Sun, 17 Jun 2018 17:09:00 +0200

Donald Eastlake <[email-masked]> writes:

> in moving the Babel protocol to standards track.

I'm in favour of adopting this change.

-Toke

---

From: Denis Ovsienko <[email-masked]>
Date: Sun, 17 Jun 2018 20:21:05 +0100

---- On Sun, 17 Jun 2018 15:56:39 +0100 Donald Eastlake <[email-masked]> wrote ---- 
 > https://datatracker.ietf.org/doc/charter-ietf-babel/ 

Hello all.

I oppose the proposed change for the following reasons.

First, the fault is not in the charter. As my previous message to the list discusses, it looks like we (the working group as a whole) have neglected some meaningful parts of our charter: "Particular emphasis will be placed on work needed for a Proposed Standard routing protocol, such as ensuring manageability and strong security." We have achieved exactly the opposite so far, and it would be fair to fix first what is actually broken (specific suggestions are in that message).

Second, de-rating of the requirements level should mean de-rating of the publication category. If the working group explicitly finds itself unable to produce a quality YANG deliverable in time, it could _potentially_ (if the charter allowed it) capture its core (6126bis + whatever security) deliverables as IETF Experimental publications, take a break and retain the motivation to have YANG eventually done and aim for Proposed Standard. But neither the current charter nor the proposed change take this into account.

-- 
    Denis Ovsienko

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 18 Jun 2018 00:03:16 +0000

> I'm in favour of adopting this change.

+1 Barbara

---

From: Dave Taht <[email-masked]>
Date: Sun, 17 Jun 2018 17:20:22 -0700

>> I'm in favour of adopting this change.

+1 Dave
> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel

-- 

Dave Täht
CEO, TekLibre, LLC
http://www.teklibre.com
Tel: 1-669-226-2619

---

From: Juliusz Chroboczek <[email-masked]>
Date: Mon, 18 Jun 2018 02:28:22 +0200

Cool.  Support, and thanks.

-- Juliusz

---

From: Donald Eastlake <[email-masked]>
Date: Mon, 18 Jun 2018 10:27:51 -0400

Hi Denis,

Thanks for your comments.

On Sun, Jun 17, 2018 at 3:21 PM, Denis Ovsienko <[email-masked]> wrote:
>  > ...

This Charter change is about process and gating, not about ultimate
goals. There is substantial work on manageability in the Information
Model and we do have a volunteer to do a preliminary YANG model. The
problem is the interlock in the current Charter between the YANG model
and the base protocol getting to Proposed Standard status and the
normative dependency on Babel in the HOMENT WG.

> Second, de-rating of the requirements level should mean de-rating of the publication category. If the working group explicitly finds itself unable to produce a quality YANG deliverable in time, it…

The entire thrust of this WG effort is to move Babel to the Standards
Track and any change from that would be a major change for which I
have not seen any support except your message.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: David Schinazi <[email-masked]>
Date: Mon, 18 Jun 2018 09:28:57 -0700

Thanks Donald and Russ!

I support this change.

David Schinazi

> On Jun 17, 2018, at 07:56, Donald Eastlake <[email-masked]> wrote:
> 
> Hi,
>

---

From: Markus Stenberg <[email-masked]>
Date: Mon, 18 Jun 2018 19:59:53 +0300

Looks good to me as well; +1 

-Markus

---

From: Gabriel Kerneis <[email-masked]>
Date: Mon, 18 Jun 2018 23:03:01 +0200

Looks like the best way forward to unlock the situation. Approved.

Gabriel

Le lun. 18 juin 2018 à 19:00, Markus Stenberg <[email-masked]> a

---

From: Matthieu Boutier <[email-masked]>
Date: Tue, 19 Jun 2018 07:15:49 +0200

> remove the specification of a YANG model as a gating factor

I also support this change. Thanks Donald.

Matthieu

---

From: Denis Ovsienko <[email-masked]>
Date: Wed, 20 Jun 2018 16:31:51 +0100

Thank you for your comments Donald, please see my questions and comments below.

 ---- On Mon, 18 Jun 2018 15:27:51 +0100 Donald Eastlake <[email-masked]> wrote ---- 
 > normative dependency on Babel in the HOMENT WG. 

I am sorry, but the only way I can read the above is it begins saying it is not about ultimate goals, and then says Proposed Standard is an ultimate goal and justifies bending the rules. Can you see it from this point of view?

The _intentional_ dependency on YANG has been in the charter for 2 years, but only now it suddenly became a "problem", do you agree it looks strange enough to deserve a proper explanation?

 > have not seen any support except your message. 

Standards Track work indeed has been the IETF's expectation of this working group. This was a reasonable initial expectation based on the way the pre-IETF work was presented at the IETF. That said, if the actual in-IETF results were as good as expected, there would not be this call and this discussion in the first place, do you agree?

I agree the proportional de-rating would be a major change to the charter. However, just writing deliverables off with no consequences would be a major change too, and in addition to that it would be difficult to distinguish from just gaming the Standards Track process. Does one of the evils look significantly less than the other?

I agree 8 people on the list have voted to support the charter change so far, and I am the only one who has objected so far. Notwithstanding the fact, I believe this working group does not yet have valid grounds to declare consensus on this call and to ask to change the charter. The matter is, your message that starts this call asks for _comments_. This is indeed a valid way to start a consensus process, and it is not a warrant to reduce it to a voting. To emphasize the difference, let me quote this:

"We reject kings, presidents and voting. We believe in rough consensus and running code."

One of the reasons I decided to join the IETF in 2016 was I knew what this saying is intended to mean -- long before that I had read RFC 7282 (On Consensus and Humming in the IETF). The document explains in detail why opposing a majority of _votes_ with a reasoned _objection_ in a call for _consensus_ is a normal IETF approach and it should not be questioned or dismissed. Specifically, it tells why the situation with this call is _not_ a consensus (and what could be done to try to achieve it).

To sum my position up, the right thing to do would be either to leave the charter intact or to ask for proportional de-rating on both sides of the deal like suggested, in either case the working group should keep to the intended IETF methods of work. I am willing to address any comments regarding my input to this consensus call.

Thank you.

-- 
    Denis Ovsienko

---

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Wed, 20 Jun 2018 17:43:42 +0200

Denis Ovsienko <[email-masked]> writes:

> One of the reasons I decided to join the IETF in 2016 was I knew what
> this saying is intended to mean -- long before that I had read RFC
> 7282 (On Consensus and Humming in the IETF). The document explains in
> detail why opposing a majority of _votes_ with a reasoned _objection_
> in a call for _consensus_ is a normal IETF approach and it should not
> be questioned or dismissed.

Your argument seems to be that no change to the charter is allowed
except one that degrades everything to something less than standards
track. While this is certainly an objection, I fail to see how it is
anything resembling "reasoned".

-Toke

---

From: "Russ White" <[email-masked]>
Date: Wed, 20 Jun 2018 13:03:18 -0400

> I am sorry, but the only way I can read the above is it begins saying it is not
> about ultimate goals, and then says Proposed Standard is an ultimate goal
> and justifies bending the rules. Can you see it from this point of view?

While proposed standard remains the ultimate goal, the path to reach that goal may need to shift over time to account for present realities. IMHO, a YANG model will be built for BABEL, but _requiring_ it "right now" has become a road block. 

There is an explanation for this, but it's not something the chairs, AD's, etc. feel the need to discuss publicly. It is better to focus on what we can focus on, and reshape the process towards the ultimate goal, than to allow the work to stall entirely. 

😊

Russ

---

From: Juliusz Chroboczek <[email-masked]>
Date: Wed, 20 Jun 2018 21:56:36 +0200

> I agree 8 people on the list have voted to support the charter change so
> far, and I am the only one who has objected so far. Notwithstanding the
> fact, I believe this working group does not yet have valid grounds to
> declare consensus on this call and to ask to change the charter.

We haven't achieved unanimity.  Consensus doesn't require unanimity.

Eight major contributors to the Babel protocol, including all of the known
active implementers, have expressed support for the change.  One lone
contributor has expressed opposition, with no technical arguments to
support his position.

> opposing a majority of _votes_ with a reasoned _objection_ in a call for
> _consensus_ is a normal IETF approach and it should not be questioned or
> dismissed.

I have read your mail from 17 June very carefully, and my understanding is
that your objection basically amounts to "any change to the charter is
unacceptable".  I do not personally believe that this is the kind of
serious technical objection that would suffice to break consensus on its
own.

-- Juliusz

---

From: Denis Ovsienko <[email-masked]>
Date: Wed, 20 Jun 2018 23:19:18 +0100

---- On Wed, 20 Jun 2018 16:43:42 +0100 Toke Høiland-Jørgensen <[email-masked]> wrote ---- 
 > anything resembling "reasoned". 

Hello Toke.

What you are describing is my conclusion, and how I come to that conclusion I took care to explain in a few recent messages to the list. Of course this is not apparent from the only paragraph you have quoted above, but still.

You are welcome to provide a better example of reasoning in support of your position.

-- 
    Denis Ovsienko

---

From: Denis Ovsienko <[email-masked]>
Date: Wed, 20 Jun 2018 23:31:48 +0100

---- On Wed, 20 Jun 2018 18:03:18 +0100 Russ White <[email-masked]> wrote ---- 
 > There is an explanation for this, but it's not something the chairs, AD's, etc. feel the need to discuss publicly. It is better to focus on what we can focus on, and reshape the process towards th…

Thank you for the comment Russ, but to me it does not make a complete sense yet. Wherever the change initiates, if it comes to a WG consensus call at some stage, it should be treated as such.

-- 
    Denis Ovsienko

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 27 Jun 2018 15:44:14 -0400

Hi Denis,

> I am sorry, but the only way I can read the above is it begins saying it is not about ultimate goals, and then says Proposed Standard is an ultimate goal and justifies bending the rules. Can you se…

No, I don't see that. There is no rule being bent. The Charter is
something specified by the IESG, the IESG can change it, and the WG
can ask the IESG to change it. Standards track status for Babel was
and remains a goal. Manageability for Babel was and remain a goal.

> The _intentional_ dependency on YANG has been in the charter for 2 years, but only now it suddenly became a "problem", do you agree it looks strange enough to deserve a proper explanation?

No, I do not agree. Perhaps everyone should always keep the WG Charter
details in mind but many IETF participants, even WG Officers,
sometimes overlook those details. And the longer it has been since the
WG was Chartered, the more memory of those details may fade although,
of course, they are still documented in writing in the Charter itself.
And the longer it has been since the WG was Chartered, the more likely
it is that circumstances have changed so that an adjustment to the
Charter is called for. So I do not think it is strange that the
"problem" is noticed now.

Let me give an example of people missing something in a Charter,
although it is a little embarrassing. When I took over as Chair of the
PPPEXT WG, Jim Carlson had long been the Chair. At the time, a draft
targeted for Proposed Standard was going through the WG, was found to
have WG consensus, and forwarded to the IESG. The only problem with
this was that the PPPEXT Charter said that the purpose of the WG was
only to review documents related to PPP and that the PPPEXT WG was
specifically prohibited from producing any new documents.  :-)
Neither Jim Carlson, who had been Chair for years, nor myself who had
taken over had noticed this. In fact, the Area Director for the WG
didn't notice this either and went ahead and issued an IETF Last Call
on the draft before this problem was noticed by another IESG member.
(The IESG solved the problem in this case by treating the document as
if it was not a WG document and re-issuing the IETF Last Call for the
required longer period of time.)

> Standards Track work indeed has been the IETF's expectation of this working group. This was a reasonable initial expectation based on the way the pre-IETF work was presented at the IETF. That said,…

I do not agree. Whether results are "good" or not is a judgement call.
Whether or not there is a YANG model is a factor some people would
include in such a judgement. But there are many other factors.

> One of the reasons I decided to join the IETF in 2016 was I knew what this saying is intended to mean -- long before that I had read RFC 7282 (On Consensus and Humming in the IETF). The document ex…

You are entitled to your opinion that this Charter change is not a
good idea and that either Charter should not be changed or, if it is
changed as indicated, the based Babel draft should re-cycle at
Experimental. However, that is not the consensus of the WG.

Any objection can be written up at great length and with many reasons
as to why it is a good objection. This does not mean that one person
can just block progress by writing up their objection that way. RFC
7282 applies only to technical objections and we are discussing
process here.  I'd be willing to say that a minority or one person who
point to a significant violation of process rules can stop something
even if many are in favor of it. But there is no process rules
violation in asking the IESG to make this minor Charter change. That's
not just my opinion but we have an explicit post by our AD stating it.

> To sum my position up, the right thing to do would be either to leave the charter intact or to ask for proportional de-rating on both sides of the deal like suggested, in either case the working gr…

"Experimental" is not a de-rating of "Proposed Standard". They are
different things for different purposes. I do not think the WG is
going outside of "intended IETF methods of work".

I'm sorry you are not happy but I do not see a reason to revisit the
determination that the WG consensus is in favor of the Charter change.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: Denis Ovsienko <[email-masked]>
Date: Fri, 29 Jun 2018 12:58:05 +0100

Thank you for this follow-up, my comments are inline.

 ---- On Wed, 27 Jun 2018 20:44:14 +0100 Donald Eastlake <[email-masked]> wrote ---- 
 > and remains a goal. Manageability for Babel was and remain a goal. 

This is a good statement, but it would be even better if it emphasized the relation between the status and the quality of deliverables.

I have closely worked with enough RFCs on the implementer's side to learn that a Standards Track status is not a guarantee of technical quality. An opportunity to improve this situation was another reason why I began to contribute to the IETF. So if anyone is ever concerned, my point of view on lowering the requirements bar is such for reasons that have formed years ago from first-hand experience. I am fine to stand corrected for the exact language I use, but not for this position.

 > required longer period of time.) 

Thank you for such a detailed comment Donald. Your experience definitely lets you relate things differently from how they look to me. But my experience lets me see other details that I consider meaningful enough to bring up if nobody else does.

 > include in such a judgement. But there are many other factors. 

One particular fact I brought up was that the WG is at least a year behind the originally agreed milestones. I do not agree this was just my subjective judgement about the WG performance.

I agree there are also other factors to take into account. That said, I do not agree it is OK to act like there is no problem at all.

 > Experimental. However, that is not the consensus of the WG. 

I confirm you understand the position I maintain, and I confirm I understand the position you maintain.

 > not just my opinion but we have an explicit post by our AD stating it. 

Thank you for explaining your grounds as a WG chair in detail Donald. As a WG participant I have made my best to treat this call for consensus as genuine, because I see YANG as a manifestation of a bigger problem.

 > determination that the WG consensus is in favor of the Charter change. 

I confirm once again I understand your position and its differences from mine.

-- 
    Denis Ovsienko