Subject: Re: [babel] (David) I-D Action: draft-ietf-babel-information-model-02.txt

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 5 Jun 2018 17:41:00 +0000

Response in-line.
Barbara

> -----Original Message-----
> From: [email-masked] <[email-masked]>
> 
> Two minor comments:
> 
> 1) babel-hello-[mu]cast-history is an implementation detail documented in
> an appendix, should it be exposed?
> Isn't rxcost/txcost/cost sufficient?

The subsequent thread on this suggested it was ok to keep this as an optional parameter. So I left it.
 
> 2) Regarding security, should it be possible to pull the private key from a
> router? Is that common practice?

The subsequent thread on this suggested the general design of the info model was ok. But I did add a statement to the description of the self-credential parameter that said "any private key component of a credential MUST NOT be readable".

---

From: David Schinazi <[email-masked]>
Date: Tue, 05 Jun 2018 12:27:10 -0700

Thanks Barbara, that works for me.

David

> On Jun 5, 2018, at 10:41, STARK, BARBARA H <[email-masked]> wrote:
> 
> Response in-line.
> Barbara
> 
> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel