Subject: [babel] Info Model: babel-neighbor-address

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 11 Oct 2018 23:54:12 +0000

In one of the recent info model iterations, we removed IPv4 multicast address and I think it was said that people only want to run Babel over IPv6.

Is this correct? Is this still the conscious group consensus?

The babel-neighbor-address parameter currently says IPv4 or IPv6. But if Babel will only run over IPv6, should this only allow IPv6 addresses?

Barbara

---

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Fri, 12 Oct 2018 11:53:05 +0200

"STARK, BARBARA H" <[email-masked]> writes:

> In one of the recent info model iterations, we removed IPv4 multicast
> address and I think it was said that people only want to run Babel
> over IPv6.
>
> The babel-neighbor-address parameter currently says IPv4 or IPv6. But
> if Babel will only run over IPv6, should this only allow IPv6
> addresses?

IMO, yes. I also think we should get rid of the v4 address from the base
spec. Not sure if there's consensus on that, though...

Also, you misspelled 'neighbour' ;)

-Toke

---

From: Juliusz Chroboczek <[email-masked]>
Date: Sat, 13 Oct 2018 13:54:05 +0200

> spec. Not sure if there's consensus on that, though...

Babel has been implemented over a proprietary, non-IP protocol in the past
[1], so we know that it does generalise to non-IPv6 environments.  I'm not
sure whether we want to reflect that in the spec or not.

Personal opinion -- leave the spec as it is, with IPv4.  No opinion about
the information model.

[1] https://www.thinkmind.org/download.php?articleid=ubicomm_2011_6_20_10156

-- Juliusz

---

From: Donald Eastlake <[email-masked]>
Date: Sun, 14 Oct 2018 22:54:50 -0400

Hi,

I'd be inclined to leave in IPv4 support also.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 1424 Pro Shop Court, Davenport, FL 33896 USA
 [email-masked]

On Sat, Oct 13, 2018 at 7:54 AM Juliusz Chroboczek <[email-masked]> wrote:
> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel