Subject: [babel] Info Model: router-id as base64

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 11 Oct 2018 22:43:48 +0000

This is the first of several emails I'm sending out asking for WG feedback on some info model questions.

I've gotten a couple of people questioning the use of base64 data type for the router-id. Since the router-id is more properly just an arbitrary 64 bits, might it make better sense to represent this as just 64 bits? I've also had hex suggested.
Barbara

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 12 Oct 2018 00:46:48 +0200

On Oct 12, 2018, at 00:43, STARK, BARBARA H <[email-masked]> wrote:
> I've gotten a couple of people questioning the use of base64 data type for the router-id. Since the router-id is more properly just an arbitrary 64 bits, might it make better sense to represent this as just 64 bits? I’ve also had hex suggested.

In an information model, you want to talk about what it *Is*, not how it could be represented.
Base64 or Base16 (a.k.a. hex) are non-starters here.
Is it a number, or is it a byte string?

Grüße, Carsten

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 11 Oct 2018 22:58:01 +0000

> From: Carsten Bormann <[email-masked]>
> 
> > I've gotten a couple of people questioning the use of base64 data type for
> the router-id. Since the router-id is more properly just an arbitrary 64 bits,
> might it make better sense to represent this as just 64 bits? I’ve also had hex
> suggested.
> 

babel-rfc6126bis says the router-id "is an arbitrary string of 8 octets". So I'd say it's a byte string.
Barbara

---

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Fri, 12 Oct 2018 12:06:00 +0200

> octets". So I'd say it's a byte string.

Yeah, it is. Specify it as such, and then whoever uses the information
model can decide which base they want to represent it in?

-Toke