Subject: [babel] Interface types in babeld

From: Juliusz Chroboczek <[email-masked]>
Date: Thu, 28 Mar 2019 15:45:29 +0100

Dear Barbara, dear all,

Concerning your query about interface types.  In babeld, an interface can
be configured by setting individual parameters:

  interface eth0 link-quality true

or by using an "interface type", which is a consistent bundle of parameters:

  interface eth0 type wired

Individual parameters can be overridden; for example

  interface eth0 type wired split-horizon false

means that eth0 has all the parameters of the type "wired", except that
split-horizon is disabled.

Currently, the interface types are:

  wired:    cost 256 split-horizon true link-quality false
  wireless: cost 96 split-horizon false link-quality true
  tunnel:   cost 96 split-horizon true link-quality false
            timestamps true max-rtt-penalty 96

The interface types are defined as not being stable between versions -- we
try to keep the individual parameters compatible between versions, but the
bundle of parameters corresponding to an interface type can be improved
between versions.

-- Juliusz

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 28 Mar 2019 17:17:06 +0100

> On Mar 28, 2019, at 3:45 PM, Juliusz Chroboczek <[email-masked]> wrote:
> 
> Dear Barbara, dear all,
> 

I suggest that we model link type as the set of parameters defined here and use the default values indicated here. 

- name e.g. wired, wireless, tunnel
- cost 
- split-horizon 
- link-quality
- timestamps
- max-rtt-penalty

The default values can be improved with each version and based on implementation experience. 

> bundle of parameters corresponding to an interface type can be improved

Mahesh Jethanandani 
[email-masked]

> 
> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel