Subject: [babel] Do we want to adopt draft-jonglez-babel-rtt-extension?

From: Juliusz Chroboczek <[email-masked]>
Date: Sat, 09 Mar 2019 16:13:18 +0100

Dear all,

Of all the Babel protocol extensions, the ones that are used in production
are all IETF WG documents.  Except draft-jonglez-babel-rtt-extension.

  https://tools.ietf.org/html/draft-jonglez-babel-rtt-extension

Draft-jonglez-babel-rtt-extension consists of one non-mandatory sub-TLV
that can be carried on Hello and IHU packets.  It contains enough data to
apply Mills' algorithm (the one used in the HELLO routing protocol and
later in NTP) in order to compute an estimate of RTT with microsecond
granularity.  The draft only specifies how to compute RTT -- using RTT for
something useful is left to the implementation -- but it gives an example
of using RTT in order to derive link cost.

The algorithm is described in more detail in

    https://arxiv.org/pdf/1403.3488.pdf

The actual motivation is overlay networks, where a single hop might span
continents, and least-hop routing yields suboptimal results.  The
algorithm has been used in production for a few years now by a French
company called Nexedi.

The same subprotocol could probably be used in other kinds of networks,
most notably congested wireless networks.  More experimentation is needed.

Personal opinion -- the algorithm as described in the draft has one flaw:
since the IHU sub-TLV does not carry a Transmit timestamp, the IHU sub-TLV
is only useful in cases where the same Packet contains a Hello TLV.  I'm
not sure if people would be happy with a flag day, so fixing that would
require either eating up another sub-TLV number, or putting the Transmit
timestamp at the very end of the sub-TLV (which would make for an ugly
format).

Do we want to adopt this draft?  I can easily upload a new revision before
Monday's cutoff date.

-- Juliusz

---

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Sat, 09 Mar 2019 16:27:17 +0100

> Do we want to adopt this draft?  I can easily upload a new revision before

I was planning to eventually implement this anyway, so sure, I support
adoption :)

-Toke

---

From: Dave Taht <[email-masked]>
Date: Sun, 10 Mar 2019 13:47:50 -0700

I support adoption.

On Sat, Mar 9, 2019 at 7:27 AM Toke Høiland-Jørgensen
<toke=[email-masked]> wrote:
> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel

-- 

Dave Täht
CTO, TekLibre, LLC
http://www.teklibre.com
Tel: 1-831-205-9740

---

From: Juliusz Chroboczek <[email-masked]>
Date: Sun, 10 Mar 2019 23:42:49 +0100

Thanks to both of you for your support.

Donald, if that's okay with you, I'm going to upload a new revision of
this draft tomorrow morning, and formally request adoption in Prague.

-- Juliusz

---

From: Donald Eastlake <[email-masked]>
Date: Sun, 10 Mar 2019 20:05:36 -0400

Hi Juliusz,

> this draft tomorrow morning, and formally request adoption in Prague.

Sure, that sounds reasonable.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 1424 Pro Shop Court, Davenport, FL 33896 USA
 [email-masked]

---

From: "Justin Kilpatrick" <[email-masked]>
Date: Mon, 11 Mar 2019 08:47:09 -0400

I will note that we (Althea) also use the RTT extension in production. We have a mixed network of point to point wireless hops and long distance internet traversing hops. The RTT extension eliminates the need for us to manually indicate which is which. 

-- 
 Justin Kilpatrick
 [email-masked]

On Sun, Mar 10, 2019, at 8:05 PM, Donald Eastlake wrote:
>  Donald E.. Eastlake 3rd +1-508-333-2270 (cell)

---

From: David Schinazi <[email-masked]>
Date: Mon, 11 Mar 2019 12:50:00 -0700

I also support adoption.

David

On Mon, Mar 11, 2019 at 5:47 AM Justin Kilpatrick <[email-masked]>
wrote:

> I will note that we (Althea) also use the RTT extension in production. We
> have a mixed network of point to point wireless hops and long distance
> internet traversing hops. The RTT extension eliminates the need for us to
> manually indicate which is which.
>
> --
>   Justin Kilpatrick
>   [email-masked]
>
>
>