Subject: Re: [babel] info-model: message vs. packet

From: Juliusz Chroboczek <[email-masked]>
Date: Tue, 05 Mar 2019 15:27:14 +0100

> I notice the various Babel drafts use "packet" more than "message".

Babel has two distinct notions:

  - a packet is a 4-octet header followed by a sequence of TLVs;
  - a TLV is one of the things defined in Section 4 of 6126bis.

Early drafts of RFC 6126 used "message" where we now use "TLV" (thanks to
Joel Halpern for fixing the terminology).  As a general rule, I suggest
that you should be consistent with 6126bis, and use "packet" and "TLV"
exclusively.

> This would impact some parameter names:
> babel-message-log -> babel-packet-log
> babel-message-log-enable -> babel-packet-log-enable
> babel-received-messages -> babel-received-packets (this is a statistic)

In the first two cases, it doesn't matter, no ambiguity is possible.  In
the third case, you should be precise -- is this intended to count packets
or TLVs?

-- Juliusz

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 5 Mar 2019 14:45:09 +0000

Thx. And good.
In my most recent editor's draft I did purge all use of "message" from the info model (including changing the log to be a packet log). There's no mention of TLVs in the info model. 
https://bhstark2.github.io/babel-information-model/draft-ietf-babel-information-model.html

I'm putting the xml of this into datatracker imminently.
Barbara

> -----Original Message-----
> From: Juliusz Chroboczek <[email-masked]>
> Sent: Tuesday, March 05, 2019 9:27 AM
> To: STARK, BARBARA H <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [babel] info-model: message vs. packet
> 
> Joel Halpern for fixing the terminology).  As a general rule, I suggest that you
> should be consistent with 6126bis, and use "packet" and "TLV"
> exclusively.
> 
> In the first two cases, it doesn't matter, no ambiguity is possible.  In the third
> case, you should be precise -- is this intended to count packets or TLVs?
> 
> -- Juliusz

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 5 Mar 2019 14:55:40 +0000

> case, you should be precise -- is this intended to count packets or TLVs?

I forgot to reply to this. It's just intended as a packet count. Packet counts can be useful because you can see at what rate a count increases (or whether it increases at all) to get some sense of Babel "health". Are any packets being received from a neighbor? Is the interval between packets expected? Etc.

I don't see a compelling use for TLV counts. I think if I have questions about what's going on at a TLV level, I'm better off just getting a packet log and examining the TLVs using tools external to the Babel-running-device.
Barbara

---

From: Juliusz Chroboczek <[email-masked]>
Date: Tue, 05 Mar 2019 16:09:16 +0100

> It's just intended as a packet count. [...] I don't see a compelling use
> for TLV counts.

Agreed.

-- Juliusz