Subject: [babel] 6126bis: implementing Babel-MAC is RECOMMENDED

From: Juliusz Chroboczek <[email-masked]>
Date: Tue, 24 Dec 2019 00:42:36 +0100

Dear all,

I've just committed some tweaks to 6126bis to the Git repository.  There's
a bunch of wording tweaks that aim at clarifying the security language,
but there's also one single-sentence paragraph with normative language:

    Every implementation of Babel SHOULD implement BABEL-MAC.

This was not discussed by the WG, and hence I do not know to what extent
this change fits WG consensus.  I'd be pleased if people who disagree with
this change could let me know now rather than later.

-- Juliusz

---

From: Juliusz Chroboczek <[email-masked]>
Date: Tue, 24 Dec 2019 00:50:42 +0100

>     Every implementation of Babel SHOULD implement BABEL-MAC.

I'm realising that this may seem somewhat cryptic to those of you who
haven't been following the ongoing discussion with the IESG.

Babel-MAC is already the RECOMMENDED cryptographic protection mechanism.
However, there's no normative language that recommends implementing
Babel-MAC.  This merely adds a recommendation for implementers, as opposed
to network administrators (who are already encouraged to deploy Babel-MAC).

-- Juliusz

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 24 Dec 2019 10:58:59 -0500

Hi Juliusz,

Season's Greetings!

Speaking just as a member of the WG, I think this is a reasonable
minor change. As you point out, use of Babel-MAC was recommended when
it provided the security features needed so it seems reasonable to
RECOMMEND its implementation.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

On Mon, Dec 23, 2019 at 6:50 PM Juliusz Chroboczek <[email-masked]> wrote:
> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Fri, 27 Dec 2019 14:52:02 +0000

I agree -- with the change and with what Donald said.
Barbara

> -----Original Message-----
> From: babel <[email-masked]> On Behalf Of Donald Eastlake
> Sent: Tuesday, December 24, 2019 10:59 AM
> To: Juliusz Chroboczek <[email-masked]>
> Cc: David Schinazi <[email-masked]>; Babel at IETF
> <[email-masked]>
> Subject: Re: [babel] 6126bis: implementing Babel-MAC is RECOMMENDED
> 
> Hi Juliusz,
> 
> Season's Greetings!
> 
> Speaking just as a member of the WG, I think this is a reasonable minor
> change. As you point out, use of Babel-MAC was recommended when it
> provided the security features needed so it seems reasonable to
>  2386 Panoramic Circle, Apopka, FL 32703 USA  [email-masked]
> 
> > Babel-MAC.  This merely adds a recommendation for implementers, as
> > opposed to network administrators (who are already encouraged to deploy
> Babel-MAC).
> >
> > -- Juliusz
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mail
> > man_listinfo_babel&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-
> 8sc8SY8T
> >
> q4vrfog&m=05TfINwjdsEszrnTHiGaQNngGrBDbZT7y9yuUYORZMc&s=Sk7JQ1
> TnSy-u9I
> > aRMHDq-pShPTZ5e1Gz8QD9I0u-Pgc&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_babel&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=LoGzhC-
> 8sc8SY8Tq4vrfog&m=05TfINwjdsEszrnTHiGaQNngGrBDbZT7y9yuUYORZMc&s
> =Sk7JQ1TnSy-u9IaRMHDq-pShPTZ5e1Gz8QD9I0u-Pgc&e=

---

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Fri, 27 Dec 2019 18:17:18 +0100

> I agree -- with the change and with what Donald said.

+1

-Toke

---

From: Dave Taht <[email-masked]>
Date: Fri, 27 Dec 2019 09:25:03 -0800

+1