Subject: [babel] v4-via-v6: what about ICMPv4?

From: Juliusz Chroboczek <[email-masked]>
Date: Mon, 27 Jul 2020 16:12:48 +0200

Dear all,

Margaret (in copy of this mail) made two comments during Théo's
presentation about v4-via-v6.

1. We should call it « v4-via-v6 » instead of « v4-over-v6 ».

I think she's right.  I haven't discussed it with Théo yet.  Comments?

2. In a network that's routing IPv4 but where some interfaces have no v4
   addresses, there might be issues with ICMPv4.  In particular, a router
   might find itself unable to send an ICMPv4 packet.

I haven't thought about the issue yet, I'll start looking at the
litterature to see if the problem has been considered.  If anyone knows
anything about this issue, please let me know.

Thanks for your help,

-- Juliusz

---

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Mon, 27 Jul 2020 16:19:18 +0200

> I think she's right.  I haven't discussed it with Théo yet.  Comments?

Fine with me.

> anything about this issue, please let me know.

No idea, I'll await your no doubt thorough literature review :)

What happens if you run traceroute over your test v4-over-v6 setup?

-Toke

---

From: Théophile Bastian <[email-masked]>
Date: Mon, 27 Jul 2020 16:23:37 +0200

> I think she's right.  I haven't discussed it with Théo yet.  Comments?

I would tend to agree, too. I find "via" a bit more accurate, "over" 
sounds a bit like tunnels now that I think about it.

> What happens if you run traceroute over your test v4-over-v6 setup?

I'll try this right away and update you.

-- 
Théophile Bastian

---

From: Théophile Bastian <[email-masked]>
Date: Mon, 27 Jul 2020 17:15:28 +0200

>> What happens if you run traceroute over your test v4-over-v6 setup?

In this topology:

A --- B --- C --- D --- E
  4   4             4   4

I get

# tracepath 10.132.4.5
  1?: [LOCALHOST]                      pmtu 1500
  1:  ???                                                   0.089ms
  1:  ???                                                   0.083ms
  2:  no reply
  3:  ???                                                   0.154ms
  4:  ???                                                   0.149ms reached
      Resume: pmtu 1500 hops 4 back 4

while trying a tracepath from A to E.

-- 
Théophile Bastian

---

From: Margaret Cullen <[email-masked]>
Date: Mon, 27 Jul 2020 11:27:32 -0400

Does this imply that if network AB had a higher MTU than network CD, large IPv4 packets from network AB with the DF (don’t fragment) bit set would black-holed by router C?  

I need to go refresh my memory of IPv4 MTU discovery to know what issues (if any) that would cause...

> On Jul 27, 2020, at 11:15 AM, Théophile Bastian <[email-masked]> wrote:
> 
> 
>> 
> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel

---

From: David Schinazi <[email-masked]>
Date: Mon, 27 Jul 2020 11:54:46 -0700

1) I like "via", it's more accurate than "over"

2) ICMP
Allow me to paraphrase what's already been
said to make sure I understand the problem correctly.
The topology is: A --- B --- C --- D --- E
and every node is dual-stacked except C who doesn't
have an IPv4 address. A is sending IPv4 packets to E,
with the DontFragment bit set, and using the full MTU
for A --- B.

scenario a) D --- E has a lower MTU than all the other links,
so it'll send ICMP to A's IPv4 address, and that should work
fine because to C this just looks like any other IPv4 packet
addressed to A.

scenario b) C --- D has a lower MTU than all the other links,
and C realizes that it won't be able to forward this IPv4 packet
because it's too big. We know that C has some notion of IPv4
even though it's not provisioned with an IPv4 address. So,
couldn't we just say that C SHOULD send ICMP using a bogus
source IPv4 address? If C doesn't want to implement ICMPv4,
then it just silently drops the packet. In practice ICMP isn't
reliable over the Internet today, so modern protocols have
mechanisms for PMTUD that can survive ICMP blackholing.
All this to say that I think we should address this in the draft,
but I don't think it's a dealbreaker.

David

On Mon, Jul 27, 2020 at 8:27 AM Margaret Cullen <
[email-masked]> wrote:

>
> Does this imply that if network AB had a higher MTU than network CD, large
> IPv4 packets from network AB with the DF (don’t fragment) bit set would
> black-holed by router C?
>