Subject: Re: [babel] Last Call: <draft-ietf-babel-information-model-11.txt>, naming inconsistencies

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 2 Nov 2020 20:15:24 +0000

Hi Antonin,
Thanks again. I see in this email that, in addition to the previous 2 errors related to mac-key-sets, you include corrections for Section 2:

-   +-- router-id
-   +-- self-seqno

+   +-- babel-self-router-id
+   +-- babel-self-seqno

I'll include these fixes in the next version.
Thx,
Barbara

> ---
> Dear all,
> 
> I’ve found some inconsistencies in the naming of some fields in the
> Babel Information Model. I’ve already send mails about them; but I’m
> afraid my mails might have fallen in limbo. The issue is minor.
> Below is a patch for the fields.
> 
> Best regards,
> 
> Antonin
> 
> 
>  draft-ietf-babel-information-model.md | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/draft-ietf-babel-information-model.md b/draft-ietf-babel-
> information-model.md
> index 7990b7a..1588797 100644
> --- a/draft-ietf-babel-information-model.md
> +++ b/draft-ietf-babel-information-model.md
> @@ -179,8 +179,8 @@ The Information Model is hierarchically structured as
> follows:
>  +-- babel-information
> 
>     +-- babel-implementation-version
> 
>     +-- babel-enable
> 
> -   +-- router-id
> 
> -   +-- self-seqno
> 
> +   +-- babel-self-router-id
> 
> +   +-- babel-self-seqno
> 
>     +-- babel-metric-comp-algorithms
> 
>     +-- babel-security-supported
> 
>     +-- babel-mac-algorithms
> 
> @@ -534,7 +534,7 @@ babel-mac-enable:
>    An implementation MAY choose
> 
>    to expose this parameter as read-only ("ro").
> 
> 
> 
> -babel-if-mac-keys-sets:
> 
> +babel-if-mac-key-sets:
> 
>  : List of references to the babel-mac entries that apply to this
> 
>    interface. When an interface instance is created, all babel-mac-key-sets
> 
>    instances with babel-mac-default-apply "true" will be included
> 
> @@ -828,7 +828,7 @@ babel-mac-default-apply:
>    applied to all new babel-interface instances, by default.
> 
>    If "true", this instance is applied to
> 
>    new babel-interfaces instances at the time they are created, by including
> 
> -  it in the babel-interface-mac-keys list.
> 
> +  it in the babel-if-mac-key-sets list.
> 
>    If "false", this instance is not applied to new babel-interfaces
> 
>    instances when they are created.
> 
>    An implementation MAY choose
> 
> --
> 2.29.1

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 4 Nov 2020 23:42:31 +0000

Thank you Antonin, for helping me (in a private email exchange) identify more of these inconsistencies. This is the additional set we identified:

OLD
   } babel-mac-obj;
NEW
   } babel-mac-key-set-obj;

OLD
   babel-mac-default-apply:  A Boolean flag indicating whether this
      babel-mac instance is applied to all new babel-interface
NEW
   babel-mac-default-apply:  A Boolean flag indicating whether this
      object instance is applied to all new babel-interface

OLD
      including it in the babel-interface-mac-keys list.  If "false",
NEW
      including it in the babel-if-mac-key-sets list.  If "false",

OLD
   babel-dtls-default-apply:  A Boolean flag indicating whether this
      babel-dtls instance is applied to all new babel-interface
NEW
   babel-dtls-default-apply:  A Boolean flag indicating whether this
      object instance is applied to all new babel-interface

Barbara

> -----Original Message-----
> From: STARK, BARBARA H
> Sent: Monday, November 02, 2020 2:15 PM
> To: 'Antonin Décimo' <[email-masked]>; [email-masked]' <last-
> [email-masked]>; [email-masked]' <draft-ietf-
> [email-masked]>; [email-masked]' <[email-masked]>
> Subject: RE: [babel] Last Call: <draft-ietf-babel-information-model-11.txt>,
> naming inconsistencies
> 
> Hi Antonin,
> Thanks again. I see in this email that, in addition to the previous 2 errors
> related to mac-key-sets, you include corrections for Section 2:
> 
> -   +-- router-id
> -   +-- self-seqno
>