Subject: [babel] I-D Action: draft-ietf-babel-information-model-14.txt

From: [email-masked]
Date: Thu, 11 Mar 2021 17:21:10 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Babel routing protocol WG of the IETF.

        Title           : Babel Information Model
        Authors         : Barbara Stark
                          Mahesh Jethanandani
	Filename        : draft-ietf-babel-information-model-14.txt
	Pages           : 23
	Date            : 2021-03-11

Abstract:
   This Babel Information Model provides structured data elements for a
   Babel implementation reporting its current state and may allow
   limited configuration of some such data elements.  This information
   model can be used as a basis for creating data models under various
   data modeling regimes.  This information model only includes
   parameters and parameter values useful for managing Babel over IPv6.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-babel-information-model/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-babel-information-model-14.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-babel-information-model-14

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: tom petch <[email-masked]>
Date: Tue, 16 Mar 2021 11:41:17 +0000

Barbara

I was looking at babel-yang-model and realised that it was impossible to understand without a comprehensive understanding of babel-information-model so the latter is clearly a Normative Reference.  Except, of course, that the latter has been put forward as Informational which is perhaps why the YANG I-D lists the latter as an Informational Reference but I cannot see that approach going anywhere ie it immediately becomes a downref:-(

In passing, imports of IETF modules must use the prefix specified in the RFC which the import of ietf-yang-types here does not.

Tom Petch
________________________________________
From: I-D-Announce <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: 12 March 2021 01:21
To: [email-masked]
Cc: [email-masked]
Subject: I-D Action: draft-ietf-babel-information-model-14.txt

Abstract:

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 16 Mar 2021 19:40:52 +0000

Hi Tom,

> Barbara
> 
> I was looking at babel-yang-model and realised that it was impossible to
> understand without a comprehensive understanding of babel-information-model
> so the latter is clearly a Normative Reference.  Except, of course, that the latter
> has been put forward as Informational which is perhaps why the YANG I-D lists
> the latter as an Informational Reference but I cannot see that approach going
> anywhere ie it immediately becomes a downref:-(
> 
> In passing, imports of IETF modules must use the prefix specified in the RFC
> which the import of ietf-yang-types here does not.
> 
> Tom Petch

You ask a very interesting question. I don't recall having that conversation in the WG (but it might have slipped my mind). I see from the charter that the deliverable was slated for Proposed Standard. The draft has gone through the complete WG process and (I think) has the full support of the WG -- so I don't *think* the WG would object to the information model as a Proposed Standard. I wouldn't object. I don't know if people in IETF or IESG would object. Thanks for asking?
Barbara

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 16 Mar 2021 20:41:31 -0700

Hi Tom,

> On Mar 16, 2021, at 4:41 AM, tom petch <[email-masked]> wrote:
> 

I understand that for readability reasons, the prefix defined in the imported module should be used. But it is not wrong to define a different prefix, and no tool will flag it if you choose a different prefix. In any case, the “prefix” statement has a local scope, and is used for accessing definitions inside the imported module, and has no impact on the imported module.

Cheers.

Mahesh Jethanandani
[email-masked]

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 17 Mar 2021 00:00:19 -0400

Hi Barbara,

It looks to me like it is just the milestone that says Proposed Standard
for the Information Model. Procedurally, Since the Information Model is
through the process and could just go to the RFC Editor, changing it from
Informational to Proposed Standard would be somewhat painful. On the other
hand, just re-running a brief WG Last Call for the YANG Model after making
the information Model reference normative, if that's really necessary, with
notice of the downref, would be relatively easy.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

On Tue, Mar 16, 2021 at 3:41 PM STARK, BARBARA H <[email-masked]> wrote:

> You ask a very interesting question. I don't recall having that
> conversation in the WG (but it might have slipped my mind). I see from the
> charter that the deliverable was slated for Proposed Standard. The draft
> has gone through the complete WG process and (I think) has the full support
> of the WG -- so I don't *think* the WG would object to the information
> model as a Proposed Standard. I wouldn't object. I don't know if people in
> IETF or IESG would object. Thanks for asking?
> Barbara
>
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel
>

---

From: tom petch <[email-masked]>
Date: Wed, 17 Mar 2021 12:07:26 +0000

From: Mahesh Jethanandani <[email-masked]>
Sent: 17 March 2021 03:41

Hi Tom,

On Mar 16, 2021, at 4:41 AM, tom petch <[email-masked]<mailto:[email-masked]>> wrote:

<tp>
RFC8407
  o  The proper module prefix MUST be used for all identifiers imported
      from other modules.

I thought that it said for IETF modules but no, it is all imports that must use the proper module prefux.

Tom Petch

Cheers.

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 17 Mar 2021 12:39:37 +0000

That WFM! Thx,
Barbara

Hi Barbara,

It looks to me like it is just the milestone that says Proposed Standard for the Information Model. Procedurally, Since the Information Model is through the process and could just go to the RFC Editor, changing it from Informational to Proposed Standard would be somewhat painful. On the other hand, just re-running a brief WG Last Call for the YANG Model after making the information Model reference normative, if that's really necessary, with notice of the downref, would be relatively easy.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]<mailto:[email-masked]>

On Tue, Mar 16, 2021 at 3:41 PM STARK, BARBARA H <[email-masked]<mailto:[email-masked]>> wrote:
Hi Tom,

_______________________________________________
babel mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/babel<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/babel__;!!BhdT!zDBXacg4bsxSrifMSAKZMoEcEnH1Cyh9kTm0I6pfwVJwVt0QC2XA02xumdjEEA$>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 17 Mar 2021 11:43:00 -0700

Hi Tom,

What is the definition of “proper module” prefix?

RFC 7950 says

       "All prefixes, including the prefix for the module itself, MUST be
       unique within the module or submodule.

which is true with this module.

Thanks.

> On Mar 17, 2021, at 5:07 AM, tom petch <[email-masked]> wrote:
> 

Mahesh Jethanandani
[email-masked]