Subject: Re: [bcause] Fwd: I-D Action: draft-haleplidis-bcause-forces-gap-analysis-00.txt

From: "Miaofuyou (Miao Fuyou)" <[email-masked]>
Date: Wed, 8 May 2019 08:35:12 +0000

Thanks for writing the draft to explore the applicability of ForCES to BNG CU separation! 

BTW, the CUSP protocol draft is updated:
https://datatracker.ietf.org/doc/draft-cuspdt-rtgwg-cu-separation-bng-protocol/

> -----Original Message-----
> From: bcause [mailto:[email-masked]] On Behalf Of Jamal Hadi Salim
> Sent: Tuesday, April 30, 2019 6:39 PM
> To: [email-masked]
> Subject: [bcause] Fwd: I-D Action:
> draft-haleplidis-bcause-forces-gap-analysis-00.txt
> 
> As a result of side discussions at IETF 104.
> Comments welcome.
> 
> cheers,
> jamal
> ---------- Forwarded message ---------
> From: <[email-masked]>
> Date: Tue, Apr 30, 2019 at 6:33 AM
> Subject: I-D Action: draft-haleplidis-bcause-forces-gap-analysis-00.txt
> To: <[email-masked]>
> 
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : ForCES architecture CUSP applicability
>         Authors         : Evangelos Haleplidis
>                           Jamal Hadi Salim
>         Filename        :
> draft-haleplidis-bcause-forces-gap-analysis-00.txt
>         Pages           : 40
>         Date            : 2019-04-30
> 
> Abstract:
>    This document provides a gap-analysis on how the ForCES architecture
>    meets the requirements for CUSP.  In addition it provides a ForCES
>    XML model that implements the current proposed CUSP information
>    model.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-haleplidis-bcause-forces-gap-analysis/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-haleplidis-bcause-forces-gap-analysis-00
> https://datatracker.ietf.org/doc/html/draft-haleplidis-bcause-forces-gap-analys
> is-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> --
> bcause mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bcause

---

From: Jamal Hadi Salim <[email-masked]>
Date: Wed, 8 May 2019 10:54:03 -0400

> https://datatracker.ietf.org/doc/draft-cuspdt-rtgwg-cu-separation-bng-protocol/

Note, our draft is strictly on CUSP-s. We didnt try to explore the full coverage
of BNG because we assume that things like management are as your draft
shows are netconf domain etc.

We did look at your draft and made two observations:

1) In ours we used the info model draft for the data model. It seems
you have more
details than what is provided in the info model.
Where is you CUSP-s abstraction for the control coming from? Maybe the
info model
is outdated?
We are thinking of publishing a new version of ours which covers all the details
you are considering in your document - but it would be easier if there was a
document which separately captured the abstraction (the info model was a
good fit).

2) Everything in the CUSP-s you have can be covered under ForCES.

cheers,
jamal

---

From: "Miaofuyou (Miao Fuyou)" <[email-masked]>
Date: Thu, 9 May 2019 01:44:40 +0000

There are 3 interfaces: service, control and management for CU separation. As you pointed out, the management interface is on netconf domain. The service interface is tunnel. Control interface is the one for major consideration, that is SCUSP protocol. I believe your intention for ForCES is also control interface. Draft-*-yang-model is helpful to understand the interfaces, while you may refer SCUSP protocol for latest details, including various message and TLS/sub-TLV. 

The CUSP work is on-going work, it's not possible to get all drafts updated in complete sync. But, the SCUSP protocols is latest one for reference. 

> From: Jamal Hadi Salim [mailto:[email-masked]]
> Sent: Wednesday, May 08, 2019 10:54 PM
> To: Miaofuyou (Miao Fuyou) <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [bcause] Fwd: I-D Action:
> Note, our draft is strictly on CUSP-s. We didnt try to explore the full coverage of
> BNG because we assume that things like management are as your draft shows
> are netconf domain etc.
> 
> 1) In ours we used the info model draft for the data model. It seems you have
> more details than what is provided in the info model.
> Where is you CUSP-s abstraction for the control coming from? Maybe the info
> model is outdated?
> > > Subject: I-D Action:
> > > Please note that it may take a couple of minutes from the time of
> > > submission until the htmlized version and diff are available at tools.ietf.org.
> > >

---

From: Jamal Hadi Salim <[email-masked]>
Date: Fri, 10 May 2019 11:27:00 -0400

> There are 3 interfaces: service, control and management for CU separation. As you pointed out, the management interface is on netconf domain. The service interface is tunnel. Control interface is t…

Assuming yang draft is for management, no?
The info draft is what SCUSP needs to deal with.

> The CUSP work is on-going work, it's not possible to get all drafts updated in complete sync. But, the SCUSP protocols is latest one for reference.

IMO, at minimal the protocol for SCUSP needs to conform to the
informational draft. i.e update
both at the same time.
Which btw is the _main_ difference with ForCES. We never have to keep
updating the
ForCES protocol. We update the data model.

cheers,
jamal

---

From: "Miaofuyou (Miao Fuyou)" <[email-masked]>
Date: Mon, 13 May 2019 02:01:10 +0000

> The info draft is what SCUSP needs to deal with.

Correct.

> Sent: Friday, May 10, 2019 11:27 PM
> > There are 3 interfaces: service, control and management for CU separation.
> As you pointed out, the management interface is on netconf domain. The
> service interface is tunnel. Control interface is the one for major consideration,
> that is SCUSP protocol. I believe your intention for ForCES is also control
> interface. Draft-*-yang-model is helpful to understand the interfaces, while you
> may refer SCUSP protocol for latest details, including various message and
> TLS/sub-TLV.
> >
> 
> > The CUSP work is on-going work, it's not possible to get all drafts updated in
> complete sync. But, the SCUSP protocols is latest one for reference.
> 
> IMO, at minimal the protocol for SCUSP needs to conform to the informational
> draft. i.e update both at the same time.
> updating the ForCES protocol. We update the data model.
> 
> cheers,
> jamal