Subject: RE: [BXXPwg] SOAP over BEEP

From: Bill Mills <[email-masked]>
Date: Fri, 15 Jun 2001 16:12:02 -0700

I do not then see how the dotted notation proposed in one of the earlier
messages on this thread is any better.  If I read 2396 right the scheme name
is parsed complete, and would not itself be tokenized.  I think using
beep.<proto>:<specifier> still implies a combinatorial explosion of schemes
on the left had side?  

It would seem cleaner then to leave the protocol to be looked up with an SRV
lookup i.e.

	beep://_beep._sctp.xml.resource.org/

Is this more palatable?

-----Original Message-----
From: Eamon O'Tuathail [mailto:[email-masked]]
Sent: Friday, June 15, 2001 2:27 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [BXXPwg] SOAP over BEEP

>> The vector that I thought needed to be dealt with is the underlying
>> transport mapping.  Let's leave it at TCP and SCTP and ignore SSL for
>> now then.  The question stands.

If we are only ever going to have two transport mappings, I would agree,
but what happens when (not if) we have twenty transport mappings (over the
next
ten years). RFC 3080 is careful to separate out the transport mapping from
the BEEP core, we really need to follow this good practice with the URI.

_______________________________________________
BXXPwg mailing list
[email-masked]
http://lists.invisible.net/mailman/listinfo/bxxpwg

---

From: Chris Hanson <[email-masked]>
Date: Sun, 17 Jun 2001 13:56:12 -0500

>	beep://_beep._sctp.xml.resource.org/

I for one don't want to see SRV lookups relied upon too heavily. 
There are quite a few people who will be able to deploy BEEP services 
on servers they control within DNS spaces they *don't*.  One of the 
great things about the web is that in the common case setting up a 
web server doesn't require involvement from unreliable third parties 
(in this case, site administrators).

   -- Chris

-- 
Chris Hanson <[email-masked]>
bDistributed.com: Making Business Distributed