Subject: [BXXPwg] BEEP Binding for JXTA

From: "Krishna Sankar" <[email-masked]>
Date: Sat, 23 Jun 2001 12:48:02 -0700

Hi all,

	Jeffrey Altman from jxta referred me to this list. I would like to see if
we can quickly form a virtual group to develop a JXTA BEEP binding. I am
sure you all have a lot of ideas how this can be achieved and so we should
be able to get to a strawperson version pretty quickly.

cheers and have a nice weekend

	Jeffrey, would this be under the platform group's umbrella ? I am not sure
where this would fit in as a few new groups are being formed.

-----Original Message-----
From: Jeffrey Altman [mailto:[email-masked]]
Sent: Saturday, June 23, 2001 8:43 AM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [JXTA dev] Beep Bad? XTalk good?

> Hi all,
>
> 	I also support the use of a protocol above TCP and BEEP is an excellent
> solution. We should be concentrating on the jxta layer providing better
and
> better P2P abstractions. IMHO, we leave it to others to solve the
transport
> problems and leverage their work. For now, BEEP looks like the best fit.
> Actually I am working on a *very* preliminary prototype binding BEEP.
>
> 	my 2c
>
> cheers
>

This is great.  You may very well want to communicate with the BEEP
working group.  There were some members who expressed interest in
working on a JXTA BEEP binding.  The BEEP mailing list is

  [email-masked]

 Jeffrey Altman * Sr.Software Designer      C-Kermit 7.1 Alpha available
 The Kermit Project @ Columbia University   includes Secure Telnet and FTP
 http://www.kermit-project.org/             using Kerberos, SRP, and
 [email-masked]          OpenSSL.  SSH soon to follow.

---------------------------------------------------------------------
To unsubscribe, e-mail: [email-masked]
For additional commands, e-mail: [email-masked]

_______________________________________________
BXXPwg mailing list
[email-masked]
http://lists.invisible.net/mailman/listinfo/bxxpwg

---

From: Jeffrey Altman <[email-masked]>
Date: Mon, 25 Jun 2001 15:59:54 EDT

APEX is a set of services (presence, access control, message
relaying).  There is no reason why those services cannot be
implemented within JXTA peer groups.  BEEP is just a transport layer
which is used by the relays to send APEX messages.  There is no reason
why those messages could not be sent using JXTA.  Its just a question
of redefining the underlying protocol.

- Jeff

> APEX cannot run over JXTA - APEX is defined only over BEEP.
> 
> I believe APEX provides the underlying messaging service that JXTA relies
> upon - I believe (with admittedly limited experience with JXTA) that there
> is an interesting, if not natural, role for APEX as a transport for JXTA
> messages.
> 
> I also do not agree with the assertion that "JXTA being more
> distributed"..
> 
> But, lets definitely dig into this and get a better understanding from
> both sides of the fence so we can come up with a good answer.
> 
> 	-Gabe
> 
> On Mon, 25 Jun 2001, Jeffrey Altman wrote:
> 
> > The APEX relay mesh network can be implemented on top of JXTA as a set
> > of peergroup services.  JXTA and APEX serve two different worlds with
> > JXTA being more distributed.  However, there is no reason why JXTA and
> > APEX networks cannot communicate with one another.
> >
> > - Jeff
> >
> > > Good thought. I was not aware of APEX. Thanks for the pointer. I do not know
> > > whether if anyone in the group has looked into APEX. We will definitely look
> > > into APEX. In the meantime, would appreciate your comments, ideas, ...
> > >
> > > cheers
> > >
> > > |-----Original Message-----
> > > |From: [email-masked]
> > > |[mailto:[email-masked]]On Behalf Of Eamon
> > > |O'Tuathail
> > > |Sent: Sunday, June 24, 2001 3:05 PM
> > > |To: [email-masked]
> > > |Cc: [email-masked]
> > > |Subject: [BXXPwg] BEEP Binding for JXTA
> > > |
> > > |
> > > |>> I would like to see if we can quickly form a virtual
> > > |>> group to develop a JXTA BEEP binding.
> > > |
> > > |Is there any reason why you would not consider using IETF APEX (which is
> > > |based on BEEP) as the basis for peer-to-peer services, such as JXTA?
> > > |
> > > |http://www.ietf.org/html.charters/apex-charter.html
> > > |
> > > |Eamon
> > > |
> > > |
> > > |_______________________________________________
> > > |BXXPwg mailing list
> > > [email-masked]
> > > |http://lists.invisible.net/mailman/listinfo/bxxpwg
> > >
> > >