Subject: RE: [BXXPwg] BEEP Binding for JXTA

From: Jeffrey Altman <[email-masked]>
Date: Mon, 25 Jun 2001 8:06:04 EDT

The APEX relay mesh network can be implemented on top of JXTA as a set
of peergroup services.  JXTA and APEX serve two different worlds with
JXTA being more distributed.  However, there is no reason why JXTA and
APEX networks cannot communicate with one another.

- Jeff

> Good thought. I was not aware of APEX. Thanks for the pointer. I do not know
> whether if anyone in the group has looked into APEX. We will definitely look
> into APEX. In the meantime, would appreciate your comments, ideas, ...
> 
> cheers
> 
> |-----Original Message-----
> |From: [email-masked]
> |[mailto:[email-masked]]On Behalf Of Eamon
> |O'Tuathail
> |Sent: Sunday, June 24, 2001 3:05 PM
> |To: [email-masked]
> |Cc: [email-masked]
> |Subject: [BXXPwg] BEEP Binding for JXTA
> |
> |
> |>> I would like to see if we can quickly form a virtual
> |>> group to develop a JXTA BEEP binding.
> |
> |Is there any reason why you would not consider using IETF APEX (which is
> |based on BEEP) as the basis for peer-to-peer services, such as JXTA?
> |
> |http://www.ietf.org/html.charters/apex-charter.html
> |
> |Eamon
> |
> |
> |_______________________________________________
> |BXXPwg mailing list
> [email-masked]
> |http://lists.invisible.net/mailman/listinfo/bxxpwg
> 
> 
> _______________________________________________
> BXXPwg mailing list
> [email-masked]
> http://lists.invisible.net/mailman/listinfo/bxxpwg
> 

 Jeffrey Altman * Sr.Software Designer      C-Kermit 7.1 Alpha available
 The Kermit Project @ Columbia University   includes Secure Telnet and FTP
 http://www.kermit-project.org/             using Kerberos, SRP, and 
 [email-masked]          OpenSSL.  SSH soon to follow.

_______________________________________________
BXXPwg mailing list
[email-masked]
http://lists.invisible.net/mailman/listinfo/bxxpwg

---

From: Gabe Wachob <[email-masked]>
Date: Mon, 25 Jun 2001 11:59:06 -0700 (PDT)

APEX cannot run over JXTA - APEX is defined only over BEEP.

I believe APEX provides the underlying messaging service that JXTA relies
upon - I believe (with admittedly limited experience with JXTA) that there
is an interesting, if not natural, role for APEX as a transport for JXTA
messages.

I also do not agree with the assertion that "JXTA being more
distributed"..

But, lets definitely dig into this and get a better understanding from
both sides of the fence so we can come up with a good answer.

	-Gabe