Subject: [BEEPwg] Vortex/BEEP peer to peer protocol

From: "Jacky Luk" <[email-masked]>
Date: Thu, 09 Feb 2006 06:03:59 +0000

Hi,
I need to implement a peer-to-peer wireless connection protocol, that is big 
request, big response. Any side can act as client and server and the data is 
full-duplex.
I've got the book BEEP The definitive Guild from Marshall T. Rose
It introduces some concepts on that, but did not supply code in C++
Code Snippet:
wl = new Wireless();
wl->vortex_act_as_server();
wl->vortex_act_as_client();

the server code was taken from vortex-omr-server.c
and the client code was taken from vortex-simple-client.c

The problem is I use listener wait for the server so the code 
vortex_act_as_client never gets invoked....
Is there anywhere I can look?
Thanks
Jack

_________________________________________________________________
FREE 'A WORD A DAY' - learn English easily! 
http://www.linguaphonenet.com/BannerTrack.asp?EMSCode=MSN06-02ETFJ-0211E

_______________________________________________
BEEPwg mailing list
[email-masked]
http://drakken.dbc.mtview.ca.us/mailman/listinfo/beepwg

---

From: Francis Brosnan Blazquez <[email-masked]>
Date: Thu, 09 Feb 2006 11:12:07 +0100

> Is there anywhere I can look?

Being a Vortex specific issue, and to those interested, this messages is
being replied at [1].

	-Francis

[1]
http://lists.aspl.es/pipermail/aspl-fact-users/2006-February/000040.html

-- 
Francis Brosnan Blazquez <[email-masked]>
Advanced Software Production Line, S.L.