Subject: [beepwg] C++ lib

From: Ye Deng <[email-masked]>
Date: Wed, 21 Jan 2009 21:45:26 -0500

Hello all,

I am looking for a C++ beep lib to implement some simple protocol (may use XML for protocol data structure).

The protocol I am going to implement need to run over secure channel (SSL/TSL).
But, I dont want the beep lib to take care of the secure lager, since I have the SSL/TSL infrastructure already.

I want the beep lib to do the jobs only related to application layer protocol implementing. (e.g. framing)

Is there an appropriate C++ beep lib for me?

Deng

---

From: Francis Brosnan Blazquez <[email-masked]>
Date: Thu, 22 Jan 2009 09:32:39 +0100

Hi Ye,

> But, I dont want the beep lib to take care of the secure lager, since
> I have the SSL/TSL infrastructure already.

Ok.

> Is there an appropriate C++ beep lib for me?

You have Vortex, which is implemented in C, but it is being used by C++
users [1]. 

Cheers!

[1] http://www.aspl.es/vortex

-- 
Francis Brosnan Blazquez <[email-masked]>
Advanced Software Production Line, S.L.