Subject: [Ietf-behave] Maximum number of binding

From: [email-masked]
Date: Fri, 19 Nov 2004 13:59:02 -0800 (PST)

I like how 'behave-nat-00' classifies different behaviors of NAT.  The 
common term definitions also make my life easier, indeed. Nice job!

One thing I thought... It would be nice to include a requirement on:

- Minimum number of bindings per NAT.

Especially, NB=AD and NB=APD  consume more memory resource in NAT. The 
requirement may have to have:

- Minimum number of connections (destinations) per binding.

I can see that developers especially who are working on residential 
gateways, or routers are trying minimize its
memory requirement to bring down hardware cost as low as possible to win 
the race. Does anyone have any idea or thoughts on above parameters in 
existing NATs?

Thanks,
Yutaka

---

From: "Francois Audet" <[email-masked]>
Date: Mon, 29 Nov 2004 10:43:57 -0800 (PST)

I have similar concerns.

We may be starting to overspecify.

> -----Original Message-----
> From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
> [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of 
> Spencer Dawkins
> Sent: Thursday, November 25, 2004 20:52
> To: ietf-behave@xxxxxxxxxxxxxxxxxxx
> Subject: Re: [Ietf-behave] Maximum number of binding
> 
> 
> I understand that we're trolling the depths of aberrent 
> behavior here, 
> but has anyone seen a NAT that cannot allocate a UDP source port (due 
> to a large number of bindings leading to port exhaustion, as 
> previously described) and still transmits the packet on the public 
> side of the NAT?
> 
> >>>     o it is strongly RECOMMENDED that the NAT send an ICMP message
> >>> type=3,
> >>>       code=0 ("net unreachable") in response to the UDP packet, 
> >>> and;
> >>>
> >>>     o Alternatively, but less preferred, the NAT SHOULD simply
> >>> drop the
> >>>       UDP packet and not transmit it on the public side of the 
> >>> NAT.
> >>
> >> Shouldn't this be a MUST?
> >
> > Sure, how about rewording that last bullet to:
> >
> >   o If the NAT doesn't send the above-described ICMP message, the
> > NAT
> >     MUST drop the UDP packet and not transmit it on the public side 
> > of
> >     the NAT.
> 
> I'm just trying to understand how precise we need to be in describing 
> MUST NOT behavior.
> 
> Thanks,
> 
> Spencer 
> 
> 
> _______________________________________________
> Ietf-behave mailing list
> Ietf-behave@xxxxxxxxxxxxxxxxxxx 
> https://list.sipfoundry.org/mailman/listinfo/ietf-behave
> 
>