Subject: RE: [Ietf-behave] port-type preservation?

From: "Francois Audet" <[email-masked]>
Date: Thu, 30 Sep 2004 11:18:44 -0700 (PDT)

Can you explain the downside of always using the dynamic range for
outgoing port binding?

> -----Original Message-----
> From: Dan Wing [mailto:dwing@xxxxxxxxx] 
> Sent: Thursday, September 30, 2004 11:14
> To: Jonathan Rosenberg; Audet, Francois [SC100:9T51:EXCH]
> Cc: ietf-behave@xxxxxxxxxxxxxxxxxxx
> Subject: RE: [Ietf-behave] port-type preservation?
> 
> 
> This sounds like a good idea, and it's logical.
> 
> However, do we know of any IETF or non-IETF protocol that 
> breaks if you don't have a source UDP port within the 
> appropriate range?
> 
> I poked around DNS and TFTP and neither care about the source 
> UDP port number for their operation.  NFSv2 (RFC1831) has a 
> preference for the connections to come from privileged ports, 
> but with everyone having privileges on their own computer 
> now-a-days I think NFS's preference is historic.
> 
> Without an application that breaks, the best I think we 
> should say is a strongly-worded "MAY", like this strawman text:
> 
>   When deciding the source UDP port for an outgoing binding a NAT
>   MAY choose a source port that is in the same IANA range (well
>   known, registered, or dynamic) as the original source UDP port.
>   However, as most modern applications to not utilize source port
>   numbers as an indicator of trust, there is little value in a NAT
>   to provide this function.
> 
> -d
> 
> 
> > -----Original Message-----
> > From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx
> > [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx]On Behalf 
> Of Jonathan 
> > Rosenberg
> > Sent: Thursday, September 30, 2004 7:52 AM
> > To: Francois Audet
> > Cc: 'ietf-behave@xxxxxxxxxxxxxxxxxxx'
> > Subject: Re: [Ietf-behave] port-type preservation?
> >
> >
> > Almost.
> >
> > What I'm saying is, if the source port on the private side 
> is in the 
> > dynamic range, the source port on the public side should 
> probably be 
> > in that range. If the source port is in the registered 
> range, so too 
> > should the source port on the public side, and same for the 
> well-known 
> > range.
> >
> > -Jonathan R.
> >
> > Francois Audet wrote:
> >
> > > So, if I understand correctly, you want us to put in the Behave 
> > > document something saying that port binding assignments are to be 
> > > done from the dynamic/private port range 49152-65535?
> > >
> > > Right?
> > >
> > >  > -----Original Message-----
> > >  > From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx
> > >  > [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On 
> Behalf Of  > 
> > > Jonathan Rosenberg  > Sent: Tuesday, September 28, 2004 23:16
> > >  > To: 'ietf-behave@xxxxxxxxxxxxxxxxxxx'
> > >  > Subject: [Ietf-behave] port-type preservation?
> > >  >
> > >  >
> > >  > Folks,
> > >  >
> > >  > An interesting thread has been going on on the mmusic 
> list, which is
> > >  > relevant to behave. The discussion was around NAT 
> preservation of
> > >  > port-types, where the types are (for UDP) "well-known" from 0
> > >  > to 1023,
> > >  > "registered" from 1024 to 49151, and "dynamic/private" 
> from 49152
> > >  > through 65535. See:
> > >  >
> > > http://www.ietf.org/mail-archive/web/mmusic/current/msg02902.html
> > >
> > > If a NAT sees an outbound packet with one of these types, does it 
> > > attempt to maintain the preservation? That is, should an outbound 
> > > packet within the dynamic range always map to a port in 
> the dynamic 
> > > range?
> > >
> > > I think the behave draft should probably say something 
> about this. I 
> > > suspect its probably a good idea to preserve the port-type.
> > >
> > > -Jonathan R.
> > > --
> > > Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> > > Chief Technology Officer                    Parsippany, 
> NJ 07054-2711
> > > dynamicsoft
> > > jdrosen@xxxxxxxxxxxxxxx                     FAX:   (973) 952-5050
> > > http://www.jdrosen.net                      PHONE: (973) 952-5000
> > > http://www.dynamicsoft.com
> > >
> > > _______________________________________________
> > > Ietf-behave mailing list
> > > Ietf-behave@xxxxxxxxxxxxxxxxxxx 
> > > https://list.sipfoundry.org/mailman/listinfo/ietf-behave
> > >
> >
> > --
> > Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> > Chief Technology Officer                    Parsippany, NJ 
> 07054-2711
> > dynamicsoft
> > jdrosen@xxxxxxxxxxxxxxx                     FAX:   (973) 952-5050
> > http://www.jdrosen.net                      PHONE: (973) 952-5000
> > http://www.dynamicsoft.com 
> > _______________________________________________
> > Ietf-behave mailing list
> > Ietf-behave@xxxxxxxxxxxxxxxxxxx 
> > https://list.sipfoundry.org/mailman/listinfo/ietf-behave
> 
> 
>

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 30 Sep 2004 11:58:17 -0700 (PDT)

Unless we can find a modern UDP-based application that cares about
preserving the range, I don't see a downside.

-d

-----Original Message-----
From: Francois Audet [mailto:audet@xxxxxxxxxxxxxxxxxx]
Sent: Thursday, September 30, 2004 11:17 AM
To: 'Dan Wing'; 'Jonathan Rosenberg'
Cc: 'ietf-behave@xxxxxxxxxxxxxxxxxxx'
Subject: RE: [Ietf-behave] port-type preservation?

> > >  > [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On
> Behalf Of  >
> > >  > To: 'ietf-behave@xxxxxxxxxxxxxxxxxxx'
> > >  > Subject: [Ietf-behave] port-type preservation?
> > >  >
> > >  >
> > >  > Folks,
> > >  >
> > >  > An interesting thread has been going on on the mmusic
> list, which is
> > >  > relevant to behave. The discussion was around NAT
> preservation of
> > >  > port-types, where the types are (for UDP) "well-known" from 0
> > >  > to 1023,
> > >  > "registered" from 1024 to 49151, and "dynamic/private"
> from 49152
> > >  > through 65535. See:
> > >  >