Subject: RE: [Ietf-behave] NAT Mapping refresh vs NAT filter refresh

From: "Francois Audet" <[email-masked]>
Date: Wed, 13 Jul 2005 15:20:26 -0700 (PDT)

Mapping and Binding do NO mean the same thing.

It was decided a while ago to use the term mapping because it
applies to both "symmetric" and "cone" NATs, which is not
the case for binding.

It was felt that the word binding (as described in behave-gen) and
other documents was not appropriate for the purpose of this
document

Furthermore, the classification using the terminoly of "binding"
did not reflect the full range of NATs that we experimentaly tested
and therefore was not suitable for this document.

> -----Original Message-----
> From: Saikat Guha [mailto:saikat@xxxxxxxxxxxxxx] 
> Sent: Wednesday, July 13, 2005 15:16
> To: Pyda Srisuresh
> Cc: Audet, Francois [SC100:9T51:EXCH]; Behave
> Subject: RE: [Ietf-behave] NAT Mapping refresh vs NAT filter refresh
> 
> 
> Thanks to suresh's pointer on the definitions, I think I 
> understand "bindings" now. Correct me if I am wrong; I 
> believe "Bindings" (draft-
> ford-behave-gen-01.txt) mean more or less the same as 
> "Mapping" (per draft-ietf-behave-nat-udp-02.txt). They are 
> both something that is created dynamically at the NAT in 
> response to the first outbound packet from a particular 
> internal address and port. "Mapping" (as per draft-
> ford-behave-gen-01.txt) is a static administrator-configured 
> entry, usually from a port-forwarding or internal-service 
> screen in many NAT interfaces. 
> draft-ietf-behave-nat-udp-02.txt does not mention anything 
> about these static entries.
> 
> On Fri, 2005-07-08 at 07:02 -0700, Pyda Srisuresh wrote: 
> > 3. Lastly, the document is missing a key requirement on Bindings. A 
> > dynamically created Binding (Address and/or Port Binding) MUST be 
> > refreshed, when there is is at least one live NAT Session using the 
> > Binding.
> 
> I believe this is what REQ-5 addresses (but uses the term 
> "mapping" as defined earlier instead of "binding" ... but has 
> the same meaning). 
> 
> 
> > Alternately, once a Binding
> > is created in relation to an endpoint and a NAT Session, subsequent 
> > NAT Sessions associated with the endpoint MUST reuse the 
> same Binding.
> 
> I believe this is what REQ-1 addresses. It says that the 
> dynamically created mapping/binding/whatever must be reused 
> for new sessions originating from the same internal endpoint.
> 
> -- 
> Saikat
>

---

From: Saikat Guha <[email-masked]>
Date: Wed, 13 Jul 2005 15:30:32 -0700 (PDT)

> applies to both "symmetric" and "cone" NATs, which is not

True enough ... in that the term "mapping" has a defined value
(I=independent,A=address,P=port,ADP=address and port) for any kind of
NAT while "implements binding" is equivalent to NB=I only and all of
the rest NB=A,NB=P,NB=ADP fall under "inconsistent binding" or "does not
implement binding" etc. So yes, the two are not interchangable without
loss in fidelity ... but they both refer to the dynamic behavior of NATs
in allocating an external endpoint to an internal endpoint.

-- 
Saikat
Attachment:
signature.asc