Subject: RE: [Ietf-behave] UDP binding timeouts

From: "Francois Audet" <[email-masked]>
Date: Wed, 15 Sep 2004 07:25:19 -0700 (PDT)

I think we can leave it to 2 minutes until we have reasons to
change it.

> -----Original Message-----
> From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
> [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of 
> Jonathan Rosenberg
> Sent: Tuesday, September 14, 2004 19:03
> To: Cullen Jennings
> Cc: Behave
> Subject: Re: [Ietf-behave] UDP binding timeouts
> 
> 
> I think the most important thing is that there is a deterministic 
> minimum that you can count on; the actual value is far less important.
> 
> In principal, you'd like to tie the timeout to typical 
> maximum activity 
> intervals for UDP-based applications. That is, normal outbound packet 
> activity for applications should keep the bindings active withot 
> requiring additional keepalives. For RTP, even a much smaller number 
> would typically suffice. For SIP over UDP, packet retransmits can be 
> spaced as large as 16s towards the tail end of the 
> transaction. If you 
> want the binding to be active for a transaction lifetime 
> without special 
> keepalives, you'd want a minimum of 20s or so.
> 
> It'd be interesting to look at other UDP based protocols and see what 
> timeouts would be appropriate. Of course, who knows what future apps 
> would do. Again, the key thing is really determinism.
> 
> -Jonathan R.
> 
> Cullen Jennings wrote:
> 
> > Medhavi raises a good point, how long should the binding 
> times be and 
> > more importantly, any particular reason why?
> > 
> > Lacking any other good reason, we will likely pick times that are 
> > consistent with what devices do today only because these somewhat 
> > match what customers seem comfortable with.
> > 
> > 
> > On 8/10/04 7:53 AM, "Medhavi Bhatia" <mbhatia@xxxxxxxxxxx> wrote:
> > 
> > 
> >>Some comments/questions:
> >> 
> >>1. REQ-3 comes up with a min-timeout of 2 minutes for UDP dynamic 
> >>bindings. Is there data somewhere on the internet which can 
> back this 
> >>up ?
> > 
> > .. snip...
> > 
> >>Medhavi Bhatia
> >>Chief Architect
> >> 
> >>NexTone Communications
> >>****Pioneering Global Communications with Excellence, Integrity and 
> >>Flawless
> >>Execution****
> >> 
> > 
> > 
> > 
> > _______________________________________________
> > Ietf-behave mailing list
> > Ietf-behave@xxxxxxxxxxxxxxxxxxx 
> > https://list.sipfoundry.org/mailman/listinfo/ietf-behave
> > 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> jdrosen@xxxxxxxxxxxxxxx                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com 
> _______________________________________________
> Ietf-behave mailing list
> Ietf-behave@xxxxxxxxxxxxxxxxxxx 
> https://list.sipfoundry.org/mailman/listinfo/i> etf-behave
> 
>

---

From: "Francois Audet" <[email-masked]>
Date: Thu, 16 Sep 2004 11:42:51 -0700 (PDT)

> I'm sorry, are you saying that we have different views that 
> keepalive messages can be dropped between the application and the 
> NAT (which is the excerpt from my email you quoted above), or 
> that we have different views on the minimum duration of a UDP 
> binding that BEHAVE should require?

Different views on the minimum duration of a UDP binding BEHAVE should
require.

> I'm happy with requiring a 2 minute timeout and I agree a 30 
> second timeout is too aggressive.

OK: so we don't have different views after all :-)

So I'll leave it at 2 minutes.