Subject: [Ietf-behave] RE: UPD and Multicast scope

From: "Francois Audet" <[email-masked]>
Date: Mon, 23 Aug 2004 11:30:08 -0700 (PDT)

<FONT 
size=2><FONT face=Arial 
color=#800000> 
<BLOCKQUOTE dir=ltr 
style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #800000 2px solid; MARGIN-RIGHT: 0px">
  <BLOCKQUOTE dir=ltr 
  style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #0000ff 2px solid; MARGIN-RIGHT: 0px">
    <FONT face=Verdana 
    color=#0000ff><FONT face=Arial 
    color=#800000>What worries me is (b). As an 
    example, I may hang up, and phone somebody else right away. If my 
    phone uses the same UDP port for every call (which many phones do), 
    then I could be receiving from two places simultaneously (the real new call, 
    and the other call that didn't hang up properly), with no good way for the 
    phone to figure out which one is the right one.<SPAN 
    class=894205217-23082004><FONT face=Verdana 
    color=#0000ff> 
  <SPAN 
  class=012262917-23082004><FONT face=Verdana color=#0000ff 
  size=2>So if you don't have a NAT at all, this 
  application would misbehave, right?  That is, following the scenario 
  above and without a NAT anywhere you would hear the previous call's 
  audio.
<FONT 
face=Arial color=#800000 size=2><SPAN 
class=518552418-23082004>I see your point. I'm taking the view that people buy 
NATs not just for NATing, but also for some protection. This is perhaps outside 
of the charter of BEHAVE. I'm not sure.
<FONT 
face=Arial color=#800000 size=2><SPAN 
class=518552418-23082004>Cullen? Jiri?
<BLOCKQUOTE dir=ltr 
style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #800000 2px solid; MARGIN-RIGHT: 0px">
  <BLOCKQUOTE dir=ltr 
  style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #0000ff 2px solid; MARGIN-RIGHT: 0px"><SPAN 
    class=125411817-23082004><SPAN 
    class=012262917-23082004>I still think that we should put 
    something in BEHAVE that encourage NAT vendors to minimize the chances of 
    ports being kept opened from the outside.<SPAN 
    class=894205217-23082004><FONT face=Verdana 
    color=#0000ff> 
  <SPAN 
  class=012262917-23082004><FONT 
  face=Verdana color=#0000ff>I agree.  Let's continue evolving strawman 
  text.
<FONT 
face=Arial color=#800000 size=2><SPAN 
class=518552418-23082004>Yes, I think your current strawman is a good 
start.

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 23 Aug 2004 11:47:39 -0700 (PDT)

<BLOCKQUOTE dir=ltr 
style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #0000ff 2px solid; MARGIN-RIGHT: 0px">
  <FONT face=Tahoma 
  size=2>-----Original Message-----From: Francois Audet 
  [mailto:audet@xxxxxxxxxxxxxxxxxx]Sent: Monday, August 23, 2004 
  11:29 AMTo: 'Dan Wing'; 'Cullen Jennings'; 'Behave'; 'Jiri 
  Kuthan'Subject: RE: UPD and Multicast scope
  <FONT 
  size=2><FONT face=Arial 
  color=#800000> 
  <BLOCKQUOTE dir=ltr 
  style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #800000 2px solid; MARGIN-RIGHT: 0px">
    <BLOCKQUOTE dir=ltr 
    style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #0000ff 2px solid; MARGIN-RIGHT: 0px">
      <FONT face=Verdana 
      color=#0000ff><FONT face=Arial 
      color=#800000>What worries me is (b). As an 
      example, I may hang up, and phone somebody else right away. If 
      my phone uses the same UDP port for every call (which many 
      phones do), then I could be receiving from two places simultaneously 
      (the real new call, and the other call that didn't hang up properly), with 
      no good way for the phone to figure out which one is the right one.<SPAN 
      class=894205217-23082004><FONT face=Verdana 
      color=#0000ff> 
    <SPAN 
    class=012262917-23082004><FONT face=Verdana color=#0000ff 
    size=2>So if you don't have a NAT at all, 
    this application would misbehave, right?  That is, following the 
    scenario above and without a NAT anywhere you would hear the previous 
    call's audio.
  <FONT 
  face=Arial color=#800000 size=2><SPAN 
  class=518552418-23082004>I see your point. I'm taking the view that people buy 
  NATs not just for NATing, but also for some protection. <SPAN 
  class=785054418-23082004><FONT face=Verdana 
  color=#0000ff> 
<FONT 
face=Verdana color=#0000ff size=2><SPAN 
class=518552418-23082004>I agree folks buy NATs 
for this reason.  It's one of the reasons I personally have a NAT (the is 
to share one IP address).
<FONT 
face=Verdana color=#0000ff size=2><SPAN 
class=518552418-23082004>But if an application 
behaves as you describe, the user will continue to hear the previous 
conversation without a NAT.  I don't see how a NAT could, or should, 
prevent the described application 
behavior.
<FONT 
face=Verdana color=#0000ff size=2><SPAN 
class=518552418-23082004><SPAN 
class=785054418-23082004>-d
<FONT 
face=Verdana color=#0000ff size=2><SPAN 
class=518552418-23082004><SPAN 
class=785054418-23082004> 
<FONT 
face=Arial color=#800000 size=2><SPAN 
class=518552418-23082004><SPAN 
class=785054418-23082004> 
<BLOCKQUOTE dir=ltr 
style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #0000ff 2px solid; MARGIN-RIGHT: 0px">
  <FONT 
  face=Arial color=#800000 size=2><SPAN 
  class=518552418-23082004><SPAN 
  class=785054418-23082004> 
  <FONT 
  face=Arial color=#800000 size=2><SPAN 
  class=518552418-23082004> This is 
  perhaps outside of the charter of BEHAVE. I'm not 
  sure.
  <FONT 
  face=Arial color=#800000 size=2><SPAN 
  class=518552418-23082004>Cullen? Jiri?
  <BLOCKQUOTE dir=ltr 
  style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #800000 2px solid; MARGIN-RIGHT: 0px">
    <BLOCKQUOTE dir=ltr 
    style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #0000ff 2px solid; MARGIN-RIGHT: 0px"><SPAN 
      class=125411817-23082004><SPAN 
      class=012262917-23082004>I still think that we should put 
      something in BEHAVE that encourage NAT vendors to minimize the chances of 
      ports being kept opened from the outside.<SPAN 
      class=894205217-23082004><FONT face=Verdana 
      color=#0000ff> 
    <FONT face=Arial 
    color=#800000><SPAN 
    class=894205217-23082004>I agree.  
    Let's continue evolving strawman 
    text.
  <FONT 
  face=Arial color=#800000 size=2><SPAN 
  class=518552418-23082004>Yes, I think your current strawman is a good 
  start.