Subject: RE: [Ietf-behave] Comments on draft-ietf-behave-rfc3489bis-03

From: "Francois Audet" <[email-masked]>
Date: Mon, 20 Mar 2006 07:33:04 -0800 (PST)

An IPv4 address could be mapped to IPv6 perhaps?

> -----Original Message-----
> From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
> [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of 
> Aki Niemi
> Sent: Sunday, March 19, 2006 13:35
> To: ext Fredrik Thulin
> Cc: ietf-behave@xxxxxxxxxxxxxxxxxxx
> Subject: Re: [Ietf-behave] Comments on draft-ietf-behave-rfc3489bis-03
> 
> 
> 
> ext Fredrik Thulin wrote:
> >   11.15.  XOR-MAPPED-ADDRESS
> > 
> > The example results for IPv4 is really helpfull. I think it would be
> > very valuable to have such examples for IPv6 as well, to make sure 
> > everyone gets this right as well. By the way, I haven't 
> been able to 
> > find a IPv6 capable STUN client to try my server with, does 
> anyone know 
> > of one?
> 
> Hmm... Why would you need to get an IPv6 address in 
> MAPPED-ADDRESS anyway? This makes me feel very uneasy; is the 
> purpose to be able to traverse a NAT-PT that maps private 
> IPv4 to IPv6? That's not cool.
> 
> Cheers,
> Aki
> 
> _______________________________________________
> Ietf-behave mailing list
> Ietf-behave@xxxxxxxxxxxxxxxxxxx 
> https://list.sipfoundry.org/mailman/listinfo/ietf-behave
> 
>

---

From: Aki Niemi <[email-masked]>
Date: Mon, 20 Mar 2006 12:57:14 -0800 (PST)

> An IPv4 address could be mapped to IPv6 perhaps?

Can you walk me through how this works? In other words, what transition
scenario is this covering?

Cheers,
Aki