Subject: RE: [Ietf-behave] slashdot: p2p firewalled file transfers

From: "Thomas Gal" <[email-masked]>
Date: Wed, 24 Nov 2004 17:55:55 -0800 (PST)

Speaking of documents, I volunteered to work on a BEHAVE testing document
and code. Cullen did my email get nabbed by a spam filter? I think we had
talked about that stun paper that disappeared, and we might as well merge it
all.

-Tom

thomasgal@xxxxxxxxxxxx  

> -----Original Message-----
> From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
> [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of 
> Jon Ringle
> Sent: Wednesday, November 24, 2004 5:04 PM
> To: ietf-behave@xxxxxxxxxxxxxxxxxxx
> Subject: Re: [Ietf-behave] slashdot: p2p firewalled file transfers
> 
> On Wednesday 24 November 2004 06:19 pm, Dan Wing wrote:
> > On Nov 24, 2004, at 11:57 AM, Jon Ringle wrote:
> > > In regards to to p2p tcp behind NATs, are you familiar with the 
> > > NUTSS
> > > research:
> > >
> > > http://www.cs.cornell.edu/People/francis/ieee-nutss.pdf
> > > http://www.cs.cornell.edu/People/francis/nutss-fdna.pdf
> >
> > Yes, but I had forgotten about it.  Thanks for the pointer.
> >
> > > This uses an approach that uses a STUN extension and SIP. For a 
> > > "BEHAVE-compliant" NAT, the port prediction described is not 
> > > necessary, since the port prediction is meant to try to deal with 
> > > symmetric NATs.
> >
> > Remember that behave (draft-ietf-behave-nat) only defines UDP 
> > behavior, not TCP behavior.  At the meeting in DC, it was 
> agreed that 
> > the filename would be modified to clearly indicate that it 
> covers only UDP.
> >
> > TCP behavior would be described in another document.  
> However, to my 
> > knowledge, no one has stepped up to writing the TCP 
> behavior document.
> > It appears that for p2p TCP to work, we need such a document and we 
> > need testing, akin to Cullen's 
> draft-jennings-midcom-stun-results, to 
> > determine what TCP behavior exists for today's NATs.
> 
> You mean something like Saikat's work:
> http://list.sipfoundry.org/archive/ietf-behave/msg00215.html
> 
> Jon
> _______________________________________________
> Ietf-behave mailing list
> Ietf-behave@xxxxxxxxxxxxxxxxxxx
> https://list.sipfoundry.org/mailman/listinfo/ietf-behave
> 
Attachment:
smime.p7s

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 7 Dec 2004 16:42:08 -0800 (PST)

Hi Thomas, 

Thanks - I think I just lost token on this. I just sent out a list of people
that I know have been doing some work on various areas. There are a tone of
things that need to be done around testing - sync up with the folks thinking
about the parts you can help on.