Subject: [Ietf-behave] Status update Dec 7

From: Cullen Jennings <[email-masked]>
Date: Tue, 7 Dec 2004 16:42:24 -0800 (PST)

Below I have listed all the chunks of work and the people who have expressed
interested in writing drafts. I'm sure I missed some folks so let me know
can keep this stuff moving as quickly as possible.

-------- Defining NAT Behavior --------------------

* UDP Unicast Behavior - Goal May 05
  Good work moving forward
  Francois leading work
  Srisuresh helping merge parts from ford-midcom-p2p
  See draft-ietf-behave-nat-00

* UDP Multicast Behavior - Goal May 05
  Good work moving forward - Dan leading
  See draft-wing-behave-multicast-00

* TCP Behavior - Goal Sep 05
  Some thought starting in this area. Work from
  Nagendra Modadugu <nagendra@xxxxxxxxxxxxxxx>
  Bryan Ford <baford@xxxxxxx>
  Senthil Sivakumar <ssenthil@xxxxxxxxx>

* ICMP behavior - Goal Nov 05
  Is this goal a mistake, should this just be in other documents?

--------- Behavior Testing ----------------------

* Using STUN for testing UDP - Goal Mar 05
  Not much happening on this.
  Rohan might do some work on this - no ETA
  Would be good to get some other volunteers on this one. 
  
* Revisions to STUN - Goal Jul 05
  Jonathan has under control
  See draft-ietf-behave-rfc3489bis-00.txt

* TCP Testing
  Saikat Guha <sg266@xxxxxxxxxxx>
  Bryan Ford <baford@xxxxxxx>
  Lots of work done - need draft

-------- Application Design ----------------------

* UDP Design Techniques - Goal Dec 05
  Dan Wing
  Francois 
  Bryan Ford <baford@xxxxxxx>

* TCP Design Techniques - Goal Dec 05
  Bryan Ford <baford@xxxxxxx>
  Dan Wing
  Francois 

-------- Test Results -----------------------------

* UDP NAT Test Results - Goal TBD
  Nice to get ICMP results
  Nice to see change from Jan 04 to Jan 05
  Cullen has been doing some of this - I need help
  See draft-jennings-midcom-stun-results-02

* UDP Multicast Test Results

* TCP NAT Test Results
  Saikat Guha <sg266@xxxxxxxxxxx>
  Shiva <shaj@xxxxxxxxx>

* ICMP NAT Test Results

--------- Other -------------

Srisuresh is working on draft on "P2P state of the NAT world"

------- random links of interest ---------

http://www.ietf.org/html.charters/behave-charter.html
http://list.sipfoundry.org/archive/ietf-behave

http://www.cs.cornell.edu/People/francis/ieee-nutss.pdf
http://www.cs.cornell.edu/People/francis/nutss-fdna.pdf
http://www.cisco.com/en/US/about/ac123/ac147/archived_issues/ipj_7-3/anatomy
.html
http://bgp.lcs.mit.edu/~dga/view.cgi
http://www.cs.cornell.edu/~saikat/NATs.html
http://www.cs.cornell.edu/~saikat/NAT-results.htm
http://midcom-p2p.sourceforge.net/
http://sourceforge.net/projects/stun

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 7 Dec 2004 21:23:46 -0800 (PST)

I missed someone earlier - I should have added that Kaushik Biswas
<kbiswas@xxxxxxxxx> had also expressed that he may be able to help on the
TCP Behavior stuff. Sorry, Cullen