Subject: [Ietf-behave] STUN/TURN unified attribute list

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 6 Jul 2006 09:25:00 -0700 (PDT)

We seem to constantly have problems getting the attribute numbering 
across TURN, STUN and turn-v6 consistent, non-overlapping and complete. 
I have gone through the most recent revisions of each of the drafts 
along with the old rfc3489 and enumerated what I think is the complete 
set. If folks see any omissions or problems please advise:

stun-04   0x0001: MAPPED-ADDRESS
HISTORIC  0x0002: RESPONSE-ADDRESS
HISTORIC  0x0003: CHANGE-REQUEST
HISTORIC  0x0004: SOURCE-ADDRESS
HISTORIC  0x0005: CHANGED-ADDRESS
stun-04   0x0006: USERNAME
stun-04   0x0007: PASSWORD
stun-04   0x0008: MESSAGE-INTEGRITY
stun-04   0x0009: ERROR-CODE
stun-04   0x000a: UNKNOWN-ATTRIBUTES
HISTORIC  0x000b: REFLECTED-FROM
turn-01   0x000c: LIFETIME
turn-01   0x0010: BANDWIDTH
turn-01   0x0012: REMOTE-ADDRESS
turn-01   0x0013: DATA
stun-04   0x0014: REALM
stun-04   0x0015: NONCE
turn-01   0x0016: RELAY-ADDRESS
v4/v6-00  0x0017: REQUESTED-ADDRESS-TYPE
turn-01   0x0018: REQUESTED-PORT
turn-01   0x0019: REQUESTED-TRANSPORT
stun-04   0x0020: XOR-MAPPED-ADDRESS
turn-01   0x0021: TIMER-VAL
turn-01   0x0022: REQUESTED-IP
stun-04   0x0023: FINGERPRINT
stun-04   0x8022: SERVER
stun-04   0x8023: ALTERNATE-SERVER
stun-04   0x8024: REFRESH-INTERVAL
Thanks,
Jonathan R.
--
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
jdrosen@xxxxxxxxx                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 6 Jul 2006 09:48:10 -0700 (PDT)

Hi Jonathan,

Inline.

> turn-01   0x0012: REMOTE-ADDRESS

REALM was 0x0015 and NONCE 0x0014 in draft-rosenberg-midcom-turn-08.
There is existing deployments of turn-08, so perhaps it would be less
confusing to keep the same values.

Also for the same reasons, perhaps some historical attributes existing
only in turn-08 should be documented (DESTINATION-ADDRESS=0x0011,
MAGIC-COOKIE=0x000F, LIFETIME=0x000D, XOR-ONLY=0x0021)

-- 
Marc Petit-Huguenin
Home: marc@xxxxxxxxxxxxxxxxxx
Work: marc@xxxxxxx

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sat, 22 Jul 2006 06:03:23 -0700 (PDT)

> turn-01   0x0018: REQUESTED-PORT

The text and section 10.6 in turn-01 use REQUESTED-PORT-PROPS.