Subject: [Ietf-behave] Milestones, ICMP

From: "Dan Wing" <[email-masked]>
Date: Mon, 8 May 2006 17:04:58 -0700 (PDT)

I would like the list to consider having
draft-srisuresh-behave-nat-icmp-02.txt become a WG item.  

I expect its milestone would align with the TCP document, which will have
its milestone date pushed out to sometime this fall, as the working group
needs to concentrate its efforts on the revision to STUN (rfc3489bis) and on
TURN, which are needed for VoIP.

Please provide comments to the list.  

-d

---

From: Philip Matthews <[email-masked]>
Date: Wed, 10 May 2006 05:44:13 -0700 (PDT)

I support having the ICMP draft becoming a WG work item.

I agree that the WG needs to concentrate on STUN and TURN,
which are needed for ICE.
- Philip

On 8-May-06, at 20:04 , Dan Wing wrote:

I would like the list to consider having
draft-srisuresh-behave-nat-icmp-02.txt become a WG item.
I expect its milestone would align with the TCP document, which  
will have
its milestone date pushed out to sometime this fall, as the working  
group
needs to concentrate its efforts on the revision to STUN  
(rfc3489bis) and on
TURN, which are needed for VoIP.

-d
_______________________________________________
Ietf-behave mailing list
Ietf-behave@xxxxxxxxxxxxxxxxxxx
https://list.sipfoundry.org/mailman/listinfo/ietf-behave

---

From: Fernando Gont <[email-masked]>
Date: Thu, 11 May 2006 04:00:31 -0700 (PDT)

At 09:45 10/05/2006, Philip Matthews wrote:

It seems I didn't receive the original post from Dan, so I am 
answering to this e-mail instead.

I support the ICMP draft in becoming a WG item.

Kindest regards,
Fernando Gont

-d
_______________________________________________
Ietf-behave mailing list
Ietf-behave@xxxxxxxxxxxxxxxxxxx
https://list.sipfoundry.org/mailman/listinfo/ietf-behave
_______________________________________________
Ietf-behave mailing list
Ietf-behave@xxxxxxxxxxxxxxxxxxx
https://list.sipfoundry.org/mailman/listinfo/ietf-behave
--
Fernando Gont
e-mail: fernando@xxxxxxxxxxx || fgont@xxxxxxx
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 24 May 2006 16:21:16 -0700 (PDT)

I strongly object to adopting this without discussion with the WG.  
Let's give this draft agenda time at the next IETF and then at the  
end ask the 100 plus members of this WG if they want to adopt it.

Cullen <with my individual hat on>

On May 8, 2006, at 5:04 PM, Dan Wing wrote:

-d

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 24 May 2006 16:39:28 -0700 (PDT)

> end ask the 100 plus members of this WG if they want to adopt it.

Decisions are made on-list.  As of my email on May 8 (two weeks 
ago), only two people responded and both were positive:  Fernando 
Gont and Philip Matthews.  The draft had agenda time at the last 
IETF, I'm not sure what else you wanted to discuss.  I know the 
scope of the document is larger than you'd like; as a WG document 
we can manage its scope in conjunction with other WG documents.

The draft will be on the agenda, if there is time.  What remains
most critical for BEHAVE is to finish off the ICE-related 
specifications (rfc3489bis, TURN, turn-v6) because it is holding
up implementations of VoIP.  To my knowledge, turning ICMP into 
an RFC is not holding up implementations of NATs, VoIP gear, or 
applications, and our agenda time will be spent accordingly.

-d

---

From: Philip Matthews <[email-masked]>
Date: Thu, 25 May 2006 08:18:21 -0700 (PDT)

Just to clarify what I meant by my previous vote for support of this  
document:

I support the idea of having a BEHAVE document that covers ICMP,
because I feel ICMP is a key protocol that BEHAVE needs to say
something about.
Right now, draft-srisuresh-behave-nat-icmp-02 is the only document
we have that covers ICMP, so I am willing to take it as a starting  
point.
But I do think it needs careful review.

What I think Cullen is suggesting is that the contents of this document
need careful review. He suggests going over it carefully in a WG  
meeting.
I would also like to see this happen.

Perhaps a way forward is to adopt draft-srisuresh-behave-nat-icmp-02
as a WG item, but put it lower on the priority list than the ICE  
documents
and the TCP document?
This would mean that the STUN and TURN documents, and the TCP document,
would get the bulk of the presentation time at the Montreal meeting,
and there might not be time for the ICMP document at that meeting.
However, we would try to have a presentation of the type that Cullen
is suggesting at a later meeting (hopefully the fall meeting).

Just my 2 cents ...

- Philip

On 24-May-06, at 19:39 , Dan Wing wrote:

its milestone date pushed out to sometime this fall, as the
working group

-d

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 25 May 2006 14:25:16 -0700 (PDT)

On May 24, 2006, at 4:39 PM, Dan Wing wrote:

The draft had agenda time at the last
IETF, I'm not sure what else you wanted to discuss.
The topic of if the WG wanted to adopt this draft and why some people  
thought that was a good idea and why others did not.

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 25 May 2006 14:51:42 -0700 (PDT)

> The topic of if the WG wanted to adopt this draft and why 
> some people thought that was a good idea and why others 
> did not.

Ok.  I will be sure at least 10 minutes are on the agenda 
for doing that.  

-d

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 25 May 2006 14:54:15 -0700 (PDT)

> point.  But I do think it needs careful review.
>
> What I think Cullen is suggesting is that the contents of this
> document need careful review.  He suggests going over it carefully
> in a WG meeting.  I would also like to see this happen.
>
> documents and the TCP document? 

Yes, that is my intent.  There are new milestones for BEHAVE, which
have been accepted by our AD (Magnus).  I emailed them to 
iesg-secretary last week and I'm waiting for them to be published.

The milestone for ICMP is March, 2007.  If (and only if) we aren't 
busy with our earlier milestones and if ICMP is ready, we can 
last-call ICMP earlier.

With Cullen's objection, though, we will discuss this at the 
meeting.  It's certainly the case that there seem to be few
people interested positively (2, plus its authors, I assume)
or negatively (1) about this document.

> This would mean that the STUN and
> TURN documents, and the TCP document, would get the bulk of the
> presentation time at the Montreal meeting, and there might not be
> time for the ICMP document at that meeting.  However, we would try
> to have a presentation of the type that Cullen is suggesting at a
> later meeting (hopefully the fall meeting).
>
> Just my 2 cents ...

Those cents make good sence.  Thanks.

-d

---

From: Pyda Srisuresh <[email-masked]>
Date: Thu, 25 May 2006 16:36:40 -0700 (PDT)

> > point.  But I do think it needs careful review.

[suresh] Philip - I sent a revised draft yesterday for publication as WG draft
(with Dan's OK). The draft is now available as
draft-ietf-behave-nat-icmp-00.txt. Do give this draft a careful review and let
us (the authors) know your comments. 

I am all for people reviewing the draft and sending comments. Decisions should
be made on the list.

> busy with our earlier milestones and if ICMP is ready, we can 

[suresh] As I said earlier, I welcome comments and review on the list. We
cannot know if a draft is ready, unless it is reviewed. The list should be such
a forum for review - Not WG meetings, which are held just 3 times a year. 

It does not make sense to wait for a WG meeting to decide on adapting a
document for the WG or any decision for that matter.

> or negatively (1) about this document.
[suresh] Dan - You did a detailed review of the draft before OKing it as WG
draft. Does that not count as one more for Yes? If so, that would be 3 for Yes,
apart from the authors. (or) would you rather not inlcude a WG chair's opinion?

Obviously, the more people review and speak up, the easier it is to proceed
forward. Thanks.

Cheers,
suresh

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 25 May 2006 19:05:11 -0700 (PDT)

> [suresh] Dan - You did a detailed review of the draft before 
> OKing it as WG draft. Does that not count as one more for
> Yes?  If so, that would be 3 for Yes, apart from the authors. 
> (or) would you rather not inlcude a WG chair's opinion?

We're still talking 1-2% of BEHAVE (~200 subscribers, ~100
attendees at IETF), with or without me.

-d

---

From: Pyda Srisuresh <[email-masked]>
Date: Thu, 25 May 2006 20:01:29 -0700 (PDT)

> attendees at IETF), with or without me.
[suresh] And, there is one person (Cullen as individual contributor) that
objected. That would be less than 1%, if you go by % counts.

And, the objection is on procedural count, not on technical. For the record, I
disagree with Cullen's assertion that decisions should only be made on the WG
meeting. This is wrong procedurally. Decisions shoudl be made on the list. And,
I did not hear any technical reason why he objects to seeing the draft draft
adapted as WG draft.

There is a pattern here. Cullen had insisted in the past there is no need for
an ICMP behave document on the list. Each time he did this, I or someone on the
list responded with a technical reason why that is not so (Refer the several
e-mail exchanges before the last IETF WG meeting). He held out on giving the
draft a slot/time in the WG meeting till the very end. He repeated the comments
again during the last WG meeting. He used similar type of questioning during
the private review as well and kept prolonging the discussion. In the end,
everyone, inluding himself, agreed there was value to the draft. Now, he
objects again - this time on procedural grounds. He has been single handedly
filibustering the document. This is not conducive to productive participation.
My 2c.

regards,
suresh

---

From: Bryan Ford <[email-masked]>
Date: Fri, 26 May 2006 00:14:23 -0700 (PDT)

FWIW, I too support the adoption of the ICMP draft.

As for "counting percentages", my observation is that it is a very rare event 
indeed that more than around 3-5 people on the BEHAVE list ever to 
participate actively in *any* given thread during a short period of time, or 
even take the time to post an "aye" or a "nay" to some proposal, however 
crucial or non-crucial it may be to the WG.  By these standards I think the 
1-2% of BEHAVE that has spoken in favor of adopting the ICMP draft represents 
a veritable "groundswell of support", so to speak. :)  And as Suresh pointed 
out, there have been no technical objections and only one procedural 
objection to adoption - the latter running directly counter to the group's 
long-established policy of deciding matters on-list whenever possible and 
only falling back to the WG meeting to decide long-running technical 
arguments that fail to reach consensus on the list.

That said, I have no objection to bringing up the issue at the WG meeting, as 
a matter of confirming the decision made on the list (or discovering any 
serious objections by people not actively participating on the list).

Bryan

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 29 May 2006 05:14:07 -0700 (PDT)

On May 25, 2006, at 4:36 PM, Pyda Srisuresh wrote:

 Decisions should
be made on the list.
Decisions should represent consensus of the members of the WG and  
that includes the people that show up for the WG meetings.