Subject: RE: [Ietf-behave] WG last call: draft-ietf-behave-nat-udp-01.txt

From: "Francois Audet" <[email-masked]>
Date: Wed, 11 May 2005 10:37:39 -0700 (PDT)

Bryan,

The first version of the draft Cullen and I presented had both UDP and TCP
covered.

The group decided in the meeting that it should be split in two. The intent
was to not have progress stalled, because there is a sense of urgency for this
problem.

> -----Original Message-----
> From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
> [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of 
> Bryan Ford
> Sent: Wednesday, May 11, 2005 07:02
> To: ietf-behave@xxxxxxxxxxxxxxxxxxx
> Subject: Re: [Ietf-behave] WG last call: 
> draft-ietf-behave-nat-udp-01.txt
> 
> 
> I likewise do not remember any such decision being made, or 
> even discussed on 
> the list.  If you're referring to some decision made 
> "somewhere up high in 
> the chain of command" at the very formation of this WG, as 
> you seem to 
> suggest, then that decision was presumably made before any 
> actual text was on 
> the table and before any of the technical issues had been 
> explored in depth.
> 
> I do remember seeing a bit of discussion long ago of whether 
> to have two 
> documents (TCP and UDP) or just one big combined document, 
> but _nobody_ here 
> is suggesting just one big document at this point.  The issue 
> here, now, is 
> whether to split the (very considerable) common portions of 
> the TCP and UDP 
> docs out into a common, transport-neutral doc.  The issue is 
> not one document 
> versus two, but two documents versus three.
> 
> At the formation of the WG, it probably wasn't obvious that 
> there would be a 
> lot of material common to TCP and UDP, because that material 
> hadn't been 
> written yet.  Now that it's been written, it's become very 
> clear that there 
> is a great deal of common technical requirements, and it would be a 
> structural and readability disaster to duplicate that 
> material across the 
> documents or litter them with ad hoc, ambiguous 
> cross-references.  Given 
> this, it seems highly appropriate to revisit the original 
> decisions on 
> document organization that were made at the formation of the WG.
> 
> Cheers,
> Bryan
> 
> On Tuesday 10 May 2005 20:28, Cullen Jennings wrote:
> > On 5/9/05 7:22 PM, "Pyda Srisuresh" <srisuresh@xxxxxxxxx> wrote:
> > > <... stuff deleted>
> > >
> > >>>>   The common requirements should be addressed in a seperate 
> > >>>> document, that will make both the TCP and UDP requirements 
> > >>>> concise and should not be interleaved in this UDP requirements 
> > >>>> draft.
> > >>>
> > >>> That's one option. Another is to make the two drafts parallel, 
> > >>> pointing out where they differ due to specific 
> differences between 
> > >>> UDP and TCP.
> > >>
> > >> Agree. That decision (to have two parrallel drafts) was already 
> > >> made
> > >
> > > [suresh] When was this decision made? This was neither 
> reviewed nor 
> > > decided upon on the list.
> >
> > This was discussed on the list before the BOF. It was 
> discussed in the 
> > BOF. It was discussed by ADs and reviewed by IAB and IESG 
> in forming 
> > charter. It has been pointed out to you in email from me. 
> It is shown 
> > in the milestone section of the Charter page.
> >
> > If there is anything I can do to make it clear I'm glad to 
> do it. If 
> > you would like to have another phone call around the reasoning that 
> > went into that decision, I am glad to set up a conference 
> call for you 
> > and anyone else that cares to join.
> >
> > I'm not sure what else to do.
> >
> > Cullen with my chair hat on.
> >
> > _______________________________________________
> > Ietf-behave mailing list
> > Ietf-behave@xxxxxxxxxxxxxxxxxxx 
> > https://list.sipfoundry.org/mailman/listinfo/ietf-behave
> _______________________________________________
> Ietf-behave mailing list
> Ietf-behave@xxxxxxxxxxxxxxxxxxx 
> https://list.sipfoundry.org/mailman/listinfo/ietf-behave
> 
>

---

From: Bryan Ford <[email-masked]>
Date: Wed, 11 May 2005 11:15:56 -0700 (PDT)

> was to not have progress stalled, because there is a sense of urgency for

As I already pointed out, I don't have any argument with splitting UDP and TCP 
- that was done long ago and was certainly the right decision.  The issue now 
is whether to take the common technical portions of both of these two 
documents and split them out into a third transport-independent document, the 
need for which only became apparent later, after a lot more work had been 
done on both the TCP and UDP drafts and major technical redundancies started 
appearing.  That's the issue that's on the table now - nobody is suggesting 
to merge the TCP and UDP drafts back into one.

Bryan