Subject: [Ietf-behave] STUN message length in rfc3489bis

From: Greg Daley <[email-masked]>
Date: Tue, 16 May 2006 06:56:07 -0700 (PDT)

Hi,
(Cc: authors)
Is it really the intention to limit the sum of
the lengths of STUN attributes to 255 characters
in RFC3489bis?
The length is currently encoded as an 8 bit field
in octets.
This is very limiting when used in conjunction
with data/send indications in draft-ietf-behave-turn-00,
especially where there are REMOTE/DESTINATION ADDRESS
and DATA fields (plus possibly MESSAGE INTEGRITY)
If you could comment that would be really useful.

Greg Daley

---

From: "Justin Uberti" <[email-masked]>
Date: Tue, 16 May 2006 10:56:13 -0700 (PDT)

Hi Greg,

According to rfc3489bis-03.txt, section 6, at the top of page 11:

"After the STUN header are zero or more attributes.  Each attribute is
TLV encoded, with a 16 bit type, 16 bit length, and variable value:"

IOW, the length is 16 bits, not 8.

--justin

Greg Daley wrote on 5/16/2006, 9:55 AM:

 > _______________________________________________
 > Ietf-behave mailing list
 > Ietf-behave@xxxxxxxxxxxxxxxxxxx
 > https://list.sipfoundry.org/mailman/listinfo/ietf-behave
 >

---

From: Greg Daley <[email-masked]>
Date: Tue, 16 May 2006 18:12:13 -0700 (PDT)

Hi,

Thanks gain, Justin for pointing this out.
I'd misread the figure.
Greg

Justin Uberti wrote:
Hi Greg,

--justin