Subject: [Ietf-behave] SNMP and consumer NATs

From: "David Barrett" <[email-masked]>
Date: Sun, 18 Jun 2006 02:14:15 -0700 (PDT)

<span style='font-size:10.0pt;
font-family:Arial'>I’m not sure if it’s within the scope of BEHAVE,
but do we offer any guidance to device manufacturers regarding the support of
SNMP?  In your experience, what fraction of consumer NAT devices (DSL routers,
wireless routers, etc) support SNMP?

<span style='font-size:10.0pt;
font-family:Arial'> 

<span style='font-size:10.0pt;
font-family:Arial'>In addition to NAT penetration (which has been discussed
extensively) I’m thinking another problem we’re facing is sharing
upstream gateways; I’m curious if there’s any way for a client to
query its gateway and get a sense of its current upstream and downstream
bandwidth utilization.  Ideally, there would be some way (perhaps UPnP or
SNMP?) to do this that is reasonable standardized across devices.

<span style='font-size:10.0pt;
font-family:Arial'> 

<span style='font-size:10.0pt;
font-family:Arial'>Has this already been done or am I barking up the wrong
tree?

<span style='font-size:10.0pt;
font-family:Arial'> 

<span style='font-size:10.0pt;
font-family:Arial'>-david

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 21 Jun 2006 20:45:11 -0700 (PDT)

inline...On Jun 18, 2006, at 2:14 AM, David Barrett wrote: I’m not sure if it’s within the scope of BEHAVE, but do we offer any guidance to device manufacturers regarding the support of SNMP?  In your experience, what fraction of consumer NAT devices (DSL routers, wireless routers, etc) support SNMP?I have not kept track of any stats on this and I have never test what SNMP work but a large percentage of the consumer NATs I have used have had config section to configure SNMP on the so they must do something.