Subject: RE: [Ietf-behave] missing defintion in draft-ietf-behave-nat-udp-04

From: "Francois Audet" <[email-masked]>
Date: Wed, 25 Jan 2006 20:29:08 -0800 (PST)

You mean when Y1 and Y2 are different????

Have you seen a NAT that actually does this?

> -----Original Message-----
> From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
> [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of 
> Karlheinz Wurm
> Sent: Wednesday, January 25, 2006 08:04
> To: ietf-behave@xxxxxxxxxxxxxxxxxxx
> Subject: [Ietf-behave] missing defintion in 
> draft-ietf-behave-nat-udp-04
> 
> 
> Hi everyone,
> 
> Since I recently got confronted with the following behavior, 
> i think one 
> definition is missing at point 4.1 ...  The following address 
> and port 
> mapping behavior are defined: ...
> 
> 
> I would call it a Port Dependent Mapping which means:
> 
>     +------+                 +------+  x
>     |  Y1  |                 |  Y2  |  t
>     +--+---+                 +---+--+  e
>        | Y1:y1            Y2:y2  |     r
>        +----------+   +----------+     n
>                   |   |                a
>           X1':x1' |   | X2':x2'        l
>                +--+---+-+
>     ...........|   NAT  |...............
>                +--+---+-+              I
>                   |   |                n
>               X:x |   | X:x            t
>                  ++---++               e
>                  |  X  |               r
>                  +-----+               n
>                                        a
> 
>        Port Dependent Mapping:
>           The NAT reuses the port mapping for subsequent packets sent
>           from the same internal IP address and port (X:x) to the same
>           external Port address, regardless of the external IP.
>           Specifically, X1':x1' equals X2':x2' if, and only 
> if, y2 equals
>           y1.
> 
> 
> Kind regards,
> 
> -- 
> Karlheinz Wurm,
> Skype Technologies S.A.
> 
> callto://wurm
> +372 536 48 166
> 
> Get Skype from http://www.skype.net
> We're hiring http://www.skype.net/company/jobs
> --
> This electronic transmission and any attached files are 
> solely for the intended recipient and may contain information 
> that is privileged, confidential or otherwise protected from 
> disclosure. Any review, retransmission, dissemination or 
> other use, including taking any action concerning this 
> information by anyone other than the intended recipient, is 
> prohibited. If you are not the intended recipient or have 
> received this communication in error, please immediately 
> notify the sender and destroy this communication.
>

---

From: Saikat Guha <[email-masked]>
Date: Wed, 25 Jan 2006 20:47:49 -0800 (PST)

> Have you seen a NAT that actually does this?

I have seen this sort of binding behavior for TCP (couple of Belkin and
Westell NATs). Actually, I vaguely remember an old version of the UDP
draft defining this sort of behavior as Port Dependent ... or NB=P or
something like that.

-- 
Saikat
Attachment:
signature.asc

---

From: Karlheinz Wurm <[email-masked]>
Date: Thu, 26 Jan 2006 00:07:11 -0800 (PST)

Francois Audet wrote:

Y1 and Y2 are different but y1 and y2 are the same. Than the NAT will 
bind it to the same external port.

e.g.

Local           RemoteAddress   External NAT address
X:x             Y1:1925         X1':33394
X:x             Y2:1925         X1':33394
X:x             Y3:34575        X1':32781
X:x             Y4:5986         X1':33625
And the worse is that the external port binding is completely random.

Yes, i am just looking in one of this router. That's why i am missing 
that definition. I don't want to name the model since we are in business 
relation with them but it is the latest model of one of the very biggest 
router vendors and widely distributed.

-----Original Message-----

Hi everyone,

    +------+                 +------+  x
    |  Y1  |                 |  Y2  |  t
    +--+---+                 +---+--+  e
       | Y1:y1            Y2:y2  |     r

Kind regards,

--
Karlheinz Wurm,
Skype Technologies S.A.
callto://wurm
+372 536 48 166
Get Skype from http://www.skype.net
We're hiring http://www.skype.net/company/jobs
--
This electronic transmission and any attached files are solely for the
intended recipient and may contain information that is privileged,
confidential or otherwise protected from disclosure. Any review,
retransmission, dissemination or other use, including taking any
action concerning this information by anyone other than the intended
recipient, is prohibited. If you are not the intended recipient or
have received this communication in error, please immediately notify
the sender and destroy this communication.
begin:vcard
fn:Karlheinz Wurm
n:Wurm;Karlheinz
email;internet:karlheinz.wurm@xxxxxxxxx
tel;work:+1 (415) 508-3653
tel;cell:+372 536 369 75
x-mozilla-html:FALSE
version:2.1
end:vcard