Subject: RE: [Ietf-behave] NAT behave draft

From: "Francois Audet" <[email-masked]>
Date: Thu, 19 Aug 2004 14:59:25 -0700 (PDT)

> I don't see the problem here, actually. Why can't we specify 
> different 
> keepalive rules for multicast and unicast? The two are readily 
> differentiated in the NAT by the IP address. For multicast, there 
> basically is a "keepalive" from the inside to the out - IGMP. If the 
> user decides to leave the group, packets won't be forwarded, 
> and there 
> is no problem.

That's kind of my thinking too.

Isn't there a way the NAT can distinguish between multicast traffic 
and uniscast traffic are apply different rules?

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 19 Aug 2004 16:10:51 -0700 (PDT)

I may have misunderstood the thread, but I thought the request 
was that BEHAVE NATs are multicast-aware enough that they don't break multicast 
(by dropping all multicast packets, for instance)... were we talking about 
something else?
 
Spencer
<BLOCKQUOTE 
style="PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
  ----- Original Message ----- 
  <DIV 
  style="BACKGROUND: #e4e4e4; FONT: 10pt arial; font-color: black">From: 
  <A title=audet@xxxxxxxxxxxxxxxxxx 
  href="mailto:audet@xxxxxxxxxxxxxxxxxx">Francois Audet 
  To: <A title=jdrosen@xxxxxxxxxxxxxxx 
  href="mailto:jdrosen@xxxxxxxxxxxxxxx">'Jonathan Rosenberg' ; <A 
  title=laforge@xxxxxxxxxxxxx href="mailto:laforge@xxxxxxxxxxxxx">'Harald 
  Welte' 
  Cc: <A 
  title=ietf-behave@xxxxxxxxxxxxxxxxxxx 
  href="mailto:'ietf-behave@xxxxxxxxxxxxxxxxxxx'">'ietf-behave@xxxxxxxxxxxxxxxxxxx' 
  
  Sent: Thursday, August 19, 2004 4:59 
  PM
  Subject: RE: [Ietf-behave] NAT behave 
  draft
  
  > I don't see the problem here, actually. Why can't we 
  specify > different > 
  > differentiated in the NAT by the IP address. For 
  multicast, there > basically is a "keepalive" from 
  the inside to the out - IGMP. If the > user decides 
  to leave the group, packets won't be forwarded, > 
  and there > is no problem. 
  That's kind of my thinking too. 
  Isn't there a way the NAT can distinguish between multicast 
  traffic and uniscast traffic are apply different 
  rules? 

  _______________________________________________Ietf-behave mailing 
  listIetf-behave@xxxxxxxxxxxxxxxxxxxhttps://list.sipfoundry.org/mailman/listinfo/ietf-behave