Subject: AW: [Ietf-behave] Ietf-behave] Re: NATting SCTP

From: Schruefer Wolfgang <[email-masked]>
Date: Thu, 3 Feb 2005 06:56:42 -0800 (PST)

<SPAN 
class=596012314-03022005>OR ...
<SPAN 
class=596012314-03022005> 
<SPAN 
class=596012314-03022005>if you want to use SCTP and you want to use 
NAPT (in the classical way) ...
<SPAN 
class=596012314-03022005> 
<SPAN 
class=596012314-03022005>...  in theory <FONT face=Arial 
color=#0000ff size=2>...  you could extend 
SCTP to accept from a remote endpoint multiple IP addresses with 
multiple ports instead of multiple IP addresses with only one fixed port 
...  
<SPAN 
class=596012314-03022005> 
<SPAN 
class=596012314-03022005> 
<SPAN 
class=596012314-03022005>Wolfgang 

Von: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
[mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] Im Auftrag von Luca 
LaurenziGesendet: Donnerstag, 3. Februar 2005 11:31An: 
Ietf-behave@xxxxxxxxxxxxxxxxxxxBetreff: Re: [Ietf-behave] 
Ietf-behave] Re: NATting SCTP

THUS...
 
if i can't change source port number whitin a gived 
association, NAPT will have to multiplex/demultiplex using something other than 
the SCTP port number?..

---

From: Qiaobing Xie <[email-masked]>
Date: Thu, 3 Feb 2005 09:14:36 -0800 (PST)

Wolfgang,

It is not possible to extend SCTP to use multiple ports in a single endpoint. One fixed port 
is rather a fundamental part of the SCTP design.

regards,
-Qiaobing
Schruefer Wolfgang wrote:

OR ...
 
if you want to use SCTP and you want to use NAPT (in the classical way) ...
 
...  in theory ...  you could extend SCTP to accept from a remote 
endpoint multiple IP addresses with multiple ports instead of multiple 
IP addresses with only one fixed port ...  

Wolfgang 

------------------------------------------------------------------------
Von: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
[mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] Im Auftrag von Luca 
Laurenzi
Gesendet: Donnerstag, 3. Februar 2005 11:31
An: Ietf-behave@xxxxxxxxxxxxxxxxxxx
Betreff: Re: [Ietf-behave] Ietf-behave] Re: NATting SCTP

THUS...
 
if i can't change source port number whitin a gived association, NAPT 
will have to multiplex/demultiplex using something other than the SCTP 
port number?.. 

------------------------------------------------------------------------

_______________________________________________
Ietf-behave mailing list
Ietf-behave@xxxxxxxxxxxxxxxxxxx
https://list.sipfoundry.org/mailman/listinfo/ietf-behave