Subject: RE: [Ietf-behave] Re: adding SCTP at behave milestone

From: Schruefer Wolfgang <[email-masked]>
Date: Wed, 23 Feb 2005 09:24:03 -0800 (PST)

Couldn't it be a compromise to split Qiaobing's draft into two drafts:

- a tiny one for NAT enhancements to support singly-homed SCTP associations
- and the other one for the multi-homed problem

I am sure there would be a big consensus about the first one and why not start 
to make it an WG draft on its own ...?

Best regards,
Wolfgang

> -----Original Message-----
> From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
> [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of 
> Qiaobing Xie
> Sent: Tuesday, February 22, 2005 7:34 PM
> To: Melinda Shore
> Cc: 'Behave'
> Subject: Re: [Ietf-behave] Re: adding SCTP at behave milestone
> 
> Melinda,
> 
> This is why I suggested that making it a WG item would help - 
> more people can read it more 
> carefully and contribute to its improvement.
> 
> As to the particular issue of nat/nat protocol, you may have 
> mis-read the draft badly.
> 
> I know your view on this nat/nat protocol issue (and I 
> dislike it too), but I have no idea 
> where you got the impression that the draft is proposing a 
> solution based on a nat/nat protocol.
> 
> Here is the only place that topic is mentioned in the draft:
> 
> "  This [state sync among NATs] can only be
>     possible if there exists some inter-NAT protocol which can provide
>     coordination amongst the NATs when the association is set up.
>     Further study is needed for this scenario.
> "
> 
> As to the multi-homed traversal problem, how do you want to frame it?
> 
> regards,
> -Qiaobing
> 
> Melinda Shore wrote:
> 
> > On Tuesday, February 22, 2005, at 12:40 PM, Francois Audet wrote:
> > 
> >> Isn't the solution to this really simple:
> >> let people who are interested continue to work on it,
> >> with the understanding that we will go to last call
> >> on the other most important document first?
> > 
> > Anybody can work on anything, obviously.  Working group milestones
> > are another matter, and it makes sense to be a bit conservative
> > in agreeing to deliver deliverables.
> > 
> > Also, the specific question that was posed was whether or 
> not to make
> > Qiaobing's draft a working group document.  I have nothing 
> but respect
> > for Qiaobing's excellent work in a number of areas, but I think that
> > this one draft is really not very good.  I don't think the 
> multihomed
> > traversal problem is framed very coherently and the 
> proposed solution
> > (a nat/nat protocol) is just wrong, for reasons I've 
> outlined previously.
> > 
> > Melinda
> > _______________________________________________
> > Ietf-behave mailing list
> > Ietf-behave@xxxxxxxxxxxxxxxxxxx
> > https://list.sipfoundry.org/mailman/listinfo/ietf-behave
> 
> _______________________________________________
> Ietf-behave mailing list
> Ietf-behave@xxxxxxxxxxxxxxxxxxx
> https://list.sipfoundry.org/mailman/listinfo/ietf-behave
>

---

From: Qiaobing Xie <[email-masked]>
Date: Wed, 23 Feb 2005 10:57:50 -0800 (PST)

Hi, Wolfgang,

Please see my earlier email. The key is not singly-homed or multi-homed, rather it is 
single-point traversal vs. multi-point traversal. The latter is the cause of all the 
troubles here and any discussion over it can be taken out from the draft without problem.

regards,
-Qiaobing
Schruefer Wolfgang wrote:

- a tiny one for NAT enhancements to support singly-homed SCTP associations
- and the other one for the multi-homed problem
I am sure there would be a big consensus about the first one and why not start to make it an WG draft on its own ...?

Best regards,
Wolfgang

-----Original Message-----

Melinda,

regards,
-Qiaobing
Melinda Shore wrote:

Melinda