Subject: [Ietf-behave] RE: [Sip] draft-takeda-symmetric-nat-traversal ??

From: "Dan Wing" <[email-masked]>
Date: Wed, 29 Sep 2004 21:09:44 -0700 (PDT)

Thanks for bringing that I-D to the group's attention.  I, for one, hadn't
seen it.

Section 8.1 is where the meat is, and it says:

   ...
   If
   the port allocation rule of the other endpoint is a symmetric type,
   the endpoint needs either to record the source port number of an
   incoming packet or to predict a port number that the symmetric NAT
   will assign, with a MAPPED-ADDRESS obtained from the other endpoint.
   ...

which I agree isn't a good mechanism, especially with a large NAT.  It
could work just fine on a small, residential NAT which isn't processing
much new traffic (and thus it is, in theory, possible to guess the next
port number it will assign for the next mapping).

This technique is too fragile for my blood.

There is a lot of other good information in this Internet Draft, though;
I hope we can incorporate some of it into the BEHAVE work if the author
is willing.

-d

> -----Original Message-----
> From: sip-bounces@xxxxxxxx [mailto:sip-bounces@xxxxxxxx]On Behalf Of
> Vikram Bhuskute
> Sent: Wednesday, September 29, 2004 4:12 AM
> To: sip@xxxxxxxx
> Subject: [Sip] draft-takeda-symmetric-nat-traversal ??
>
>
> Hello all,
>             While searching for NAT traversal solution i came across a
> draft  "draft-takeda-symmetric-nat-traversal-00.txt"
>             from url (
> http://cnscenter.future.co.kr/resource/ietf/ind-draft/draft-takeda
> -symmetric-nat-traversal-00.txt)
>
>            It proposes some solution for Symmetric NAT based on some
> Prediction .....?  It dosent seem reliable ... !!!
>           (however it gives  glimps on type of Symmetric NATs )
>
>            Is it still a matter of further research ? or the concept  is
> not well accepted ?
>
>           thanks in advance
>
>  vikram
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use sip-implementors@xxxxxxxxxxxxxxx for questions on current sip
> Use sipping@xxxxxxxx for new developments on the application of sip

---

From: "Francois Audet" <[email-masked]>
Date: Thu, 30 Sep 2004 16:14:18 -0700 (PDT)

I've removed from the SIP mailing list and kept it in BEHAVE.

I agree with Dan that the mechanism is brittle. However, there is
some good information in there. 

In particular, I find Table 6.3.1 a nice way to reconcile the
categories of NAT behavior we have in BEHAVE with the "old" 
terminology (Cone, Symmetric, etc). Might be a good idea to think
about a similar format. I'll think about it.

> From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
> [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Dan Wing
> Sent: Wednesday, September 29, 2004 21:10
> To: Vikram Bhuskute; sip@xxxxxxxx
> Cc: takeday@xxxxxxxxx; IETF Behave Mailing List
> Subject: [Ietf-behave] RE: [Sip] 
> draft-takeda-symmetric-nat-traversal ?? 
> 
> 
> Thanks for bringing that I-D to the group's attention.  I, 
> for one, hadn't seen it.
> 
> which I agree isn't a good mechanism, especially with a large 
> NAT.  It could work just fine on a small, residential NAT 
> which isn't processing much new traffic (and thus it is, in 
> theory, possible to guess the next port number it will assign 
> for the next mapping).
> 
> There is a lot of other good information in this Internet 
> Draft, though; I hope we can incorporate some of it into the 
> BEHAVE work if the author is willing.
> 
> -d
> 
> >            Is it still a matter of further research ? or 
> the concept  
> > is not well accepted ?
> >
> >           thanks in advance
> >
> >  vikram
> >
> > Use sip-implementors@xxxxxxxxxxxxxxx for questions on 
> current sip Use 
> > sipping@xxxxxxxx for new developments on the application of sip
> 
> Ietf-behave mailing list
> Ietf-behave@xxxxxxxxxxxxxxxxxxx 
> https://list.sipfoundry.org/mailman/listinf> o/ietf-behave
> 
>