Subject: RE: [Ietf-behave] Maximum number of binding

From: "Francois Audet" <[email-masked]>
Date: Fri, 19 Nov 2004 15:58:41 -0800 (PST)

Thanks for the comments. I hadn't put too much tought into it, as
I viewed this more of a product specification type of requirement.

Let's see if anybody has any views on the list.

> -----Original Message-----
> From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
> [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of 
> Yutaka_Takeda@xxxxxxxxxxxxxxxxxxxx
> Sent: Friday, November 19, 2004 13:59
> To: ietf-behave@xxxxxxxxxxxxxxxxxxx
> Subject: [Ietf-behave] Maximum number of binding
> 
> 
> I like how 'behave-nat-00' classifies different behaviors of 
> NAT.  The 
> common term definitions also make my life easier, indeed. Nice job!
> 
> One thing I thought... It would be nice to include a requirement on:
> 
> - Minimum number of bindings per NAT.
> 
> Especially, NB=AD and NB=APD  consume more memory resource in 
> NAT. The 
> requirement may have to have:
> 
> - Minimum number of connections (destinations) per binding.
> 
> I can see that developers especially who are working on residential 
> gateways, or routers are trying minimize its
> memory requirement to bring down hardware cost as low as 
> possible to win 
> the race. Does anyone have any idea or thoughts on above 
> parameters in 
> existing NATs?
> 
> Thanks,
> Yutaka
> 
> 
> _______________________________________________
> Ietf-behave mailing list
> Ietf-behave@xxxxxxxxxxxxxxxxxxx 
> https://list.sipfoundry.org/mailman/listinfo/ietf-behave
> 
>

---

From: [email-masked]
Date: Wed, 24 Nov 2004 15:04:31 -0800 (PST)

If number of simultaneous connections per 
binding exceeds what a NAT can have, the NAT might either overwrite an 
existing binding for a new connection or do nothing with the new 
connection, and there is no way for an application to know what is 
going on... this is the problem. I think Teredo is a good example, which 
encapsulates multiple IPv6 TCP/UDP connection to many remote hosts on 
a single IPv4 UDP socket binding assuming that a NAT can have enough number of 
connections on a single binding (especially when NB=AD or APD). I feel at least 
in such a case the NAT could send a new ICMP error like "Too many 
connections" back to a connecting node, IMHO.
 
Yutaka
 
<BLOCKQUOTE 
style="PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
  ----- Original Message ----- 
  <DIV 
  style="BACKGROUND: #e4e4e4; FONT: 10pt arial; font-color: black">From: 
  <A title=audet@xxxxxxxxxxxxxxxxxx 
  href="mailto:audet@xxxxxxxxxxxxxxxxxx">Francois Audet 
  To: <A 
  title=Yutaka_Takeda@xxxxxxxxxxxxxxxxxxxx 
  href="mailto:Yutaka_Takeda@xxxxxxxxxxxxxxxxxxxx">Yutaka_Takeda@xxxxxxxxxxxxxxxxxxxx 
  ; <A title=ietf-behave@xxxxxxxxxxxxxxxxxxx 
  href="mailto:'ietf-behave@xxxxxxxxxxxxxxxxxxx'">'ietf-behave@xxxxxxxxxxxxxxxxxxx' 
  
  Sent: Friday, November 19, 2004 3:57 
  PM
  Subject: RE: [Ietf-behave] Maximum number 
  of binding
  
  Thanks for the comments. I hadn't put too much tought into it, 
  as I viewed this more of a product specification type 
  of requirement. 
  Let's see if anybody has any views on the list. 
  > -----Original Message----- > 
  From: <A 
  href="mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx">ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
  > [<A 
  href="mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx">mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] 
  On Behalf Of > <A 
  href="mailto:Yutaka_Takeda@xxxxxxxxxxxxxxxxxxxx">Yutaka_Takeda@xxxxxxxxxxxxxxxxxxxx 
  > Sent: Friday, November 19, 2004 13:59 <FONT 
  size=2>> To: <A 
  href="mailto:ietf-behave@xxxxxxxxxxxxxxxxxxx">ietf-behave@xxxxxxxxxxxxxxxxxxx 
  > > <FONT 
  size=2>> I like how 'behave-nat-00' classifies different behaviors of 
  > NAT.  The > 
  > > One thing I thought... It 
  would be nice to include a requirement on: > 
  > > Especially, NB=AD and 
  NB=APD  consume more memory resource in > NAT. 
  The > requirement may have to have: 
  > > - Minimum number of 
  connections (destinations) per binding. > 
  > I can see that developers especially who are 
  working on residential > gateways, or routers are 
  trying minimize its > memory requirement to bring 
  down hardware cost as low as > possible to win 
  > the race. Does anyone have any idea or thoughts 
  on above > parameters in <FONT 
  size=2>> existing NATs? > <FONT 
  size=2>> Thanks, > Yutaka <FONT 
  size=2>> > > 
  _______________________________________________ > 
  Ietf-behave mailing list > 
  Ietf-behave@xxxxxxxxxxxxxxxxxxx > <A 
  href="https://list.sipfoundry.org/mailman/listinfo/ietf-behave" 
  target=_blank>https://list.sipfoundry.org/mailman/listinfo/ietf-behave 

  _______________________________________________Ietf-behave mailing 
  listIetf-behave@xxxxxxxxxxxxxxxxxxxhttps://list.sipfoundry.org/mailman/listinfo/ietf-behave

---

From: Dan Wing <[email-masked]>
Date: Wed, 24 Nov 2004 16:02:46 -0800 (PST)

ICMP type=3, code=2 is "protocol unreachable" which most closely 
indicates the problem the NAT is attempting to communicate.  However, 
code=2 can only be sent by the destination host.  So ICMP type=3, 
code=0 "net unreachable" is probably best.

-d

On Nov 24, 2004, at 3:04 PM, yutaka_takeda@xxxxxxxxxxxxxxxxxxxx wrote:

If number of simultaneous connections per binding exceeds what a NAT 
can have, the NAT might either overwrite an existing binding for a new 
connection or do nothing with the new connection, and there is no way 
for an application to know what is going on... this is the problem. I 
think Teredo is a good example, which encapsulates multiple IPv6 
TCP/UDP connection to many remote hosts on a single IPv4 UDP socket 
binding assuming that a NAT can have enough number of connections on a 
single binding (especially when NB=AD or APD). I feel at least in such 
a case the NAT could send a new ICMP error like "Too many connections" 
back to a connecting node, IMHO.
 
Yutaka
 
----- Original Message -----
 From: Francois Audet
To: Yutaka_Takeda@xxxxxxxxxxxxxxxxxxxx ; 
'ietf-behave@xxxxxxxxxxxxxxxxxxx'
Sent: Friday, November 19, 2004 3:57 PM
Subject: RE: [Ietf-behave] Maximum number of binding