Subject: RE: [Ietf-behave] NAT behave draft

From: "Francois Audet" <[email-masked]>
Date: Wed, 11 Aug 2004 15:20:10 -0700 (PDT)

So you are advocating the same logic for TCP as UDP?

> -----Original Message-----
> From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
> [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of 
> Geoff Huston
> Sent: Wednesday, August 11, 2004 15:16
> To: Jiri Kuthan; 'ietf-behave@xxxxxxxxxxxxxxxxxxx'
> Subject: RE: [Ietf-behave] NAT behave draft
> 
> 
> Bidirectional, as I understand it in the context of the 
> draft, means that an inbound packet or an outbound packet 
> will refresh the binding expiration timer.
> 
> You are right that in must circumstances TCP follows a packet 
> in one direction with a packet in the other, so in the case 
> of TCP the three options produce a very similar outcome.
> 
> On thinking about this some more, the circumstances where 
> this would _not_ 
> happen
> are when one end has closed its connection but the other has 
> not. In this case I guess that the safest action for the NAT 
> is to use outbound as the binding expiration timer trigger 
> for TCP. i.e. the binding will expire once the 'internal' 
> host has closed its TCP state, even if the external end 
> continues to direct packets to the closed session.
> 
>     Geoff

---

From: Geoff Huston <[email-masked]>
Date: Wed, 11 Aug 2004 17:41:41 -0700 (PDT)

In short, yes I am.

  regards,

    Geoff

At 08:18 AM 12/08/2004, Francois Audet wrote:

> From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx
[<mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx>mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] 
On Behalf Of