Subject: [Ietf-behave] Conflicting Error Codes

From: "Peter Livesey" <[email-masked]>
Date: Fri, 30 Jun 2006 01:48:45 -0700 (PDT)

Rohan, 

There is a clash of error codes between the base STUN (well draft 03) and the 
TURN usage (turn-01). 

In 3489bis error 437 indicates a "stale nonce", this clashes with the "no 
binding" error in turn-01. It could be confusing to a client who receives an 
error response to an authenticated SetActiveDestination request. Did the 
request fail due to the binding not being there or because the authentication 
failed? I guess in the stale nonce case the error response would contain 
another nonce, but would it not be cleaner to not have to do this?

Forgive me if this is already being addressed in the next revision of 
rfc3489bis.

Cheers,

Pete L.

Peter Livesey 
Senior Software Engineer 
Phone: 
+441189348712
Fax: 
+441189348716
Video: 
peter.livesey@xxxxxxxxxxxxxxxxxx
E-mail: 
peter.livesey@xxxxxxxxxxxx
Video Phone: 
+441189348712
Unit 8a Castle End Business Park, Castle End Road
Ruscombe, Berkshire RG10 9XQ, United Kingdom

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 5 Jul 2006 14:10:05 -0700 (PDT)

This is an error in the stun spec, which has been corrected to use 438 
for stale nonce.

-Jonathan R.

Peter Livesey wrote:

Rohan, 

There is a clash of error codes between the base STUN (well draft 03) and the TURN usage (turn-01). 

In 3489bis error 437 indicates a "stale nonce", this clashes with the "no binding" error in turn-01. It could be confusing to a client who receives an error response to an authenticated SetActiveDestination request. Did the request fail due to the binding not being there or because the authentication failed? I guess in the stale nonce case the error response would contain another nonce, but would it not be cleaner to not have to do this?

Forgive me if this is already being addressed in the next revision of rfc3489bis.

Cheers,

Pete L.

Peter Livesey 
Senior Software Engineer 
Phone: 
+441189348712
Fax: 
+441189348716
Video: 

_______________________________________________
Ietf-behave mailing list
Ietf-behave@xxxxxxxxxxxxxxxxxxx
https://list.sipfoundry.org/mailman/listinfo/ietf-behave
--
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
jdrosen@xxxxxxxxx                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com