Subject: RE: [Ietf-behave] Idealized UDP/TCP port bindings

From: "Senthil Sivakumar (ssenthil)" <[email-masked]>
Date: Thu, 22 Dec 2005 08:22:25 -0800 (PST)

The port space for TCP and UDP are not shared from a NAT's perspective
and I don't think there is any advantage of preserving the port mapping
between the protocols. Also, if there are applications that require this
then it would the Application Layer gateways that would be required to
preserve the same port for both TCP and UDP.

Senthil

> -----Original Message-----
> From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
> [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of 
> Dave Hudson
> Sent: Wednesday, December 21, 2005 7:16 AM
> To: ietf-behave@xxxxxxxxxxxxxxxxxxx
> Subject: [Ietf-behave] Idealized UDP/TCP port bindings
> 
> I can't recall having seen any discussion of this so I 
> thought I'd ask the question...
> 
> If I have a port mapping within a NAT where private address 
> and port A:P maps to a public address and port A':P' is there 
> any advantage to having the mapping of P -> P' be the same 
> for both UDP and TCP?  (e.g. if I have an private port 12345 
> which maps to a public port 9977 for UDP does it help if 
> 12345 also maps to 9977 for TCP as opposed to some other 
> mapping, say, 11111?).  I'm assuming here that the NAT 
> exhibits endpoint independent mapping.
> 
> 
> Thanks,
> Dave
> _______________________________________________
> Ietf-behave mailing list
> Ietf-behave@xxxxxxxxxxxxxxxxxxx
> https://list.sipfoundry.org/mailman/listinfo/ietf-behave
>

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 13 Jan 2006 11:45:03 -0800 (PST)

I agree with Pyda and Senthil here - I think UPD ports are a separate space
from TCP ports and should not be related. As a side note, I have heard about
a NAT that actually does this but most don't.