Subject: RE: [Ietf-behave] FW: I-D ACTION:draft-ietf-behave-nat-udp-02.txt

From: "Francois Audet" <[email-masked]>
Date: Thu, 30 Jun 2005 17:12:46 -0700 (PDT)

I am OK with your proposed clarification for REQ-11, which is basically
to change the
term "support ICMP Destination Unreachable" terminology with "support
ICMP processing".

I'm also OK with your alternative with the explicit sub-bullets.

Dan, you wrote this. Are you OK with the suggestion?

> -----Original Message-----
> From: Saikat Guha [mailto:sg266@xxxxxxxxxxx] 
> Sent: Thursday, June 30, 2005 15:17
> To: Audet, Francois [SC100:9T51:EXCH]
> Cc: 'Behave'
> Subject: Re: [Ietf-behave] FW: I-D 
> ACTION:draft-ietf-behave-nat-udp-02.txt
> 
> 
> On Wed, 2005-06-29 at 13:32 -0400, Francois Audet wrote:
> > I want to draw the attention of the group to the
> > new issue of the UDP draft.
> 
> Few notes ... some from dangling threads and some new 
> (so there is one place to look up the issues)
> 
> 1) (old) -- REQ7a. 
> 'nuff said. 
> 
> 
> 2) (old) -- Clarification:
> The ICMP timeout in REQ-11a is still unclear to me. I realize 
> Cullen is on vacation. Just a reminder.
> 
> 
> 3) (new) -- Confusing terminology:
> >   REQ-11: It is RECOMMENDED that a NAT support ICMP Destination
> >     Unreachable.
> 
> At first glance, I seems this just asks the NAT to support 
> ICMP Type=3 (Type=3 is Destination Unreachable). 
> 
> As defined earlier, however, "Support Destination 
> Unreachable" actually means "A NAT which performs the 
> functions described in [section 9]" which includes "Receipt 
> of *any* sort of ICMP message MUST NOT destroy the NAT 
> mapping." (emphasis mine). It seems unclear if REQ-11 is for 
> all ICMPs or just Destination unreachable.
> 
> In any case, changing the terminology to "Support ICMP 
> Translations" or "Support ICMP Processing" etc would avoid 
> this confusing. Also, if you really meant just ICMP 
> Destination Unreachable in REQ-11, then the other 
> requirements from the paragraph should also be summarized:
> 
> REQ-11: Receipt of any sort of ICMP message MUST NOT destroy the NAT
>    mapping.
>     a) The NAT's default configuration SHOULD NOT filter ICMP messages
>        based on their source IP address.
>     b) It is RECOMMENDED that a NAT support ICMP Destination 
>        Unreachable messages.
>     c) The ICMP timeout SHOULD be greater than 2 seconds.
> 
> or more concisely as,
> 
> REQ-11: It is RECOMMENDED that a NAT support ICMP Processing.
>     a) The ICMP timeout SHOULD be greater than 2 seconds.
> 
> 
> -- 
> Saikat
>

---

From: "Cullen Jennings" <[email-masked]>
Date: Sun, 31 Jul 2005 03:31:31 -0700 (PDT)

I'm not - testing indicates that many devices today do not allow all ICMP
packets. Look the only thing so far identified that we need is destination
unreachable so that path MTU works. The goals here is not to define how we
wished NATs were implemented. It is to define the minimal behavior that we
need to them change such that a wide range of applications are possible.
Unless someone has a good reason by we need ICMP processing (which is
encouraged) instead of ICMP Dest. Unreach, I see no reason to add it in.

Cullen <not as chair>

-----Original Message-----
From: Francois Audet [mailto:audet@xxxxxxxxxx]
Sent: Friday, July 01, 2005 2:13 AM
To: Saikat Guha; dwing@xxxxxxxxx; Cullen Jennings
Cc: Behave
Subject: RE: [Ietf-behave] FW: I-D ACTION:draft-ietf-behave-nat-udp-02.txt

I am OK with your proposed clarification for REQ-11, which is basically to
change the term "support ICMP Destination Unreachable" terminology with
"support ICMP processing".

> > I want to draw the attention of the group to the new issue of the
> > UDP draft.
>
> Few notes ... some from dangling threads and some new (so there is one
> place to look up the issues)
>
> 1) (old) -- REQ7a.
> 'nuff said.
>
>
> The ICMP timeout in REQ-11a is still unclear to me. I realize Cullen
> is on vacation. Just a reminder.
>
>
> At first glance, I seems this just asks the NAT to support ICMP Type=3
> (Type=3 is Destination Unreachable).
>
> As defined earlier, however, "Support Destination Unreachable"
> actually means "A NAT which performs the functions described in
> [section 9]" which includes "Receipt of *any* sort of ICMP message
> MUST NOT destroy the NAT mapping." (emphasis mine). It seems unclear
> if REQ-11 is for all ICMPs or just Destination unreachable.
>
> In any case, changing the terminology to "Support ICMP Translations"
> or "Support ICMP Processing" etc would avoid this confusing. Also, if
> you really meant just ICMP Destination Unreachable in REQ-11, then the
> other requirements from the paragraph should also be summarized:
>