Subject: RE: [Ietf-behave] Applicability statement in the UDP draft

From: "Francois Audet" <[email-masked]>
Date: Fri, 8 Jul 2005 19:30:55 -0700 (PDT)

> -----Original Message-----
> From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
> [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of 
> Pyda Srisuresh
> Sent: Friday, July 08, 2005 07:24
> To: Behave
> Subject: [Ietf-behave] Applicability statement in the UDP draft 
> 
> 
> Francois,
> 
> In section 1, titled "applicability Statement", you state the 
> following.
> 
>    The requirements of this specification apply generally to all NAT
>    variations, including the ones described in RFC 2663 [3] 
> (Traditional
>    NAT, Basic NAT, NAPT, Bi-directional NAT, Twice NAT, and Multihomed
>    NATs).  However, it is not within the scope of this 
> specification to
>    address all issues specific to all possible NAT variations.
> 
> Yet, in section 3, you state:
> 
>                           In this specification, the term "NAT" refers
>    to both "Basic NAT" and "Network Address/Port Translator (NAPT)".
> 
> For the reminder of the document, you use the above 
> definition for NAT in deriving the Behave requirements. 
> 
> If the scope of applicability is beyond Traditional NATs, 
> then the requirements do not do justice to that, as they 
> assume traditional NAT. 

You are correct. We are looking at Traditional NAT only. That section 1 
comment will be modified.

> You will need to spell out which of 
> the requirements are generic and which are specific to Basic 
> NAT and/or NAPT.

> cheers,
> suresh
> 
> 
> 
> 
> _______________________________________________
> Ietf-behave mailing list
> Ietf-behave@xxxxxxxxxxxxxxxxxxx 
> https://list.sipfoundry.org/mailman/listinfo/ietf-behave
> 
>

---

From: Pyda Srisuresh <[email-masked]>
Date: Sun, 10 Jul 2005 01:52:15 -0700 (PDT)

> comment will be modified.
[suresh] Well, the WG charter refers to NATs in general and does not restrict
to Traditional NATs. Perhaps, the WG chairs can make the call on what the scope
of the drafts should be.

cheers,
suresh

---

From: "Cullen Jennings" <[email-masked]>
Date: Sun, 31 Jul 2005 03:31:34 -0700 (PDT)

The scope was NATs.

Cullen

-----Original Message-----
From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx
[mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Pyda Srisuresh
Sent: Sunday, July 10, 2005 10:52 AM
To: Francois Audet; Behave
Subject: RE: [Ietf-behave] Applicability statement in the UDP draft

--- Francois Audet <audet@xxxxxxxxxx> wrote:

> > [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Pyda
> > Srisuresh
> >    NATs).  However, it is not within the scope of this specification
> > to
> > For the reminder of the document, you use the above definition for
> > NAT in deriving the Behave requirements.
> >
> > If the scope of applicability is beyond Traditional NATs, then the
> > requirements do not do justice to that, as they assume traditional
> > NAT.
>
> You are correct. We are looking at Traditional NAT only. That section
> 1 comment will be modified.
>
[suresh] Well, the WG charter refers to NATs in general and does not
restrict to Traditional NATs. Perhaps, the WG chairs can make the call on
what the scope of the drafts should be.

cheers,
suresh

> > You will need to spell out which of the requirements are generic and
> > which are specific to Basic NAT and/or NAPT.
>
>
>
> > cheers,
> > suresh
> >
> >
> >
> >