Subject: RE: [Ietf-behave] New draft on UDP unicast behavior

From: "Francois Audet" <[email-masked]>
Date: Wed, 20 Oct 2004 16:50:50 -0700 (PDT)

OK, I think we have concensus on the following.

11 - Requirements

   REQ-3c:  If the host's source port was in the range 0-1023, 
                the NAT's source port must also be in the same range.  
                If the host's source port was in the range 1024-65535, 
                the NAT's source port must also be in that range.

REQ-10:  If a NAT includes ALGs, all of those ALGs MUST be
         disabled by default.
 
    REQ-10a:  If a NAT includes ALGs, it is RECOMMENDED that
              the NAT allow the user to enable or disable each
              ALG separately.  

11.1 - Requirements discussion

   REQ-3c:  Certain applications expect the source UDP port to be
            in the well-known range. See RFC 2623 for an example.

REQ-10:  NAT ALGs may interfere with UNSAF methods.
 
    REQ-10a:  This requirement allows the user
              to enable ALGs which are necessary to aid operation
              of some applications without enabling ALGs which
              interfere with operation of other applications.

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 20 Oct 2004 17:02:32 -0700 (PDT)

<FONT face=Verdana color=#0000ff 
size=2>Looks good to me.  
<FONT face=Verdana color=#0000ff 
size=2> 
<FONT face=Verdana color=#0000ff 
size=2>-d
 
<BLOCKQUOTE dir=ltr 
style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #0000ff 2px solid; MARGIN-RIGHT: 0px">
  <FONT face=Tahoma 
  size=2>-----Original Message-----From: Francois Audet 
  [mailto:audet@xxxxxxxxxxxxxxxxxx]Sent: Wednesday, October 20, 2004 
  4:51 PMTo: 'Senthil Sivakumar'; 'Dan Wing'Cc: 
  'Behave'Subject: RE: [Ietf-behave] New draft on UDP unicast 
  behavior 
  OK, I think we have concensus on the following. 
  11 - Requirements 
     REQ-3c:  If the host's source port was in 
  the range 0-1023,         
          the NAT's source port 
  must also be in the same range.  
          
          If the host's source 
  port was in the range 1024-65535, 
          
          the NAT's source port 
  must also be in that range. 
  REQ-10:  If a NAT includes ALGs, all of those ALGs MUST 
  be          
  disabled by default.   <FONT 
  size=2>    REQ-10a:  If a NAT includes ALGs, it is 
  RECOMMENDED that <FONT 
  size=2>              
  the NAT allow the user to enable or disable each <FONT 
  size=2>              
  ALG separately.  
  11.1 - Requirements discussion 
     REQ-3c:  Certain applications expect the 
  source UDP port to be <FONT 
  size=2>            in 
  the well-known range. See RFC 2623 for an example. 
  REQ-10:  NAT ALGs may interfere with UNSAF 
  methods.   <FONT 
  size=2>    REQ-10a:  This requirement allows the 
  user <FONT 
  size=2>              
  to enable ALGs which are necessary to aid operation <FONT 
  size=2>              
  of some applications without enabling ALGs which <FONT 
  size=2>              
  interfere with operation of other applications.