Subject: RE: [Ietf-behave] draft-ietf-behave-nat-00: RTP behavior descript ion

From: "Francois Audet" <[email-masked]>
Date: Fri, 29 Oct 2004 11:52:33 -0700 (PDT)

Hi Bryan,

It's out of scope of THIS document.

It's in the scope of the Application Document which we will tackle next.

> -----Original Message-----
> From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
> [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of 
> Bryan Ford
> Sent: Friday, October 29, 2004 10:30
> To: ietf-behave@xxxxxxxxxxxxxxxxxxx
> Subject: Re: [Ietf-behave] draft-ietf-behave-nat-00: RTP 
> behavior descript ion
> 
> 
> On Friday 29 October 2004 09:35, Melinda Shore wrote:
> > On Friday, October 29, 2004, at 09:22 AM, Jon Ringle wrote:
> > > Not only should there be a notion of BEHAVE-compliant 
> NATs, but also 
> > > BEHAVE-compliant applications. I don't think it's unreasonable to 
> > > say that an application is not BEHAVE-compliant if it 
> requires port 
> > > parity/+1 reservation. Such an application would become 
> > > BEHAVE-compliant once such
> > > restriction are removed by the application.
> >
> > If we could go back and change every protocol that has NAT 
> problems, 
> > it would probably make more sense to change them so that 
> they have no 
> > NAT problems rather than having a different set of NAT problems. My 
> > sense is that the working group is focused on defining a set of 
> > friendlier NAT behaviors and that defining new, desirable 
> application 
> > behavior is quite, quite, quite far out-of-scope.
> 
> It does not seem at all out of scope to me that the BEHAVE 
> group should define 
> a set of design guidelines for new or updated applications 
> that will ensure 
> that they work robustly and deterministically over 
> BEHAVE-compliant NATs.  If 
> this information is only available encoded in a form oriented 
> entirely toward 
> NAT implementors, then application protocol designers are 
> much less likely to 
> read it or to understand how to make their applications work 
> robustly over 
> NATs.  This group needs to address both sides of the equation 
> in order to 
> solve the overall problem it was formed to solve.
> 
> Bryan
> _______________________________________________
> Ietf-behave mailing list
> Ietf-behave@xxxxxxxxxxxxxxxxxxx 
> https://list.sipfoundry.org/mailman/listinfo/ietf-behave
> 
>

---

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 2 Nov 2004 05:25:14 -0800 (PST)

I am confused. This may not be news, but ...
 
Looking at the current charter for Behave, the closest thing 
to "the Application Document" that I see a milestone for is

  
    Dec 05
      
    Produce a BCP that discusses protocol design techniques 
      for using the existing set of NAT traversal approaches 

Is this the same thing (doesn't sound like it to me), or is 
"the Application Document which we will tackle next" out of scope for the 
existing charter?
 
The document being discussed below sounds more like "a BCP 
that discusses application protocol design techniques for avoiding issues with 
NAT traversal" - ALSO a worthy goal, just a different one.
 
Spencer
<BLOCKQUOTE 
style="PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
  ----- Original Message ----- 
  <DIV 
  style="BACKGROUND: #e4e4e4; FONT: 10pt arial; font-color: black">From: 
  <A title=audet@xxxxxxxxxxxxxxxxxx 
  href="mailto:audet@xxxxxxxxxxxxxxxxxx">Francois Audet 
  To: <A title=baford@xxxxxxx 
  href="mailto:baford@xxxxxxx">'Bryan Ford' ; <A 
  title=ietf-behave@xxxxxxxxxxxxxxxxxxx 
  href="mailto:'ietf-behave@xxxxxxxxxxxxxxxxxxx'">'ietf-behave@xxxxxxxxxxxxxxxxxxx' 
  
  Sent: Friday, October 29, 2004 12:52 
  PM
  Subject: RE: [Ietf-behave] 
  draft-ietf-behave-nat-00: RTP behavior descript ion
  
  Hi Bryan, 
  It's out of scope of THIS document. 
  It's in the scope of the Application Document which we will 
  tackle next. 
  > -----Original Message----- > 
  From: <A 
  href="mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx">ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx 
  > [<A 
  href="mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx">mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] 
  On Behalf Of > Bryan Ford <FONT 
  size=2>> Sent: Friday, October 29, 2004 10:30 > 
  To: <A 
  href="mailto:ietf-behave@xxxxxxxxxxxxxxxxxxx">ietf-behave@xxxxxxxxxxxxxxxxxxx 
  > behavior descript ion <FONT 
  size=2>> > > On 
  Friday 29 October 2004 09:35, Melinda Shore wrote: <FONT 
  size=2>> > On Friday, October 29, 2004, at 09:22 AM, Jon Ringle 
  wrote: > > > Not only should there be a 
  notion of BEHAVE-compliant > NATs, but also 
  > > > BEHAVE-compliant applications. I don't 
  think it's unreasonable to > > > say that an 
  application is not BEHAVE-compliant if it > 
  requires port > > > parity/+1 reservation. 
  Such an application would become > > > 
  BEHAVE-compliant once such > > > restriction 
  are removed by the application. > > 
  > > If we could go back and change every protocol that 
  has NAT > problems, > 
  > it would probably make more sense to change them so that <FONT 
  size=2>> they have no > > NAT problems rather 
  than having a different set of NAT problems. My > 
  > > friendlier NAT behaviors and that defining 
  new, desirable > application <FONT 
  size=2>> > behavior is quite, quite, quite far out-of-scope. 
  > > It does not seem at all out 
  of scope to me that the BEHAVE > group should 
  define > a set of design guidelines for new or 
  updated applications > that will ensure 
  > that they work robustly and deterministically 
  over > BEHAVE-compliant NATs.  If 
  > this information is only available encoded in a 
  form oriented > entirely toward <FONT 
  size=2>> NAT implementors, then application protocol designers are 
  > much less likely to > 
  read it or to understand how to make their applications work <FONT 
  size=2>> robustly over > NATs.  This group 
  needs to address both sides of the equation > in 
  order to > solve the overall problem it was formed 
  to solve. > > 
  Bryan > 
  _______________________________________________ > 
  Ietf-behave mailing list > 
  Ietf-behave@xxxxxxxxxxxxxxxxxxx > <A 
  href="https://list.sipfoundry.org/mailman/listinfo/ietf-behave" 
  target=_blank>https://list.sipfoundry.org/mailman/listinfo/ietf-behave 

  _______________________________________________Ietf-behave mailing 
  listIetf-behave@xxxxxxxxxxxxxxxxxxxhttps://list.sipfoundry.org/mailman/listinfo/ietf-behave