Subject: [Ietf-behave] FW: I-D ACTION:draft-ietf-behave-nat-udp-02.txt

From: "Francois Audet" <[email-masked]>
Date: Wed, 29 Jun 2005 10:33:05 -0700 (PDT)

I want to draw the attention of the group to the 
new issue of the UDP draft.

> -----Original Message-----
> From: Internet-Drafts@xxxxxxxx [mailto:Internet-Drafts@xxxxxxxx] 
> Sent: Wednesday, June 29, 2005 09:39
> To: Audet, Francois [SC100:9T51:EXCH]
> Subject: I-D ACTION:draft-ietf-behave-nat-udp-02.txt
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories. This draft is a work item of the 
> Behavior Engineering for Hindrance 
> Avoidance Working Group of the IETF.
> 
>       Title           : NAT Behavioral Requirements for Unicast UDP
>       Author(s)       : F. Audet, C. Jennings
>       Filename        : draft-ietf-behave-nat-udp-02.txt
>       Pages           : 25
>       Date            : 2005-6-28
> 
> This document defines basic terminology for describing different
>     types of NAT behavior when handling Unicast UDP, and 
> defines a set of
>     requirements that would allow many applications, such as 
> multimedia
>     communications or on-line gaming, to work consistently.  
> Developing
>     NATs that meet this set of requirements will greatly increase the
>     likelihood that these applications will function properly.
> 
> A URL for this Internet-Draft is: 
> http://www.ietf.org/internet-drafts/draft-ietf-behave-nat-udp-02.txt
> 
> To remove yourself from the I-D Announcement list, send a 
> message to i-d-announce-request@xxxxxxxx with the word 
> unsubscribe in the body 
> of the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
> 
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username "anonymous" and a password of your e-mail 
> address. After logging in, type "cd internet-drafts" and then
>       "get draft-ietf-behave-nat-udp-02.txt".
> 
> A list of Internet-Drafts directories can be found in 
> http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
>       mailserv@xxxxxxxxx
> In the body type:
>       "FILE /internet-drafts/draft-ietf-behave-nat-udp-02.txt".
> 
> NOTE: The mail server at ietf.org can return the document in
>       MIME-encoded form by using the "mpack" utility.  To use this
>       feature, insert the command "ENCODING mime" before the "FILE"
>       command.  To decode the response(s), you will need "munpack" or
>       a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
>       exhibit different behavior, especially when dealing with
>       "multipart" MIME messages (i.e. documents which have been split
>       up into multiple messages), so check your local documentation on
>       how to manipulate these messages.
> 
> 
> Below is the data which will enable a MIME compliant mail 
> reader implementation to automatically retrieve the ASCII 
> version of the Internet-Draft.
> 
> 
> [The following attachment must be fetched by mail. Command-click the 
> URL below and send the resulting message to get the 
> attachment.] 
> <mailto:mailserv@xxxxxxxx?body=ENCODING%20mime%0D%0AFILE%20/in
ternet-drafts/draft-ietf-behave-nat-udp-02.txt>
[The following attachment must be fetched by ftp.  Command-click the 
URL below to ask your ftp client to fetch it.] <ftp://ftp.ietf.org/internet-drafts/draft-ietf-behave-nat-udp-02.txt>
_______________________________________________
I-D-Announce mailing list
I-D-Announce@xxxxxxxx https://www1.ietf.org/mailman/listinfo/i-d-announce

---

From: David Barrett <[email-masked]>
Date: Wed, 29 Jun 2005 14:12:42 -0700 (PDT)

Can you explain to me the relation between the BEHAVE draft and this 
one?  There seems to be a very high degree of overlap, and some direct 
conflicts.  Which one speaks "for the IETF"?  For example I couldn't 
help but note the first requirement:

   REQ-1: A NAT MUST have an "External NAT mapping is endpoint
      independent" behavior.
This is taking a *much* stronger position than BEHAVE draft.  Whether 
one agrees or disagrees with this individual requirement, I think we can 
all agree that it's best to have one set of NAT requirements rather than 
fragmenting into different drafts.

-david

Francois Audet wrote:
ternet-drafts/draft-ietf-behave-nat-udp-02.txt>
[The following attachment must be fetched by ftp.  Command-click the
URL below to ask your ftp client to fetch it.] 
<ftp://ftp.ietf.org/internet-drafts/draft-ietf-behave-nat-udp-02.txt>
_______________________________________________
I-D-Announce mailing list
I-D-Announce@xxxxxxxx https://www1.ietf.org/mailman/listinfo/i-d-announce

------------------------------------------------------------------------

_______________________________________________
Ietf-behave mailing list
Ietf-behave@xxxxxxxxxxxxxxxxxxx
https://list.sipfoundry.org/mailman/listinfo/ietf-behave

---

From: Saikat Guha <[email-masked]>
Date: Thu, 30 Jun 2005 15:20:37 -0700 (PDT)

> new issue of the UDP draft.

Few notes ... some from dangling threads and some new 
(so there is one place to look up the issues)

1) (old) -- REQ7a. 
'nuff said. 

2) (old) -- Clarification:
The ICMP timeout in REQ-11a is still unclear to me. I realize Cullen is
on vacation. Just a reminder.

3) (new) -- Confusing terminology:
>   REQ-11: It is RECOMMENDED that a NAT support ICMP Destination
>     Unreachable.

At first glance, I seems this just asks the NAT to support ICMP Type=3
(Type=3 is Destination Unreachable). 

As defined earlier, however, "Support Destination Unreachable" actually
means "A NAT which performs the functions described in [section 9]"
which includes "Receipt of *any* sort of ICMP message MUST NOT destroy
the NAT mapping." (emphasis mine). It seems unclear if REQ-11 is for all
ICMPs or just Destination unreachable.

In any case, changing the terminology to "Support ICMP Translations" or
"Support ICMP Processing" etc would avoid this confusing. Also, if you
really meant just ICMP Destination Unreachable in REQ-11, then the other
requirements from the paragraph should also be summarized:

REQ-11: Receipt of any sort of ICMP message MUST NOT destroy the NAT
   mapping.
    a) The NAT's default configuration SHOULD NOT filter ICMP messages
       based on their source IP address.
    b) It is RECOMMENDED that a NAT support ICMP Destination 
       Unreachable messages.
    c) The ICMP timeout SHOULD be greater than 2 seconds.

or more concisely as,

REQ-11: It is RECOMMENDED that a NAT support ICMP Processing.
    a) The ICMP timeout SHOULD be greater than 2 seconds.

-- 
Saikat
Attachment:
signature.asc