Subject: [Ietf-behave] ICMP Behavior

From: Cullen Jennings <[email-masked]>
Date: Mon, 25 Oct 2004 06:59:07 -0700 (PDT)

What do we want the document about ICMP handling in NATs to say?

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 25 Oct 2004 14:05:56 -0700 (PDT)

I'm not sure how we could separate ICMP handling from the handling of
TCP, UDP, SCTP, IPsec, ...?

-d

> -----Original Message-----
> From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx
> [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx]On Behalf Of Cullen
> Jennings
> Sent: Monday, October 25, 2004 6:56 AM
> To: Behave
> Subject: [Ietf-behave] ICMP Behavior
> 
> 
> 
> _______________________________________________
> Ietf-behave mailing list
> Ietf-behave@xxxxxxxxxxxxxxxxxxx
> https://list.sipfoundry.org/mailman/listinfo/ietf-behave

---

From: Senthil Sivakumar <[email-masked]>
Date: Mon, 25 Oct 2004 14:24:55 -0700 (PDT)

My suggestions would be to address the following:
1. ICMP identifier being used as identifiers for demux in pings.
How should we handle them? Any different than TCP/UDP ports?
2. ICMP Error handling by NATs. Handling the embedded IP/TCP/UDP
headers.
3. What ICMP errors MUST and SHOULD be handled by NATs?

4. Timer handling for ICMP. Whether to refresh the timer for the outside to
inside echo req/replies?
Senthil

At 06:56 AM 10/25/2004 -0700, Cullen Jennings wrote: