Subject: [Ietf-behave] Ietf-behave] Re: NATting SCTP

From: "Luca Laurenzi" <[email-masked]>
Date: Tue, 1 Feb 2005 07:02:13 -0800 (PST)

If i want to map multiple IP 
addresses to a single IP adress, using a NAPT mechanism:

HOST A+<FONT 
face=Arial>-----------------------N
<FONT face=Arial 
size=2>                                     A--E+-------------cloud------------------+--HOST 
Z
HOST 
B+---------------------- P                 
<FONT 
face=Arial>                                     
T
 
if HOST A sends a 
packet:

----->From 
IP-A(port:2222)---------To:IPZ:port-80---------->
 
Napt gets it and makes:
 
----->From 
IP-E(port:9999)---------To:IPZ:port-80----------->

if HOST B sends a 
packet:
 
----->From 
IP-B(port:1111)---------To:IPZ:port-80----------->
 
Napt gets it and makes:
 
----->From 
IP-E(port:8888)---------To:IPZ:port-80----------->
 
A NAPT table will map internal IP 
addresses to a single external IP address E.
 NAPT table also create an 
unique correspondence: HOST IP /<FONT 
face=Arial size=2> source port number,
 (i.e. 2222 <----> IP A), chosing a 
port number, whitin a set of actually 
availables port numbers, 
(..on the fly..).
 
This works, to multiplex/demultiplex 
packets from/to NAPT device, if i have hosts 
that are sharing
 a single external IP address. 
(the traditional NAPT mechanism...)
 
But..
If i have a multihomed host, working whit SCTP, i 
can't do this!!
 
RFC3257 says "..If Network Address Port 
Translation is used with a multihomed SCTP   endpoint, then any 
port translation must be applied on a perassociation basis such that an 
SCTP
 endpoint continues to receive the same 
port number for all messages within a given association..."
 
What does it means?..if i can't change source port 
number whitin a gived association,
NAPT "will have to multiplex using something other 
than the SCTP port number"?..
<FONT 
face="Courier New"><FONT 
face="Courier New"><FONT 
face="Courier New"><FONT 
face="Courier New"><FONT 
face="Courier New"><FONT 
face="Courier New">

---

From: Qiaobing Xie <[email-masked]>
Date: Tue, 1 Feb 2005 12:45:13 -0800 (PST)

Hi, Luca,

Luca Laurenzi wrote:

If i want to map multiple IP addresses to a single IP adress, using a 
NAPT mechanism:
 
HOST A+-----------------------N
                              A--E+-------------cloud------------------+--HOST Z
HOST B+---------------------- P                 
                              T
In SCTP, the multiple IP addresses should belong to a single HOST and share a single port. 
Please revise your example and see if you still have problems.

regards,
-Qiaobing

if HOST A sends a packet:

----->From IP-A(port:2222)---------To:IPZ:port-80---------->
 
Napt gets it and makes:
 
----->From IP-E(port:9999)---------To:IPZ:port-80----------->

if HOST B sends a packet:
 
----->From IP-B(port:1111)---------To:IPZ:port-80----------->
 
Napt gets it and makes:
 
----->From IP-E(port:8888)---------To:IPZ:port-80----------->
 
A NAPT table will map internal IP addresses to a single external IP 
address E.
 NAPT table also create an unique correspondence: HOST IP / source port 
number,
 (i.e. 2222 <----> IP A), chosing a port number, whitin a set of 
actually availables port numbers,
(..on the fly..).
 
This works, to multiplex/demultiplex packets from/to NAPT device, if i 
have hosts that are sharing
 a single external IP address. (the traditional NAPT mechanism...)
 
But..
If i have a multihomed host, working whit SCTP, i can't do this!!
 
RFC3257 says "..If Network Address Port Translation is used with a 
multihomed SCTP
   endpoint, then any port translation must be applied on a 
perassociation basis such that an SCTP
 endpoint continues to receive the same port number for all messages 
within a given association..."
 
What does it means?..if i can't change source port number whitin a gived 
association,
NAPT "will have to multiplex using something other than the SCTP port 
number"?..

------------------------------------------------------------------------

_______________________________________________
Ietf-behave mailing list
Ietf-behave@xxxxxxxxxxxxxxxxxxx
https://list.sipfoundry.org/mailman/listinfo/ietf-behave