Subject: RE: [Ietf-behave] Twice NAT _must_ be in-scope

From: "Francois Audet" <[email-masked]>
Date: Fri, 10 Dec 2004 13:08:44 -0800 (PST)

Basically, the point is that the requirements in this document is
applicable to NATs that support Twice-NAT and Static NAT.

I agree with that.

What we don't want to do in this document is talk about 
Twice-NAT or Static NAT specific aspects. 

> -----Original Message-----
> From: Cullen Jennings [mailto:fluffy@xxxxxxxxx] 
> Sent: Friday, December 10, 2004 10:50
> To: Pyda Srisuresh; Audet, Francois [SC100:9T51:EXCH]; 
> Jonathan Rosenberg
> Cc: 'Bryan Ford'; Behave
> Subject: Re: [Ietf-behave] Twice NAT _must_ be in-scope
> 
> 
> On 12/9/04 6:25 PM, "Pyda Srisuresh" <srisuresh@xxxxxxxxx> wrote:
> 
> > Cullen,
> > 
> > You make a good point. However, BEHAVE recommendations is not all 
> > about static/dynamic port bindings. For example, the UDP 
> behave draft 
> > recommends support for hairpin behavior. The draft also recommends 
> > support for IP fragmentation. Why should static NATs be 
> excluded for 
> > these and other such requirements?
> > 
> > regards,
> > suresh
> 
> Yes I agree with you that various things types of NATs may 
> want to do many of the same things. I just don't want to take 
> on, in this document, describing all the things one might 
> want to do on a twice-nat to give applications the best odds 
> of working. You make a good point that fragmentation and 
> loopback are examples of things that all NATs might want to 
> deal with in a similar way. Just trying to take this in small 
> bite size pieces. 
> 
> 
>

---

From: Pyda Srisuresh <[email-masked]>
Date: Fri, 10 Dec 2004 17:57:41 -0800 (PST)

Agreed. It is not the objective of the draft to describe NAT types. But, it is
the objective of the draft to provide behavioral recommendaations for the known
NAT types.

regards,
suresh

> > deal with in a similar way. Just trying to take this in small 

=====