Subject: RE: [Ietf-behave] TCP without relays

From: "Francois Audet" <[email-masked]>
Date: Mon, 11 Oct 2004 09:29:39 -0700 (PDT)

> The main point to notice here is that what is happening is 
> really _exactly_ 
> the same as for UDP hole punching, just using TCP instead, 
> with a lot of help 
> from the SO_REUSEADDR/SO_REUSEPORT options.  Which is really 
> what we want.  
> And the success of this trick for TCP depends on _exactly_ the same 
> conditions as the success of the trick for UDP (namely cone 
> NAT behavior), 
> with the minor additional proviso that firewalls must simply drop 
> unrecognized incoming SYNs on the floor and not send back 
> RSTs.  Which 
> apparently a lot of firewalls if not most already do.

I assume that likewise, we have the same limitations with "symmetric
NATs" as we have with UDP, right?

---

From: Bryan Ford <[email-masked]>
Date: Mon, 11 Oct 2004 10:03:23 -0700 (PDT)

> NATs" as we have with UDP, right?

Exactly.  Symmetric NAT == EVIL.

Bryan