Subject: RE: [Ietf-behave] Question about draft-ietf-behave-nat-udp-04 in a P2P application

From: "Matthews, Philip (Philip)" <[email-masked]>
Date: Wed, 21 Dec 2005 08:28:42 -0800 (PST)

Suresh:

Thanks very much for replying with your pointer
and reminding me about draft-ford-behave-app-01.

I took a quick look through draft-ford-behave-app-01.txt and
in addition to the text you quote below, I saw the following
statement:

   BEHAVE-compliant NATs are required to support Address Restricted 
   Cone NAT Behavior, which essentially resets the idle timer for ALL
   sessions for a particular binding (i.e., involving a particular
   private port) whenever outbound traffic is seen from that private
   port on ANY such session.

What is the justification for this statement? 

That is, where in draft-ietf-behave-nat-udp-04 is a statement to this
effect made?

Given that draft-ford-behave-app-01 is not yet a WG document,
I think it would be good to have some statement in
draft-ietf-behave-nat-udp-04.

- Philip

> -----Original Message-----
> From: Pyda Srisuresh [mailto:srisuresh@xxxxxxxxx] 
> Sent: December 21, 2005 11:16
> To: Matthews, Philip (Philip)
> Cc: ietf-behave@xxxxxxxxxxxxxxxxxxx
> Subject: Re: [Ietf-behave] Question about 
> draft-ietf-behave-nat-udp-04 in a P2P application
> 
> Philip,
> 
> The application design guideline draft, 
> <draft-ford-behave-app-01.txt> has the
> following in section 3.1 to address your question. Hope this helps. 
> 
> REQ-6  Applications wishing to accept connections from other peers
>        after registering via UDP with one or more rendezvous servers
>        MUST send periodic outgoing UDP "keep-alive" packets to at
>        least one rendezvous server, at least once within the 
>        BEHAVE-compliant NAT UDP timeout (2 minutes).
> 
> cheers,
> suresh
> 
> --- "Matthews, Philip (Philip)" <matthewsp@xxxxxxxxx> wrote:
> 
> > Francois and Cullen:
> > 
> > I have a question about the behavior of a NAT "N" that is compliant
> > with draft-ietf-behave-nat-udp-04.
> > 
> > Say that NAT N implements the more stringent filtering behaviour of
> > "Address dependent filtering" (REQ-8), and say that, despite this,
> > I am trying to write a peer-to-peer application A which is located
> > behind NAT N and which maintains UDP connections with 20 other peers
> > B,C,D,....
> > Application A uses the same address and port for all these 
> connections.
> > 
> > To maintain the appropriate bindings in NAT "N", so that 
> application A
> > can receive
> > packets from each of these peers, must application A send a 
> UDP packet
> > to all 20 peers B,C,D,... every 2 minutes, or can 
> application A send a
> > UDP packet
> > to just one of these peers every 2 minutes?
> > 
> > (For simplicity, assume NAT "N" has a "NAT inbound refresh 
> behavior" of
> > False).
> > 
> > I am hoping, of course, that a packet every 2 minutes to 
> just ONE peer
> > will be
> > sufficient to maintain all these mappings. However, I cannot seem to
> > find any
> > words one way or another about this in the document. Am I missing
> > something?
> > 
> > - Philip
> > 
> > _______________________________________________
> > Ietf-behave mailing list
> > Ietf-behave@xxxxxxxxxxxxxxxxxxx
> > https://list.sipfoundry.org/mailman/listinfo/ietf-behave
> > 
> 
> 
> 
>

---

From: Pyda Srisuresh <[email-masked]>
Date: Wed, 21 Dec 2005 09:03:58 -0800 (PST)

> and reminding me about draft-ford-behave-app-01.
[suresh] I wasnt reminding you. I was giving you a pointer.

> That is, where in draft-ietf-behave-nat-udp-04 is a statement to this
[suresh] Sure, It would be useful to have a statement to this effect or
otherwise in the UDP draft.

cheers,
suresh