Subject: RE: AW: [Ietf-behave] Ietf-behave] Re: NATting SCTP

From: Schruefer Wolfgang <[email-masked]>
Date: Thu, 17 Feb 2005 15:07:26 -0800 (PST)

Qiaobing,

please see inline ... 

> -----Original Message-----
> From: Qiaobing Xie [mailto:Qiaobing.Xie@xxxxxxxxxxxx] 
> Sent: Thursday, February 17, 2005 11:45 PM
> To: Schruefer Wolfgang
> Cc: 'Randall Stewart'; Luca Laurenzi; Ietf-behave@xxxxxxxxxxxxxxxxxxx
> Subject: Re: AW: [Ietf-behave] Ietf-behave] Re: NATting SCTP
> 
> Wolfgang,
> 
> ...
> > Example:
> > 
> > - A client application on host X needs Interface redundancy, 
> >   but unfortunately SCTP can not establish a multihomed 
> Association due to NAPT... 
> > - I assume this NAPT box is able to handle SCTP like TCP ...
> > 
> >   
> >    SCTP   (A1, Port P)----- NAPT(A2,P1)----cloud               SCTP  (here 
> > single
> >    HOST                                    cloud------------+--HOST   homed 
> > for 
> >     X     (B1, Port P)----- NAPT(B2,P2)----cloud                Z     
> > easier drawing....)
> >    
> > 
> > - The application is smart: it creates 2 singled homed associations:
> >   a primary association containing Addr A as Source Address 
> and a secondary containing Addr B as Source Address.
> > - If Association A fails, the application continues data 
> transfer using association B.
> 
> You are talking about failover from one SCTP association to 
> another. This is covered in 
> RSERPOOL, not SCTP.

Please see it as an example how easy multihoming might work over NAPT ... 

I thought RSERPOOL covers a failover of different Hosts, not a failover of 
redundant associations between the same hosts ...

Wolfgang

> 
> regards,
> -Qiaobing
> 
> > 
> > And you see: The application has a multihoming 
> functionality, it uses SCTP and it is behind a NAPT!
> > 
> > **********************************************
> > 
> > My vision:
> > If the application can realize multihoming, SCTP should be 
> able to do it also. Probably better. 
> > 
> > My question:
> > Why is impossible and a fundamental change to implement 
> this application logic within SCTP??? 
> > 
> > 
> > Best regards,
> > Wolfgang
> 
>

---

From: Qiaobing Xie <[email-masked]>
Date: Thu, 17 Feb 2005 15:50:02 -0800 (PST)

Wolfgang,

...
I thought RSERPOOL covers a failover of different Hosts, not a failover of redundant associations between the same hosts ...
Nope. RSERPOOL covers failover among different endpoints. They can of cause be on the same host.

regards,
-Qiaobing