Subject: RE: [Ietf-behave] WG last call: draft-ietf-behave-nat-udp-01.txt

From: "Francois Audet" <[email-masked]>
Date: Thu, 12 May 2005 12:38:15 -0700 (PDT)

I have strong objections to reverse the decision to go 
ahead with separate documents.

> -----Original Message-----
> From: Bryan Ford [mailto:baford@xxxxxxx] 
> Sent: Thursday, May 12, 2005 12:21
> To: ietf-behave@xxxxxxxxxxxxxxxxxxx
> Cc: Audet, Francois [SC100:9T51:EXCH]; 'Pyda Srisuresh'
> Subject: Re: [Ietf-behave] WG last call: 
> draft-ietf-behave-nat-udp-01.txt
> 
> 
> On Thursday 12 May 2005 12:34, Francois Audet wrote:
> > This is the charter:
> > [...]
> > Seems pretty clear to me.
> >
> > The decision to split the document into smaller more 
> manageable chunks 
> > was made in IETF 62.
> 
> Copy-and-pasting the original milestone list from the BEHAVE 
> group home page 
> and repeatedly pointing back to well-known early WG decisions 
> that nobody is 
> disputing does absolutely nothing to address the issues 
> actually being 
> discussed.  Nobody is disputing the original decision "to 
> split the document 
> into smaller more manageable chunks"; we are proposing to 
> take this decision 
> further and split the common parts of the UDP and TCP 
> documents into a 
> separate "more manageable chunk".  Nobody is contesting what 
> the original 
> milestones _were_; we are talking about what they _should be_ 
> now that 
> substantial work has been done and the interrelationships between the 
> documents to be produced has become clearer.
> 
> > I will also point out that we are actually ON SCHEDULE for the UDP 
> > document.
> 
> What's the huge hurry?  Is the publication of the UDP draft 
> so urgent that it 
> can't wait another month or two in order to avoid serious 
> inconsistencies and 
> duplication of content between it and the other forthcoming 
> documents this WG 
> produces?  The world has waited for many years already for 
> the IETF to 
> produce documents on NAT; is this task now suddenly so urgent 
> that the world 
> can't even wait a couple more months in order to ensure that the NAT 
> documents the IETF produces are actually solid, well-organized, and 
> consistent with each other?
> 
> Besides, the proposed BEHAVE-GEN draft is already written and 
> has been under 
> evaluation and discussion for some time already too.  There's 
> no reason to 
> assume that linking BEHAVE-UDP with BEHAVE-GEN will cause all 
> that much 
> delay: BEHAVE-GEN, after all, mostly just contains stuff 
> that's in BEHAVE-UDP 
> but is needed for BEHAVE-TCP too.  If you have objections to 
> specific content 
> in BEHAVE-GEN, then let's fix it and get both drafts 
> published as quickly as 
> possible.
> 
> Cheers,
> Bryan
> 
> >
> > > -----Original Message-----
> > > From: ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx
> > > [mailto:ietf-behave-bounces@xxxxxxxxxxxxxxxxxxx] On 
> Behalf Of Pyda 
> > > Srisuresh
> > > Sent: Thursday, May 12, 2005 07:11
> > > To: ietf-behave@xxxxxxxxxxxxxxxxxxx
> > > Subject: Re: [Ietf-behave] WG last call: 
> > > draft-ietf-behave-nat-udp-01.txt
> > >
> > >
> > > Right, I fully agree with Bryan's comments below
> > >
> > > There was no such decision made in the BOF/WG meetings or on the 
> > > list or in private e-mails with Cullen, as far as I can recall. 
> > > Bryan & I had several e-mail exchanges with Francois & Cullen, 
> > > authors of the behave-udp draft. Bryan and I talked about 
> moving out 
> > > non-UDP-specific stuff into a generic recommendation draft durign 
> > > the e-mail discussions and we did a draft on it. 
> Subsequent to that, 
> > > I even requested the WG chairs to slot in the behave-gen 
> draft for 
> > > the WG meeting in Minneapolis. Had I known a decisin was made to 
> > > duplicate all the common material in TCP & UDP drafts or cross 
> > > reference them in some ad hoc way, I would, no doubt, have raised 
> > > this on the list (as I am doing now).
> > >
> > > Here is a request to Jon Peterson, our AD:
> > >
> > > As Bryan says below, I suggest we step back a bit and 
> revise the WG 
> > > milestones. At the formation of the WG, while milestones 
> are being 
> > > created, it probably wasn't obvious that there would be a lot of 
> > > material common to TCP and UDP. Now, it is. I believe, we need to 
> > > include the  behave-gen draft as one of the early on milestones. 
> > > Further, I believe, this is an opportune time to identify all the 
> > > drafts that should be adapted as WG drafts and do an 
> overhaul of the
> > > milestones. Thanks.
> > >
> > > regards,
> > > suresh
> > >
> > > --- Bryan Ford <baford@xxxxxxx> wrote:
> > > > I likewise do not remember any such decision being 
> made, or even 
> > > > discussed on
> > > >
> > > > the list.  If you're referring to some decision made 
> "somewhere up 
> > > > high in the chain of command" at the very formation of 
> this WG, as
> > >
> > > you seem to
> > >
> > > > suggest, then that decision was presumably made before any
> > >
> > > actual text was on
> > >
> > > > the table and before any of the technical issues had been
> > >
> > > explored in
> > >
> > > > depth.
> > > >
> > > > I do remember seeing a bit of discussion long ago of
> > >
> > > whether to have
> > >
> > > > two
> > > > documents (TCP and UDP) or just one big combined document,
> > >
> > > but _nobody_ here
> > >
> > > > is suggesting just one big document at this point.  The
> > >
> > > issue here, now, is
> > >
> > > > whether to split the (very considerable) common portions of
> > >
> > > the TCP and UDP
> > >
> > > > docs out into a common, transport-neutral doc.  The issue
> > >
> > > is not one document
> > >
> > > > versus two, but two documents versus three.
> > > >
> > > > At the formation of the WG, it probably wasn't obvious 
> that there 
> > > > would be a lot of material common to TCP and UDP, because that
> > >
> > > material hadn't been
> > >
> > > > written yet.  Now that it's been written, it's become very
> > >
> > > clear that there
> > >
> > > > is a great deal of common technical requirements, and 
> it would be 
> > > > a structural and readability disaster to duplicate that
> > >
> > > material across the
> > >
> > > > documents or litter them with ad hoc, ambiguous
> > >
> > > cross-references.  Given
> > >
> > > > this, it seems highly appropriate to revisit the original
> > >
> > > decisions on
> > >
> > > > document organization that were made at the formation of the WG.
> > > >
> > > > Cheers,
> > > > Bryan
> > > >
> > > > On Tuesday 10 May 2005 20:28, Cullen Jennings wrote:
> > > > > On 5/9/05 7:22 PM, "Pyda Srisuresh" 
> <srisuresh@xxxxxxxxx> wrote:
> > > > > > <... stuff deleted>
> > > > > >
> > > > > >>>>   The common requirements should be addressed in 
> a seperate 
> > > > > >>>> document, that will make both the TCP and UDP 
> requirements 
> > > > > >>>> concise and should not be interleaved in this UDP
> > >
> > > requirements
> > >
> > > > > >>>> draft.
> > > > > >>>
> > > > > >>> That's one option. Another is to make the two drafts
> > >
> > > parallel,
> > >
> > > > > >>> pointing out where they differ due to specific 
> differences 
> > > > > >>> between UDP and TCP.
> > > > > >>
> > > > > >> Agree. That decision (to have two parrallel drafts)
> > >
> > > was already
> > >
> > > > > >> made
> > > > > >
> > > > > > [suresh] When was this decision made? This was neither 
> > > > > > reviewed nor decided upon on the list.
> > > > >
> > > > > This was discussed on the list before the BOF. It was
> > >
> > > discussed in
> > >
> > > > > the BOF. It was discussed by ADs and reviewed by IAB 
> and IESG in 
> > > > > forming charter. It has been pointed out to you in email
> > >
> > > from me. It
> > >
> > > > > is shown in the milestone section of the Charter page.
> > > > >
> > > > > If there is anything I can do to make it clear I'm glad
> > >
> > > to do it. If
> > >
> > > > > you would like to have another phone call around the
> > >
> > > reasoning that
> > >
> > > > > went into that decision, I am glad to set up a conference
> > >
> > > call for
> > >
> > > > > you and anyone else that cares to join.
> > > > >
> > > > > I'm not sure what else to do.
> > > > >
> > > > > Cullen with my chair hat on.
> > > > >
> > > > > _______________________________________________
> > > > > Ietf-behave mailing list Ietf-behave@xxxxxxxxxxxxxxxxxxx
> > > > > https://list.sipfoundry.org/mailman/listinfo/ietf-behave
> > >
> > > _______________________________________________
> > > Ietf-behave mailing list
> > > Ietf-behave@xxxxxxxxxxxxxxxxxxx 
> > > https://list.sipfoundry.org/mailman/listinfo/ietf-behave
> 
>

---

From: Bryan Ford <[email-masked]>
Date: Thu, 12 May 2005 13:05:52 -0700 (PDT)

> ahead with separate documents.

Are you even LISTENING???  Nobody is proposing to reverse the decision to 
separate the TCP and UDP documents.  Nobody is proposing to "reverse" any 
earlier decision at all.  We're basically just proposing to generalize the 
existing Nov 05 "ICMP" milestone into a "transport-independent behavior" 
milestone, and bring it forward in the schedule to go alongside the UDP 
draft.  For example, here's one way we might do it:

-May 05         Produce a BCP that defines unicast UDP behavioral requirements
+Jun 05         Produce a BCP that defines unicast UDP behavioral requirements
+Jun 05         Produce a BCP that defines transport protocol-independent 
behavioral requirements
 Jul 05         Any revisions to STUN required by other WG deliverables
 Sep 05         Produce a BCP that defines TCP behavioral requirements for NATs
-Nov 05         Produce a BCP that defines basic ICMP behavioral requirements

Note that I'm not proposing any change to the TCP milestone, and in particular 
am not proposing that the TCP and UDP documents be linked.

So far you have offered no argument whatsoever as to why a minor change of the 
above form to the WG milestones, accompanied with a simple but much-needed 
document reorganization, would be a bad idea.  I and others on the list have 
offered plenty of reasons why it would be a good idea: organizational 
coherence, consistency, minimizing redundancy.  All you seem to offer is the 
statement that you have "strong objections."  Do you actually have ANY 
rational objections at all, other than sheer conservatism, or perhaps a blind 
passion to get your pet document published as quickly as possible regardless 
of the needs of the situation?  Doggedly thumping on the original WG charter 
as if it were the Ten Commandments, and refusing to contemplate even the 
slightest change in the interest of producing good specifications, is not a 
viable way to produce good specifications or to benefit the Internet 
community.

Bryan