Subject: [BEHAVE] STUN message type field

From: "Kevin Johns" <[email-masked]>
Date: Thu, 16 Nov 2006 17:02:31 -0700

Hi,
 
In looking at the STUN header, I am a bit confused by the STUN message
type field. There are two M2 entries (should one be a M1?) and there is
a C0 and C1 intermixed. I was wondering why the field is formatted this
way, it seems one would want to group common field together (i.e. C0 and
C1 would be next to each other) rather then spread them about?
 
Thanks
Kevin

~~~~~~~~~~~~~~~~~~~~~~
Kevin C. Johns
Project Director - PacketCable Communications Protocols
CableLabs(r)
858 Coal Creek Circle
Louisville, CO 80027-9750
Phone:  303.661.9100
Direct: 303.661.3303
HTTP://www.CableLabs.com <http://www.cablelabs.com/>  

_______________________________________________
Behave mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/behave

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 16 Nov 2006 17:10:08 -0800

> C1 would be next to each other) rather then spread them about?

This is for compability with RFC 3489.  If I remember well, it was
decided in the BEHAVE session to add some text to explain that.