Subject: [BEHAVE] STUN -> Session Traversal Underneath NAT

From: "Pete Cordell" <[email-masked]>
Date: Tue, 28 Nov 2006 17:53:24 -0000

I jested before, but the more I think about it, the more I find the 'simple' 
in the STUN name irksome.

STUN now is really (potentially) STUN + TURN of old.  I don't see how that 
combination can be called simple.  Granted, it's not hugely complex, but it 
is not HTTP 0.9 either!  Between the two of them there are 14 different 
types of message and 24 different attributes.

Further, STUN on it's own isn't much good.  In reality the STUN base specs 
are just the message definitions, whereas ICE is how to use those messages. 
Together there is 185 pages of documentation, which I don't consider to be 
simple.  (SIP is 269 pages and I don't think we can argue that is simple. 
Thus STUN + usage is of comparable complexity; to document at least.)

But the thing I hate most about it though is the marketing spin feel of it! 
Use this and your teeth will be whiter than white and it won't cost you a 
penny!

Actually, I think the word 'simple' should be avoided in all acronyms as a 
matter of policy.  Even if something starts out simple, if it's useful it 
gets added to and evolves into something that is no longer simple.  Is SMTP 
still simple?

Thus, I put to the floor that the acronym for STUN should expand to:

    Session Traversal Underneath NAT,

and further request that statements such as "STUN is a simple ... protocol" 
be removed from the spec.  (Just use "STUN is a ... protocol").

Pete.
--
=============================================
Pete Cordell
Tech-Know-Ware Ltd
for XML to C++ data binding visit
http://www.tech-know-ware.com/lmx
(or http://www.xml2cpp.com)
=============================================

_______________________________________________
Behave mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/behave

---

From: Philip Matthews <[email-masked]>
Date: Wed, 29 Nov 2006 15:36:01 -0500

If we are going to do this, then I would prefer "Session Traversal  
through NAT".
I don't see how "underneath" is really appropriate either.
No one talks about sending a packet or a media session "underneath" a  
NAT.

- Philip

On 28-Nov-06, at 12:53 , Pete Cordell wrote:

> I jested before, but the more I think about it, the more I find the  
> 'simple' in the STUN name irksome.
>
> STUN now is really (potentially) STUN + TURN of old.  I don't see  
> how that combination can be called simple.  Granted, it's not  
> hugely complex, but it is not HTTP 0.9 either!  Between the two of  
> them there are 14 different types of message and 24 different  
> attributes.
>
> Further, STUN on it's own isn't much good.  In reality the STUN  
> base specs are just the message definitions, whereas ICE is how to  
> use those messages. Together there is 185 pages of documentation,  
> which I don't consider to be simple.  (SIP is 269 pages and I don't  
> think we can argue that is simple. Thus STUN + usage is of  
> comparable complexity; to document at least.)
>
> But the thing I hate most about it though is the marketing spin  
> feel of it! Use this and your teeth will be whiter than white and  
> it won't cost you a penny!
>
> Actually, I think the word 'simple' should be avoided in all  
> acronyms as a matter of policy.  Even if something starts out  
> simple, if it's useful it gets added to and evolves into something  
> that is no longer simple.  Is SMTP still simple?
>
> and further request that statements such as "STUN is a simple ...  
> protocol" be removed from the spec.  (Just use "STUN is a ...  
> protocol").
>
> Pete.
> --

---

From: "Brian Stucker" <[email-masked]>
Date: Wed, 29 Nov 2006 14:42:23 -0600

Oh! So that's what that little light on the bottom of my home NAT/router
is there for. :)

I was beginning to think I had been holding that picture of the OSI
model upside down all these years.

Regards,
Brian 

> -----Original Message-----
> From: Philip Matthews [mailto:[email-masked]] 
> Sent: Wednesday, November 29, 2006 2:36 PM
> To: Pete Cordell
> Cc: [email-masked]
> Subject: Re: [BEHAVE] STUN -> Session Traversal Underneath NAT
> 
> If we are going to do this, then I would prefer "Session 
> Traversal through NAT".
> No one talks about sending a packet or a media session 
> "underneath" a NAT.
> 
> - Philip
> 
> > STUN now is really (potentially) STUN + TURN of old.  I 
> don't see how 
> > that combination can be called simple.  Granted, it's not hugely 
> > complex, but it is not HTTP 0.9 either!  Between the two of 
> them there 
> > are 14 different types of message and 24 different attributes.
> >
> > Further, STUN on it's own isn't much good.  In reality the 
> STUN base 
> > specs are just the message definitions, whereas ICE is how to use 
> > those messages. Together there is 185 pages of 
> documentation, which I 
> > don't consider to be simple.  (SIP is 269 pages and I don't 
> think we 
> > can argue that is simple. Thus STUN + usage is of comparable 
> > complexity; to document at least.)
> >
> > But the thing I hate most about it though is the marketing 
> spin feel 
> > of it! Use this and your teeth will be whiter than white 
> and it won't 
> > cost you a penny!
> >
> > Actually, I think the word 'simple' should be avoided in 
> all acronyms 
> > as a matter of policy.  Even if something starts out 
> simple, if it's 
> > useful it gets added to and evolves into something that is 
> no longer 
> > simple.  Is SMTP still simple?
> >

---

From: Hisham Khartabil <[email-masked]>
Date: Thu, 30 Nov 2006 11:23:11 +0100

Session Traversal for Users of NAT
Session Traversal through Ubiquitous NATs

For the S, you can also use Sophisticated or Smooth, but maybe not 
Simple ;)

Hisham

On Nov 29, 2006, at 9:36 PM, Philip Matthews wrote:

>> STUN now is really (potentially) STUN + TURN of old.  I don't see how 
>> complex, but it is not HTTP 0.9 either!  Between the two of them 
>> there are 14 different types of message and 24 different attributes.
>>
>> Further, STUN on it's own isn't much good.  In reality the STUN base 
>> those messages. Together there is 185 pages of documentation, which I 
>> don't consider to be simple.  (SIP is 269 pages and I don't think we 
>> But the thing I hate most about it though is the marketing spin feel 
>> of it! Use this and your teeth will be whiter than white and it won't 
>> cost you a penny!
>>
>> Actually, I think the word 'simple' should be avoided in all acronyms 
>> as a matter of policy.  Even if something starts out simple, if it's 
>> useful it gets added to and evolves into something that is no longer

---

From: "Pete Cordell" <[email-masked]>
Date: Thu, 30 Nov 2006 11:59:26 -0000

I agree it needs to be a U word.  I went through my dictionary and came up 
with the following (in rough order of preference):

Session Traversal Unblocking NAT
Session Traversal Understanding NAT
Session Traversal Using NAT
Session Traversal Uniting NAT
Session Traversal Untangling NAT

I would also be OK with Underneath.  Not great, but kinda works!

If you feel like going with the Session Traversal through ??? NATs route, 
there are various derogatory terms that start with U, such as: Session 
Traversal through Unholy NATs!

Pete.
--
----- Original Message ----- 
From: "Hisham Khartabil" <[email-masked]>
To: "Philip Matthews" <[email-masked]>
Cc: "Pete Cordell" <[email-masked]>; <[email-masked]>
Sent: Thursday, November 30, 2006 10:23 AM
Subject: Re: [BEHAVE] STUN -> Session Traversal Underneath NAT

> For the S, you can also use Sophisticated or Smooth, but maybe not Simple 
> ;)
>
> Hisham
>
>>> complex, but it is not HTTP 0.9 either!  Between the two of them there 
>>> specs are just the message definitions, whereas ICE is how to use those 
>>> messages. Together there is 185 pages of documentation, which I don't 
>>> consider to be simple.  (SIP is 269 pages and I don't think we can argue 
>>> that is simple. Thus STUN + usage is of comparable complexity; to 
>>> document at least.)
>>>
>>> But the thing I hate most about it though is the marketing spin feel of 
>>> it! Use this and your teeth will be whiter than white and it won't cost 
>>> you a penny!
>>>
>>> Actually, I think the word 'simple' should be avoided in all acronyms as 
>>> a matter of policy.  Even if something starts out simple, if it's useful 
>>> it gets added to and evolves into something that is no longer simple. 
>>> Is SMTP still simple?
>>>

---

From: Christian Huitema <[email-masked]>
Date: Thu, 30 Nov 2006 10:44:09 -0800

"Session Traversal Uncorking NAT"...

> From: Pete Cordell [mailto:[email-masked]]
> Sent: Thursday, November 30, 2006 3:59 AM
> To: Hisham Khartabil; Philip Matthews
> Cc: [email-masked]
> I agree it needs to be a U word.  I went through my dictionary and
came
> up
> Simple
> how
> there
> base
> those
> feel of
> acronyms as

---

From: "Francois Audet" <[email-masked]>
Date: Thu, 30 Nov 2006 12:58:00 -0600

When you think about it, it's not even for NAT traversal anymore (that
would be ICE).

It's more a set of generic tools for NAT support.

STUN: Set of Tools Useful for NAT
      ^      ^     ^          ^

Cheers.

> From: Christian Huitema [mailto:[email-masked]] 
> Sent: Thursday, November 30, 2006 10:44
> To: Pete Cordell; Hisham Khartabil; Philip Matthews
> Cc: [email-masked]
> Subject: RE: [BEHAVE] STUN -> Session Traversal Underneath NAT
> 
> > If you feel like going with the Session Traversal through ??? NATs 
> > route, there are various derogatory terms that start with 
> U, such as: 
> > Session Traversal through Unholy NATs!
> > 
> > Pete.
> > --
> Traversal 
> "underneath"
> > a
> don't see
> > >>> consider to be simple.  (SIP is 269 pages and I don't 
> think we can
> > argue
> > >>> it! Use this and your teeth will be whiter than white 
> and it won't
> > cost
> > >>> you a penny!
> > >>>
> > >>> a matter of policy.  Even if something starts out 
> simple, if it's
> > useful

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 30 Nov 2006 13:15:42 -0600

Agree with Francois here. This would be a lot less confusing than having two 
specs come out for NAT traversal at the same time...

Spencer

----- Original Message ----- 
From: "Francois Audet" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, November 30, 2006 12:58 PM
Subject: RE: [BEHAVE] STUN -> Session Traversal Underneath NAT

Cheers.

---

From: Philip Matthews <[email-masked]>
Date: Thu, 30 Nov 2006 17:37:02 -0500

I also agree with Francois and Spencer.
Though I will suggest that
"Set of Tools Useful for NAT traversal (STUN)" would be more accurate.

And there is a history of not always having the acronym correspond  
directly
to the first letter of each work. Consider, for example, RSVP  
(Resource Reservation Protocol).
I am sure folks can come up with other examples.

- Philip

On 30-Nov-06, at 14:15 , Spencer Dawkins wrote:

> Agree with Francois here. This would be a lot less confusing than  
> having two specs come out for NAT traversal at the same time...
>
> Spencer
>
> ----- Original Message ----- From: "Francois Audet" <[email-masked]>
> To: <[email-masked]>

---

From: "Francois Audet" <[email-masked]>
Date: Thu, 30 Nov 2006 16:47:26 -0600

Yes agreed.

In fact, the worst names we come up with is when we try to match an
acronym.
For example, "Behavior Engineering for Hindrance Avoidance"...

> Sent: Thursday, November 30, 2006 14:37
> To: Spencer Dawkins; Audet, Francois (SC100:3055); Pete Cordell
> Cc: [email-masked]
> And there is a history of not always having the acronym 
> correspond directly to the first letter of each work. 
> Consider, for example, RSVP (Resource Reservation Protocol).

---

From: Philip Matthews <[email-masked]>
Date: Thu, 30 Nov 2006 21:32:03 -0500

Perhaps even more accurate would be
"Set of Tools and Usages for NAT traversal".

- Philip