Subject: RE: [BEHAVE] Review of rfc3489bis-05 up to section 8

From: "Brian Stucker" <[email-masked]>
Date: Fri, 1 Dec 2006 20:15:28 -0600

What if the TCP connection was established, but closed between the time
a STUN request was sent out, and a response came back in? Failure? Seems
like it would have to be, but what would the client be expected to do?

Regards,
Brian

> -----Original Message-----
> From: Saikat Guha [mailto:[email-masked]] 
> Sent: Wednesday, November 29, 2006 8:26 PM
> To: Dan Wing
> Cc: Stucker, Brian (RICH1:AR00); 'Jonathan Rosenberg'; 
> [email-masked]; [email-masked]
> Subject: RE: [BEHAVE] Review of rfc3489bis-05 up to section 8
> 
> On Wed, 2006-11-29 at 17:07 -0800, Dan Wing wrote:
> > I expect that would interact poorly with TCP simultaneous-open.  
> > Saikat, any thoughts?
> >
> > > -----Original Message-----
> > > From: Brian Stucker [mailto:[email-masked]]
> > > 
> > >  One other thought on section 7.1... The current text states that 
> > > transport failures (ICMP errors) for UDP should be considered 
> > > failures.
> > > What about other transport failures? Does a TCP connection reset 
> > > constitute a failure of the STUN transaction?
> 
> If an app is trying TCP S-O and *only* TCP S-O, then RSTs can 
> be annoying, but apps should be doing both regular 
> connections and S-O in parallel as per ICE.
> 
> If an endpoint gets an RST while trying to STUN the other 
> end, then packets must be getting through to the other end 
> (BEHAVE compliant NATs are not supposed to RST new 
> connections). In those cases, the regular connection should 
> work (i.e. local LAN or already-punched NAT).
> 
> --
> Saikat
> 

_______________________________________________
Behave mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/behave

---

From: Saikat Guha <[email-masked]>
Date: Mon, 04 Dec 2006 08:29:13 -0500

> like it would have to be, but what would the client be expected to do?

Normally the OS would not report a failure on the write() call if the
socket went away before the request would be written. (Actually, it
would signal EPIPE and kill the process normally) I believe.