Subject: [BEHAVE] Re: [Ietf-behave] turn02 REQUESTED-TRANSPORT

From: "Rohan Mahy" <[email-masked]>
Date: Mon, 4 Dec 2006 10:24:53 -0800

Hi,

My concern about using the IANA protocol registry is that it implies
that any protocol in that registry is usable, which is certainly not
the case. Also, TURN would not establish a registry of these values,
since defining a new transport would require a significant body of
normative text that the community would be unlikely to overlook.

thanks,
-rohan

On 10/15/06, Lars Eggert <[email-masked]> wrote:
> On Oct 16, 2006, at 1:15, Alfred E. Heggestad wrote:
> > Instead of defining two new values for UDP/TCP transport can we reuse
> > e.g. the values defined in netinet/in.h:
>
> These are taken from the IANA registry for protocol numbers (http://
> www.iana.org/assignments/protocol-numbers), and I agree that using
> those numbers would be better than creating a new registry.
>
> Lars
> --
> Lars Eggert                                     NEC Network Laboratories
>
>
> _______________________________________________
> Ietf-behave mailing list
> [email-masked]
> https://list.sipfoundry.org/mailman/listinfo/ietf-behave
>

_______________________________________________
Behave mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/behave

---

From: Lars Eggert <[email-masked]>
Date: Fri, 15 Dec 2006 11:39:48 +0100

Rohan,

> normative text that the community would be unlikely to overlook.

the suggestion wasn't to allow the entire IANA registry here, it was  
that the numeric values of the allowed protocols should be the ones  
used in the IANA registry.

Lars