Subject: Re: [BEHAVE] STUN -> Session Traversal Underneath NAT

From: "Pete Cordell" <[email-masked]>
Date: Fri, 1 Dec 2006 17:59:03 -0000

I'm happy with this, although technically the acronym would be STUNT, which 
may not project the right image.

A compromise of all the suggestions so far could be:

    Set of Tools for Uncorking NATs

My only reservation with that is it makes NATs sound like fine wine which 
doesn't seem right!

On the other hand,

    Set of Tools for Unblocking NATs

makes NATs sound more like drains, which may be more appropriate!

Maybe if we want to toss around a few more ideas we can do it off-list, and 
come back when we've got a candidate.

Pete.
----- Original Message ----- 
From: "Philip Matthews" <[email-masked]>
To: "Francois Audet" <[email-masked]>
Cc: "Spencer Dawkins" <[email-masked]>; "Pete Cordell" 
<[email-masked]>; <[email-masked]>
Sent: Friday, December 01, 2006 2:32 AM
Subject: Re: [BEHAVE] STUN -> Session Traversal Underneath NAT

> Perhaps even more accurate would be
> "Set of Tools and Usages for NAT traversal".
>
> - Philip
>
>
> On 30-Nov-06, at 17:47 , Francois Audet wrote:
>
>> Yes agreed.
>>
>> In fact, the worst names we come up with is when we try to match an
>> acronym.
>> For example, "Behavior Engineering for Hindrance Avoidance"...
>>
>>> -----Original Message-----
>>> From: Philip Matthews [mailto:[email-masked]]
>>> Sent: Thursday, November 30, 2006 14:37
>>> To: Spencer Dawkins; Audet, Francois (SC100:3055); Pete Cordell
>>> Cc: [email-masked]
>>> Subject: Re: [BEHAVE] STUN -> Session Traversal Underneath NAT
>>>
>>> I also agree with Francois and Spencer.
>>> Though I will suggest that
>>> "Set of Tools Useful for NAT traversal (STUN)" would be more  accurate.
>>>
>>> And there is a history of not always having the acronym
>>> correspond directly to the first letter of each work.
>>> Consider, for example, RSVP (Resource Reservation Protocol).
>>> I am sure folks can come up with other examples.
>>>
>>> - Philip
>>>
>>>
>>> On 30-Nov-06, at 14:15 , Spencer Dawkins wrote:
>>>
>>>> Agree with Francois here. This would be a lot less confusing than
>>>> having two specs come out for NAT traversal at the same time...
>>>>
>>>> Spencer
>>>>
>>>> ----- Original Message ----- From: "Francois Audet"
>>> <[email-masked]>
>>>> To: <[email-masked]>
>>>> Sent: Thursday, November 30, 2006 12:58 PM
>>>> Subject: RE: [BEHAVE] STUN -> Session Traversal Underneath NAT
>>>>
>>>>
>>>> When you think about it, it's not even for NAT traversal
>>> anymore (that
>>>> would be ICE).
>>>>
>>>> It's more a set of generic tools for NAT support.
>>>>
>>>> STUN: Set of Tools Useful for NAT
>>>>      ^      ^     ^          ^
>>>>
>>>> Cheers.
>>>>
--
=============================================
Pete Cordell
Tech-Know-Ware Ltd
for XML to C++ data binding visit
http://www.tech-know-ware.com/lmx
(or http://www.xml2cpp.com)
=============================================

_______________________________________________
Behave mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/behave

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 01 Dec 2006 17:00:52 -0500

Ahhh. Nothing brings out opinions like a naming debate.

I think Francois got it right. I'd prefer "STUN: Set of Tools Useful for 
NAT". I like semi-derogatory things like Uncorking and Unblocking more 
for working group names (which is an IETF insider thing) and not 
protocol names (which are read by everyone).

-Jonathan R.

Pete Cordell wrote:

> I'm happy with this, although technically the acronym would be STUNT, 
> which may not project the right image.
> 
> My only reservation with that is it makes NATs sound like fine wine 
> which doesn't seem right!
> 
> On the other hand,
> 
> Maybe if we want to toss around a few more ideas we can do it off-list, 
> and come back when we've got a candidate.
> 
> Pete.
> ----- Original Message ----- From: "Philip Matthews" 
> <[email-masked]>

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: "Francois Audet" <[email-masked]>
Date: Fri, 1 Dec 2006 16:09:55 -0600

Thanks.

By the way, I got the idea by reading the Abstract which pretty much
says exactly that. 

> From: Jonathan Rosenberg [mailto:[email-masked]] 
> Sent: Friday, December 01, 2006 14:01
> To: Pete Cordell
> Cc: Philip Matthews; Audet, Francois (SC100:3055); 
> [email-masked]
> I think Francois got it right. I'd prefer "STUN: Set of Tools 
> Useful for NAT". I like semi-derogatory things like Uncorking 
> and Unblocking more for working group names (which is an IETF 
> insider thing) and not protocol names (which are read by everyone).

---

From: "Pete Cordell" <[email-masked]>
Date: Fri, 1 Dec 2006 22:42:47 -0000

Excellent.  All sorted.

Pete.
----- Original Message ----- 
From: "Francois Audet" <[email-masked]>
To: "Jonathan Rosenberg" <[email-masked]>; "Pete Cordell" 
<[email-masked]>
Cc: "Philip Matthews" <[email-masked]>; 
<[email-masked]>
Sent: Friday, December 01, 2006 10:09 PM
Subject: RE: [BEHAVE] STUN -> Session Traversal Underneath NAT

Thanks.