Subject: [BEHAVE] [TURN] Response to a bad Send Indication

From: Simon Perreault <[email-masked]>
Date: Mon, 28 Apr 2008 14:18:36 -0400

Hello,

From [draft-ietf-behave-turn-07], Section 9.2:

   The resulting UDP datagram is then sent to the peer.  If any errors
   are detected during this process (e.g., the Send indication does not
   contain a PEER-ADDRESS attribute), the received indication is
   silently discarded and no UDP datagram is sent.

Wouldn't it be better to send a 400 Bad Request to the client instead?

Thanks,
Simon
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: Simon Perreault <[email-masked]>
Date: Mon, 28 Apr 2008 15:16:13 -0400

> Wouldn't it be better to send a 400 Bad Request to the client instead?

I just realized that this is an Indication and as such never receives any 
response.

Nothing to see here, move along...
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave