Subject: Re: [BEHAVE] Consensus call on Adding "Client" attribute to STUN

From: Rémi Denis-Courmont <[email-masked]>
Date: Fri, 2 May 2008 15:06:12 +0300

Dan,

I think I'll wait for the conclusion of this before I update the test vectors. 
I can see it coming that people will ask for a CLIENT attribute there.

Is that OK?

Le Thursday 24 April 2008 20:31:25 ext Magnus Westerlund, vous avez écrit :
> This is a one week+ consensus call (until the 5th of May) if the WG
> thinks that STUN (draft-ietf-behave-rfc3489bis) shall be extended with
> an additional attribute "Client" before publication.
>
> With the general description along the lines of:
>
>     X.Y CLIENT
>
>     The client attribute contains a textual description of the software
>     being used by the client, including manufacturer and version number.
>     The attribute has no impact on operation of the protocol, and serves
>     only as a tool for diagnostic and debugging purposes.  The value of
>     CLIENT is variable length.  It MUST be a UTF-8 [RFC3629] encoded
>     sequence of less than 128 characters (which can be as long as 763
>     bytes).
>
> And some Security Considerations on the risk for targeted attacks
> against clients with this information. Plus other text needed to bring
> it in consistently
>
> The text is open for wordsmithing by the editors of the STUN spec.
>
> Please indicate your position on adding this or not.
>
> Cheers
>
> Magnus Westerlund
>
> IETF Transport Area Director & TSVWG Chair
> ----------------------------------------------------------------------
> Multimedia Technologies, Ericsson Research EAB/TVM
> ----------------------------------------------------------------------
> Ericsson AB                | Phone +46 8 4048287
> Färögatan 6                | Fax   +46 8 7575550
> S-164 80 Stockholm, Sweden | mailto: [email-masked]
> ----------------------------------------------------------------------
>
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave

-- 
Rémi Denis-Courmont
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: "Dan Wing" <[email-masked]>
Date: Fri, 2 May 2008 08:52:44 -0700

As chair: fine by me.  I was hoping more people would comment for/against
Magnus's consensus call. 

As an individual and co-author of rfc3489bis:  I support adding the new CLIENT
attribute.

-d

> -----Original Message-----
> From: Rémi Denis-Courmont [mailto:[email-masked]] 
> Sent: Friday, May 02, 2008 5:06 AM
> To: Dan Wing
> Cc: [email-masked]
> Subject: Re: [BEHAVE] Consensus call on Adding "Client" 
> attribute to STUN
> 
> 
> 	Dan,
>

---

From: Philip Matthews <[email-masked]>
Date: Mon, 5 May 2008 16:50:12 -0400

I have no problem with adding this attribute.
- Philip

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 12 May 2008 18:23:53 +0200

Hi,

I got all Yes, go for it and no against so I rule there to be consensus 
to add this attribute. Authors, please go ahead and add it.

Cheers

Magnus

-- 

Magnus Westerlund

---

From: Rémi Denis-Courmont <[email-masked]>
Date: Wed, 21 May 2008 13:49:42 +0300

> to add this attribute. Authors, please go ahead and add it.

By the way, which attribute number is to be requested for this? I'll update 
the test vectors when that's settled.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 21 May 2008 23:41:14 -0400

I'm about to start making edits. Once I put it in I'll post. FWIW, I 
also support this change.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   499 Thornall St.
Cisco Fellow                                   Edison, NJ 08837
Cisco, Voice Technology Group
[email-masked]
http://www.jdrosen.net                         PHONE: (408) 902-3084
http://www.cisco.com
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave