Subject: Re: [BEHAVE] Determining NAT Filtering Behavior

From: "Derek MacDonald" <[email-masked]>
Date: Sun, 15 Jun 2008 14:48:40 -0700

So, my take-away from this is that nothing needs to be changed?

On Fri, Mar 21, 2008 at 10:08 AM, Dan Wing <[email-masked]> wrote:

>
> > > draft-ietf-behave-rfc3489bis-15, bottom of page 6:
> > >
> > >   For request/response transactions, this transaction ID allows
> > >   the client to associate the response with the request that
> > >   generated it; for indications, this serves as a debugging aid.
> > >
> >
> > so what you are saying is that, by default, the STUN Client
> > does not check the source address of the STUN Response.
>
> I didn't see text in rfc3489bis that said the port of the response
> needed to be checked.  I believe behavior-discovery needs to
> send response packets from different ports and from different
> IP addresses in order to do some of its checks.
>
> > But it can be overridden by the usage, like e.g. ICE:
> >
> >
> >
> > 7.1.2.2.  Success Cases
> >
> >    A check is considered to be a success if all of the following are
> >    true:
> >
> >    o  the STUN transaction generated a success response
> >
> >    o  the source IP address and port of the response equals the
> >       destination IP address and port that the Binding
> > Request was sent
> >       to
> >
> >    o  the destination IP address and port of the response match the
> >       source IP address and port that the Binding Request was
> > sent from
>
> Right.
>
> > Is is specified in the TURN-07 draft that the TURN client should check
> > the source address of any STUN Response, btw?
>
> I don't believe so.
>
> But, considering that TURN is most often used when the TURN client
> is behind a 'symmetric' NAT, the TURN server needs to be very careful
> and send the STUN Response using the source IP address of the STUN
> request.  Otherwise, the TURN server's response will not get through
> the symmetric NAT at all.
>
> -d
>
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: "Dan Wing" <[email-masked]>
Date: Sun, 15 Jun 2008 19:26:34 -0700

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Derek MacDonald
> Sent: Sunday, June 15, 2008 2:49 PM
> To: Dan Wing
> Cc: Alfred E. Heggestad; Behave WG; Philip Matthews
> Subject: Re: [BEHAVE] Determining NAT Filtering Behavior
> 

That is my summary, yes.

-d