Subject: [BEHAVE] comment on draft-ietf-behave-stun-test-vectors-03

From: "Alfred E. Heggestad" <[email-masked]>
Date: Mon, 28 Jul 2008 09:50:09 +0200

Hi

I have a small comment to draft-ietf-behave-stun-test-vectors-03

some example messages are using padding, but the padding value
is not the same in all examples.

for example, in section 2.1 the USERNAME attribute has 2
padding bytes set to 0x20. the same with SOFTWARE attribute
in section 2.2 and 2.3

the USERNAME attribute in section 2.4 (Sample request with long-term authentication)
is using a padding value of 0x00

while this is perfectly valid, I guess most STUN library implementations
will use a fixed value for padding (most likely 0x00). I dont see that
there is any use in letting the application choose the padding value
per message.

so I suggest that we stick to padding 0x00 in all example messages

/alfred
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: Rémi Denis-Courmont <[email-masked]>
Date: Mon, 28 Jul 2008 11:13:06 +0300

> is not the same in all examples.

I disagree here. Test vectors are about testing *parsers*, not about forcing 
implementors to *format* messages in exactly the same manner.

I purposedly used 0x20 as padding to break parsers that assume nul-padding 
(not unlikely error with C code). Same presumptive comment about the lack of 
SOFTWARE name in one of the vectors.

-- 
Rémi Denis-Courmont
Maemo Software, Nokia Devices R&D
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: "Alfred E. Heggestad" <[email-masked]>
Date: Tue, 29 Jul 2008 09:26:00 +0200

> SOFTWARE name in one of the vectors.

OK, I see your point. A agree with you and withdraw my comment..

/alfred