Subject: [BEHAVE] FW: translator friendly DNS Proxy

From: "Dan Wing" <[email-masked]>
Date: Thu, 7 Aug 2008 10:41:47 -0700

This draft is probably of interest to Behave.

-d

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Thursday, August 07, 2008 1:35 AM
To: [email-masked]
Subject: translator friendly DNS Proxy

Hi, all

I submitted this document.

In this document, I proposed DNS proxy that is separated from NAT-PT.
This document describes about relationship DNS proxy and sNATPT[1].
I think that this DNS proxy can collabolate with other translation
technologies.

I know that this working group isn't appropriate to discuss such kind items,
but I informed this document bacause many people that are interested in
subscribed this mailing list.
And, if there is more suitable working group to discuss it, please tell me
that.

[1] sNATPT: Miyata, H., "Simplified Network Address Translation - Protocol
Translation"
                   draft-miyata-v6ops-snatpt-00

Thanks your comments.
Best Regards,

--------------------------
A new version of I-D, draft-endo-v6ops-dnsproxy-00.txt has been successfuly
submitted by Masahito Endo and posted to the IETF repository.

Filename:        draft-endo-v6ops-dnsproxy
Revision:        00
Title:           Translator Friendly DNS Proxy
Creation_date:   2008-08-07
WG ID:           Independent Submission
Number_of_pages: 24

Abstract:
This document describes the DNS Proxy that is separated from NAT-PT [RFC2766].
NAT-PT was designed to work with DNS Application Level Gateway.  However
[RFC4966] pointed out DNS related issues, and [RFC2766] was changed to
historical state.  This document attempts to DNS Proxy specification, removing
dependency on NAT-PT as well as resolving problems pointed in [RFC4966].

// masaxmasa

_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: <[email-masked]>
Date: Fri, 8 Aug 2008 11:14:56 +0900

Thanks Dan,

These two documents are described to resolve original NAT-PT specification
by separating translator and DNS proxy roll clearly.

        draft-miyata-v6ops-snatpt
        draft-endo-v6ops-dnsproxy

The relationship between above two functions looks like totd and TRT.
(Actually, the snapt works on IP layer)
Once we can make them simple, we can assemble each functions
to adopt any user's requirement.

Thanks for your comments!

------------------------------------
Hiroshi Miyata
Network & Software Development Dept.
Yokogawa Electric Corp.

-----Original Message-----
From: Dan Wing [mailto:[email-masked]]
Sent: Friday, August 08, 2008 2:42 AM
To: 'Behave WG'
Cc: Endou, Masahito ([email-masked]); Miyata, Hiroshi ([email-masked])
Subject: FW: translator friendly DNS Proxy

-d

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, August 07, 2008 1:35 AM
To: [email-masked]
Subject: translator friendly DNS Proxy

Hi, all

In this document, I proposed DNS proxy that is separated from NAT-PT.
This document describes about relationship DNS proxy and sNATPT[1].
I think that this DNS proxy can collabolate with other translation technologies.

I know that this working group isn't appropriate to discuss such kind items, but I informed this document bacause many people that are interested in subscribed this mailing list.
And, if there is more suitable working group to discuss it, please tell me that.

[1] sNATPT: Miyata, H., "Simplified Network Address Translation - Protocol Translation"
                   draft-miyata-v6ops-snatpt-00

Thanks your comments.
Best Regards,

--------------------------
A new version of I-D, draft-endo-v6ops-dnsproxy-00.txt has been successfuly submitted by Masahito Endo and posted to the IETF repository.

Abstract:
This document describes the DNS Proxy that is separated from NAT-PT [RFC2766].
NAT-PT was designed to work with DNS Application Level Gateway.  However [RFC4966] pointed out DNS related issues, and [RFC2766] was changed to historical state.  This document attempts to DNS Proxy specification, removing dependency on NAT-PT as well as resolving problems pointed in [RFC4966].

// masaxmasa