Subject: [BEHAVE] Reason behind using interface's ipv4 address

From: "Nirav Shah (nirashah)" <[email-masked]>
Date: Wed, 13 Aug 2008 15:43:37 -0700

Hello Experts,
 
This is my first post to behave draft mailing list and not sure whether
the below question has been already asked before or not.
 
I was going through the Behave draft and have few questions about the
same.
 
    It is mentioned that in nat64, to translate the Ipv6 address to Ipv4
address, you required to use the interface's IPv4 address.
 
   But, by doing this, aren't we limiting ourselves to only 64k flow
entries ? ( we can have more if we assign multiple ip address to same
interface)
 
   In nat-pt we can assign the pool of ipv4 address, so we don't have
this limitation there.
 
   Is there any particular reason behind not having the concept of using
pool for nat64 ?

Thanks,
Nirav Shah.
Software Engineer.
Cisco Systems.

 
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: Rémi Denis-Courmont <[email-masked]>
Date: Thu, 14 Aug 2008 09:08:21 +0300

> entries ? ( we can have more if we assign multiple ip address to same

No. You can have multiple IPv4 addresses assigned to the NAT64 box. However, 
you must always map a given IPv6 client to the same IPv4 address - otherwise 
every second web applications and many protocols will break.

In any case, it is assumed that IPv4 is a restricted resource if you need 
NAT64. Otherwise, using NAT-less dual-stack would be a lot better.

-- 
Rémi Denis-Courmont
Maemo Software, Nokia Devices R&D
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave