Subject: [BEHAVE] Reason behind using interface's ipv4 address

From: "Nirav Shah (nirashah)" <[email-masked]>
Date: Wed, 13 Aug 2008 16:03:09 -0700

Hello Experts,
 
This is my first post to behave draft mailing list and not sure whether
the below question has been already asked before or not.
 
I was going through the Behave draft and have few questions about the
same.
 
    It is mentioned that in nat64, to translate the Ipv6 address to Ipv4
address, you required to use the interface's IPv4 address.
 
   But, by doing this, aren't we limiting ourselves to only 64k flow
entries ? ( we can have more if we assign multiple ip address to same
interface)
 
   In nat-pt we can assign the pool of ipv4 address, so we don't have
this limitation there.
 
   Is there any particular reason behind not having the concept of using
pool for nat64 ?

Thanks,
Nirav Shah.
Software Engineer.
Cisco Systems.
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Thu, 14 Aug 2008 11:53:14 +0200

On 14 aug 2008, at 1:03, Nirav Shah (nirashah) wrote:

>     It is mentioned that in nat64, to translate the Ipv6 address to  
> Ipv4 address, you required to use the interface's IPv4 address.

>     But, by doing this, aren't we limiting ourselves to only 64k  
> flow entries ? ( we can have more if we assign multiple ip address  
> to same interface)

Is there any specific text that requires this limitation?

If so, it should probably be updated. A pool would be appropriate,  
assuming the considerations mentioned by Rémi.